proftpd configuration

Discussion in 'Installation/Configuration' started by irben, Apr 13, 2008.

  1. irben

    irben New Member

    Greetings!

    I've installed Fedora 8 using "The perfect server" article.
    I cannot configure proftpd to access ftp. I've created user test, but it cannot login, although this user can be logged in via ssh.
    I've made some changes in proftpd.conf file but this was useless.
    May be you know some default steps I have to configure or I should show you my config file?
     
  2. irben

    irben New Member

    May be I have to add some permissions to specified user? If so, how can I do it?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    What shell does your FTP user have? Is that shell listed in /etc/shells?
     
  4. irben

    irben New Member

    It would be perfect to access to ftp from Windows machine, cause I need this ftp to access my home files from work and other places and there is no Linux for 99%.
    I cannot connect my ftp even from server, where ftp is running.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Yes, but what shell is your user having? You can find out about the user's shell by looking at /etc/passwd. The shell that is used by that user must be listed in /etc/shells because otherwise the user can't use FTP.
     
  6. irben

    irben New Member

    My user uses bash.
    Is there any real config file which could be an example for me to access ftp.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Did you disable SELinux?
    What's the output of
    Code:
    iptables -L
    ?
     
  8. irben

    irben New Member

    SE Linux is disabled. Firewall too.
    I can enter my credentials, but I've got error. This is my dialog:

    "Connected to irben.id.lv (192.168.1.102).
    220 ProFTPD 1.3.1 Server (Irben FTP server) [::ffff:192.168.1.102]
    Name (irben.id.lv:root): test
    331 Password required for test
    530 Login incorrect.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> exit
    221 Goodbye."

    You can try to connect my ftp with test user and testpass as password.
    What exactly do I have to do to grant new user permission to access ftp?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    So the username is test? What's the output of
    Code:
    grep test /etc/passwd
    ? What's in /etc/shells?
    Did you set a password for the user by running
    Code:
    passwd test
    ?
     
  10. irben

    irben New Member

    Code:
    [root@irben~]# grep test /etc/passwd
    test:x:20001:20001::/home/test:/bin/bash
    Code:
    [root@irben~]# cat /etc/shells
    /bin/sh
    /bin/bash
    /bin/nologin
    /bin/zsh
    /bin/false
    /SENDMAIL/ANY/SHELL/
    Yes, of course. I've told test user's pass is: testpass
     
  11. falko

    falko Super Moderator ISPConfig Developer

  12. irben

    irben New Member

Share This Page