proftpd anonymous login

Discussion in 'Server Operation' started by gabrix, Oct 21, 2006.

  1. gabrix

    gabrix New Member

    On a debian sarge kernel 2.6 i'm using proftpd as anonymous ftp and as anoymous it should let me in any password i give as email address and that's what i get once i login:
    Code:
    Looking up ftp.cacca.cx
    Trying mail.cacca.cx:21
    Connected to ftp.cacca.cx:21
    220 87.3.151.95 FTP server ready
    USER anonymous
    
    331 Anonymous login ok, send your complete email address as your password.
    PASS xxxx
    230-Welcome, archive user [email protected] !
    230-
    230-The local time is: Sat Oct 21 01:51:30 2006
    230-
    230-This is an experimental FTP server.  If have any unusual problems,
    230-please report them via e-mail to <[email protected]>.
    230-
    230 Ciao anonymous.
    SYST
    
    215 UNIX Type: L8
    TYPE I
    
    200 Type set to I
    PWD
    
    257 "/" is current directory.
    Loading directory listing / from server (LC_TIME=en_GB)
    PASV
    
    227 Entering Passive Mode (87,3,151,95,234,251).
    Cannot create a data connection: Connection refused
    Disconnecting from site ftp.gabrix.ath.cx
    I cancelled from /etc/pam.d/proftpd anything refered to pam autentication:I'm using very permissive umask rules on proftpd.conf 011 011 :eek:

    P.S.
    I just used ftp-ssl as client and it logged me in ... i'm using gftp ... i wonder what's wrong in its options....
     
    Last edited: Oct 21, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    You shouldn't have done this.

    Did you try both active and passive transfers in your FTP client?

    What's in /etc/proftpd.conf?

    You mean SFTP? It uses port 22 (SSH) and has nothing to do with normal FTP.
     
  3. gabrix

    gabrix New Member

    It doesn't log me in with any ftp client ... anyway this is my /etc/pam.d/proftpd.conf:
    This is my proftpd.conf:
    I only want anonymous logins and users have an incoming dir where upload files and nothing else and a pub dir where download from and nothing else ... as you see i tried to disable the pam module which is on by default but not mandatory for logins as far as i know so it should let me in even if it's not been loaded :
    And i forgot :it's a debian sarge kernel 2.6.8-2-386 and :
     
    Last edited: Oct 25, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you replace your anonymous FTP configuration with this?
    Code:
            <Anonymous /path/to/ftp>
              User                          ftp
              Group                         nogroup
              UserAlias                     anonymous ftp
              UserAlias                     guest ftp
              MaxClients                    10
              <Directory *>
                <Limit WRITE>
                  DenyAll
                </Limit>
              </Directory>
              <Directory /path/to/ftp/incoming>
                Umask                       002
                <Limit STOR>
                  AllowAll
                </Limit>
                <Limit READ>
                  DenyAll
                </Limit>
              </Directory>
            </Anonymous>
    Make sure you replace /path/to/ftp and that the user ftp and the group nogroup exist.
     
  5. gabrix

    gabrix New Member

    /home/ftp is owned by ftp:nogroup 644 ftp user has noshell in /etc/shells
    I tryied the configuration you gave me and it doesn't let me in as anonymous ,but it does still as normal user,and still ... shows the server vesion .Basically that's the conf i'm actually using:
    I would like incoming dir for uploads and only uploads and a pub where only downloads are allowed
     
    Last edited: Oct 26, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    What do you mean with that?
    What's the output of
    Code:
    grep ftp /etc/passwd
    ?
     
  7. gabrix

    gabrix New Member

    I meant the anonyous chrooted ftp home is owned by the anonymous ftp user ... does it ?
    Anyway i installed wu-ftpd and i got over this ... thanks anyway !
     
  8. gabrix

    gabrix New Member

    i think it is just a gftp problem if proftpd is not accepting connections :
    With ftp instead everything it 's all right , still as normal user:
    and also as anonymous all right:
    What's the problem with gftp ?
    An another thing is proftpd is not writing logs i have this directive in proftpd.conf
    And this an ls -la on /var/log/proftpd.log
    proftpd is running as user nobody and as group nogroup.If something it's not clear just ask ... thanks !
     
    Last edited: Nov 12, 2006
  9. falko

    falko Super Moderator ISPConfig Developer

    I think the log file is /var/log/xferlog.
     
  10. gabrix

    gabrix New Member

    I have to call it xferlog anyway ?Cause i don't have a file that name ...
     
  11. falko

    falko Super Moderator ISPConfig Developer

    I think it's created when you upload/download with FTP for the first time.
     

Share This Page