proftpd and passive mode

Discussion in 'Server Operation' started by bzzik, Nov 6, 2008.

  1. bzzik

    bzzik New Member

    Hey guys!

    Running CentOS 5.2 and ISPConfig 2.2.27 I have problem with passive mode in proftpd. I have opened on my router's firewall ports 50000:50001. I have added line PassivePorts 50000 50001 in my proftpd.conf, but cannot connect to ftp through any browser. With Total Commander no probs - it is connecting fine in active mode and in passive also (dunno how). But browsers do not...

    Where to start troubleshooting?
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs?
  3. bzzik

    bzzik New Member

    Unfortunately I cannot find log file for porftpd. Where should it be?
  4. falko

    falko Super Moderator ISPConfig Developer

    Please check all logs in the /var/log directory.
  5. bzzik

    bzzik New Member

    Only xferlog there, but it shows only successful connections...

    Please note, that I have marked Save Log: in ISPConfig settings.
  6. falko

    falko Super Moderator ISPConfig Developer

    Does it work from inside your LAN?
  7. bzzik

    bzzik New Member

    Nope :confused:

    Do not understand what is going on. I can connect from outside with Total Commander and can connect from localhost, but cannot from LAN... pff

    May be that is because it is on OTHER network. We have 1 router with 2 different networks. I have pure-ftp installed on one machine in network 1 and can not connect there from router. But can not to network 2 to machine with proftpd.
    Last edited: Nov 12, 2008
  8. bzzik

    bzzik New Member

    Was away for some time... And getting back to this problem :( I can connect through LAN.

    It is really anoying, cause my clients cannot access to FTP because of passive do not work :(
    I just tried to connect with filezilla (in active mode) - it is also unsuccessful. It just hangs up on LIST.

    The main and most funny is, that I can easily connect with TOTAL COMMANDER. And there is no probs with it...

    UPDATE: I have successfully logged in with filezilla. After many attempts I found out, that transfer mode should be ASCII (by default it is Auto). But, when I try to change directory it agains hangs on LIST:

    Last edited: Dec 9, 2008
  9. marpada

    marpada New Member

    Take a look at the firewall configuration (/etc/sysconfig/iptables) or ISPConfig firewall if enabled.
    Maine dispensary
    Last edited: May 13, 2011
  10. bzzik

    bzzik New Member

    Firewall is OK. I can connect from LAN also.
  11. bzzik

    bzzik New Member

    I have resolved this issue! A friend of mine help with it. May be this will help others also, so I am posting this very easy solution:

    I am using iptables as firewall. So, to make your ftp working well just enable ip_conntrack_ftp module in iptables! It is located in section 2.2 Non-required modules. Just uncomment it and here we go - woirking ftp and NOTE you do no need passive ports opened! FTP will work well without it even in passive mode!
  12. misterm

    misterm Member HowtoForge Supporter

    How you make in ispconfig 2

    I have the same problems with ispconfig 2.
    For Falko, to you an idea about the concerns I have?
    Thank you for your help
  13. falko

    falko Super Moderator ISPConfig Developer

    Did you check your firewall settings? Did you try both active and passive mode in your FTP client?

Share This Page