proftpd - All files in root again

Discussion in 'Server Operation' started by KenKnight, Oct 6, 2006.

  1. KenKnight

    KenKnight Member

    Hi all,

    A few weeks ago I moved everything to a new server. Same setup, different box.

    Sadly proftpd is acting up again. When I try to use passive mode I get all folders and all files showing up in the root directory of my ftp listing. This is happening with smartFTP and my main web editing package, so it's not just a smartftp problem.

    Here's my conf files;


    ServerName "Debian"
    ServerType standalone
    DeferWelcome off
    DefaultAddress 192.168.10.10
    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks on
    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200
    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    ListOptions "-l"
    DenyFilter \*.*/
    Port 21
    MaxInstances 30
    User nobody
    Group nogroup
    Umask 022 022
    AllowOverwrite on
    IdentLookups off
    ServerIdent on "FTP Server ready."
    Include /etc/proftpd_ispconfig.conf

    ####### ispconfig file ###################
    DefaultAddress 127.0.0.1
    <VirtualHost 192.168.10.10>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    MasqueradeAddress helpconsulting.net
    PassivePorts 40000 40100
    </VirtualHost>


    -----------------------------------------------------------

    Adding the masquerade and passive statements corrected the problems I was having outside the firewall, but I'm not sure what will correct the duplicate listings. I thought that DefaultRoot was supposed to handle that.

    Thanks for any input.

    Cheers!
    Ken
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add
    Code:
    DefaultRoot ~
    to /etc/proftpd.conf (before /etc/proftpd_ispconfig.conf gets included). Restart ProFTPd afterwards.
     
  3. KenKnight

    KenKnight Member

    Thanks Falko, tried that and still same problem. It had actually been in there prior to me posting the config as I moved it to the proftpd_ispconfig file to see if it made any difference. After making the changes I also completely reboot the machine just to make sure (even though I know that shouldn't be necessary).

    Cheers!
    Ken
     
  4. KenKnight

    KenKnight Member

    Hi all,

    If anyone else runs into this (at least with smartftp), there is apparently a default option called "recursive" under the settings section that causes this problem. I unchecked this and it fixed the problem in smartftp.

    Thanks again for the help.

    Cheers!
    Ken
     

Share This Page