ProFTP work but not with ISPconfig

Discussion in 'Installation/Configuration' started by bodi, Sep 23, 2007.

  1. bodi

    bodi New Member

    Hi,

    i installed my Debian Etch exactly like this:
    http://www.howtoforge.com/perfect_setup_debian_etch_p6

    But ISPConfig show, that FTP is down.

    Now I see on the installtion guide, that I have to edit /etc/proftpd/proftpd.conf and write in "UseIPv6 off" but and don't know where. I write it somewhere and I can't restart proftp.

    Without this line I can restart:
    Code:
    /etc/init.d/proftpd restart
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd.
    
    How can I use FTP with ISPConfig?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a line "UseIPv6 on" in the file, you must change this line to "UseIPv6 off".
     
  3. bodi

    bodi New Member


    There is no line with useIPv6!
    I have also searched with "/useIPv6" and I didn't find it.

    What could I do?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/proftpd/proftpd.conf?
     
  5. bodi

    bodi New Member

    Code:
    #
    #	ispCP OMEGA ProFTPd config file
    #
    #
    #
    # Includes required DSO modules. This is mandatory in proftpd 1.3
    #
    Include /etc/proftpd/modules.conf
    
    ServerName				"{HOST_NAME}"
    ServerType				standalone
    DeferWelcome			off
    
    ShowSymlinks			on
    MultilineRFC2228		on
    DefaultServer			on
    ShowSymlinks			on
    AllowOverwrite			on
    UseReverseDNS			off
    IdentLookups			off
    AllowStoreRestart		on
    AllowForeignAddress		on
    
    LogFormat 				traff "%b %u"
    
    TimeoutNoTransfer		600
    TimeoutStalled			600
    TimeoutIdle				1200
    
    DisplayLogin			welcome.msg
    DisplayFirstChdir		message
    
    #ListOptions 		"-l"
    
    DenyFilter				\*.*/
    
    DefaultRoot				~
    ServerIdent on "FTP Server ready."
    
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd		off
    
    # Port 21 is the standard FTP port.
    
    Port					21
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    
    MaxInstances			30
    
    # Set the user and group that the server normally runs at.
    
    User					nobody
    Group					nogroup
    
    # Normally, we want files to be overwriteable.
    
    <Directory /*>
      # Umask 022 is a good standard umask to prevent new files and dirs
      # (second parm) from being group and world writable.
      Umask					022	022
    
      AllowOverwrite		on
      HideNoAccess 			on
    
    </Directory>
    
    <Limit ALL>
      IgnoreHidden 			on
    </Limit>
    
    <Global>
    
    RootLogin				off
      # proFTPd >= 1.3: change log dirs to /var/log/proftpd
      TransferLog			/var/log/proftpd/
      ExtendedLog 			/var/log/proftpd/ftp_traff.log read,write traff
      PathDenyFilter 		"\.quota$"
    </Global>
    
    <IfModule mod_delay.c>
    	DelayEngine			off
    </IfModule>
    
    #
    # ISPCP Managment;
    #
    SQLBackend				mysql		# enable for proFTPd >= 1.3
    SQLAuthTypes 			Crypt
    SQLAuthenticate			on
    SQLConnectInfo			{DATABASE_NAME}@{DATABASE_HOST} {DATABASE_USER} {DATABASE_PASS}
    SQLUserInfo				ftp_users userid passwd uid gid homedir shell
    SQLGroupInfo			ftp_group groupname gid members
    SQLMinID				2000
    
    #
    # ISPCP Quota management;
    #
    
    QuotaEngine 			on
    QuotaShowQuotas 		on
    QuotaDisplayUnits 		Mb
    
    SQLNamedQuery			get-quota-limit SELECT "name, quota_type, per_session, limit_type, bytes_in_avail, bytes_out_avail, bytes_xfer_avail, files_in_avail, files_out_avail, files_xfer_avail FROM quotalimits WHERE name = '%{0}' AND quota_type = '%{1}'"
    SQLNamedQuery			get-quota-tally SELECT "name, quota_type, bytes_in_used, bytes_out_used, bytes_xfer_used, files_in_used, files_out_used, files_xfer_used FROM quotatallies WHERE name = '%{0}' AND quota_type = '%{1}'"
    SQLNamedQuery			update-quota-tally UPDATE "bytes_in_used = bytes_in_used + %{0}, bytes_out_used = bytes_out_used + %{1}, bytes_xfer_used = bytes_xfer_used + %{2}, files_in_used = files_in_used + %{3}, files_out_used = files_out_used + %{4}, files_xfer_used = files_xfer_used + %{5} WHERE name = '%{6}' AND quota_type = '%{7}'" quotatallies
    SQLNamedQuery			insert-quota-tally INSERT "%{0}, %{1}, %{2}, %{3}, %{4}, %{5}, %{6}, %{7}" quotatallies
    
    QuotaLock 				/var/run/proftpd/tally.lock
    QuotaLimitTable 		sql:/get-quota-limit
    QuotaTallyTable 		sql:/get-quota-tally/update-quota-tally/insert-quota-tally
    
    
    #
    # SSL via TLS
    #
    #<IfModule mod_tls.c>
    #  TLSEngine				off									# on for use of TLS
    #  TLSLog					/var/log/proftpd/ftp_ssl.log		# where to log to
    #  TLSProtocol				SSLv23								# SSLv23 or TLSv1
    #  TLSOptions				NoCertRequest						# either to request the certificate or not
    #  TLSRSACertificateFile	/etc/proftpd/ssl.crt				# SSL certfile
    #  TLSRSACertificateKeyFile	/etc/proftpd/ssl.key				# SSL keyfile
    #  TLSVerifyClient			off									# client verification
    #</IfModule>
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a config file for another controlpanel (ispCP OMEGA) which is not compatible with ISPConfig and not a normal Debian configuration file as used in the perfect setup guide.

    Run:

    apt-get --purge remove proftpd

    to uninstall proftpd and remove the configuration files, then install proftpd again:

    apt-get install proftpd
     
  7. bodi

    bodi New Member

    thanks for this help! Now it works!

    But FTP is very slow, I haven't any rights to write with a normal user and the normal ISPConfig Webuser starts at the root.

    Edit* Now it works!

    *sorry and thx*
     
    Last edited: Sep 25, 2007
  8. bodi

    bodi New Member

    hm...
    Since a few days the ftp-server is very slow. I need 2-5 minutes to connect!! What can I do?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs? Have you tried active and passive transfers in your FTP client?
     
  10. bodi

    bodi New Member


    passive transfers are extremly slow
    active transfers are faster


    Where can I find the errors?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Then it's your firewall. Do you need to use passive transfers? Otherwise I suggest that you use active transfers.
     

Share This Page