PROFTP refusing user name and password

Discussion in 'Server Operation' started by unixfox, Feb 2, 2010.

  1. unixfox

    unixfox New Member

    I have PROFTP running on Fedora. First of all I can FTP localhost and login with my user name and password with no problem. However, when I try to login remotely (over the internet) I cannot login. It refuses my user name and password.

    It's not my router, I have the ports open, otherwise I wouldn't even get a login. I've restarted the FTP server and completely shut down and restarted the entire system as well.

    Any clues? Any body?

  2. Hans

    Hans Moderator ISPConfig Developer

    Here are some items to verify:

    - Make sure you entered the right hostname.
    - Make sure that port 21 is open on your server.
    - Use the right account information; USERNAME and PASSWORD are not the same as username and password.
    -Make sure you have an A-record pointing to your server within the DNS-settings of your domainregistar.
    - Try to use PAssive FTP instead.
  3. unixfox

    unixfox New Member

    Thanks Hans for the quick reply!

    I've made sure that it is indeed the right host name. I only have 3 and all are set to accept FTP connections. Port 21 is open otherwise I don't think I would even get a login. If I login directly on the LAN side it works fine so I don't think it's the username or password. I've tried using passive mode as well.

    Now...when you say have an A record pointing to my server "within" the DNS settings of my domain registrar what exactly are saying? All other services work fine except FTP which leads me to believe it has nothing to do with DNS. But then again that's why I'm here.

  4. unixfox

    unixfox New Member

    Ok, now I'm not able to login to localhost anymore. Here is the output when I try it:

    ftp localhost
    Connected to localhost.localdomain.
    220 FTP Server ready.
    500 AUTH not understood
    500 AUTH not understood
    KERBEROS_V4 rejected as an authentication type
    Name (localhost:robertp):
    331 Password required for robertp.
    530 Login incorrect.
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.

    I'm lost at this point
  5. falko

    falko Super Moderator ISPConfig Developer

    What guide (URL) did you use to set up the ProFTPd server?
  6. unixfox

    unixfox New Member

    It's been so long ago I don't know which URL it is. However, I will say it was The Perfect Setup using Fedora 5 a couple of years ago. I do have ISPCONFIG running.
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page