procmail problem - mail delivery

Discussion in 'Installation/Configuration' started by Lobanak, Feb 28, 2009.

  1. Lobanak

    Lobanak New Member

    Hello all,

    ispconfig running since several years now on my server. Since some time I wonder, why one mail-address don't get any email. The user is set up as Administrator for this domain. All looks the same on another domain. Checked all files and permissions against the other domain.

    The only thing I see is the following in the mail.log when I send a mail over terminal:
    Code:
    Feb 28 10:36:39 server postfix/pickup[10389]: 7CA1313EDA: uid=0 from=<root>
    Feb 28 10:36:39 server postfix/cleanup[14803]: 7CA1313EDA: message-id=<20090228093639.7CA1313EDA@mail.mydomain.dom>
    Feb 28 10:36:39 server postfix/qmgr[10390]: 7CA1313EDA: from=<root@server.mydomain.dom>, size=297, nrcpt=1 (queue active)
    Feb 28 10:36:41 server postfix/smtpd[14811]: connect from localhost.localdomain[127.0.0.1]
    Feb 28 10:36:41 server postfix/smtpd[14811]: 6CF1013F47: client=localhost.localdomain[127.0.0.1]
    Feb 28 10:36:41 server postfix/cleanup[14803]: 6CF1013F47: message-id=<20090228093639.7CA1313EDA@mail.mydomain.dom>
    Feb 28 10:36:41 server postfix/smtpd[14811]: disconnect from localhost.localdomain[127.0.0.1]
    Feb 28 10:36:41 server postfix/qmgr[10390]: 6CF1013F47: from=<root@server.mydomain.dom>, size=755, nrcpt=1 (queue active)
    [B]Feb 28 10:36:41 server procmail[15177]: Suspicious rcfile "/var/www/web7/.procmailrc"[/B]
    Feb 28 10:36:41 server postfix/local[14813]: 6CF1013F47: to=<web7_lobanak@server.mydomain.dom>, orig_to=<lobanak@myotherdomain.dom>, relay=local, delay=0.02, delays=0.01/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 28 10:36:41 server postfix/qmgr[10390]: 6CF1013F47: removed
    Feb 28 10:36:41 server amavis[9551]: (09551-08) Passed CLEAN, <root@server.r-media.de> -> <lobanak@myotherdomain.dom>, Message-ID: <20090228093639.7CA1313EDA@mail.mydomain.dom>, mail_id: 7c9Mf7ftPJfd, Hits: 3.516, size: 297, queued_as: 6CF1013F47, 1938 ms
    Feb 28 10:36:41 server postfix/smtp[14805]: 7CA1313EDA: to=<lobanak@myotherdomain.dom>, relay=127.0.0.1[127.0.0.1]:10024, delay=2, delays=0.03/0/0/1.9, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=09551-08, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 6CF1013F47)
    Feb 28 10:36:41 server postfix/qmgr[10390]: 7CA1313EDA: removed
    the problem is the suspicious .procmailrc, but its the same then every other procmailrc on other domains
    Code:
    MAILDIR=$HOME/Maildir/
    DEFAULT=$MAILDIR
    ORGMAIL=$MAILDIR
    
    INCLUDERC=/var/www/web7/user/web7_lobanak/.mailsize.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.quota.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.antivirus.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.local-rules.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.html-trap.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.spamassassin.rc
    ## INCLUDERC=/var/www/web7/user/web7_lobanak/.autoresponder.rc
    at another domain it looks like this:
    Code:
    Feb 28 10:47:56 server postfix/smtpd[18718]: connect from localhost.localdomain[127.0.0.1]
    Feb 28 10:47:56 server postfix/smtpd[18718]: disconnect from localhost.localdomain[127.0.0.1]
    Feb 28 10:47:57 server postfix/pickup[10389]: 7177713EDA: uid=0 from=<root>
    Feb 28 10:47:57 server postfix/cleanup[18630]: 7177713EDA: message-id=<20090228094757.7177713EDA@mail.mydomain.dom>
    Feb 28 10:47:57 server postfix/qmgr[10390]: 7177713EDA: from=<root@server.mydomain.dom>, size=291, nrcpt=1 (queue active)
    Feb 28 10:48:06 server postfix/smtpd[18628]: connect from localhost.localdomain[127.0.0.1]
    Feb 28 10:48:06 server postfix/smtpd[18628]: 2E95413F47: client=localhost.localdomain[127.0.0.1]
    Feb 28 10:48:06 server postfix/cleanup[18630]: 2E95413F47: message-id=<20090228094757.7177713EDA@mail.mydomain.dom>
    Feb 28 10:48:06 server postfix/smtpd[18628]: disconnect from localhost.localdomain[127.0.0.1]
    Feb 28 10:48:06 server postfix/qmgr[10390]: 2E95413F47: from=<root@server.mydomain.dom>, size=737, nrcpt=1 (queue active)
    Feb 28 10:48:06 server amavis[11692]: (11692-09) Passed CLEAN, <root@server.mydomain.dom> -> <alex@3rddomain.dom>, Message-ID: <20090228094757.7177713EDA@mail.mydomain.dom>, mail_id: QpNzKFQLHO8Y, Hits: 3.552, size: 291, queued_as: 2E95413F47, 8735 ms
    Feb 28 10:48:06 server postfix/smtp[17398]: 7177713EDA: to=<alex@3rddomain.dom>, relay=127.0.0.1[127.0.0.1]:10024, delay=8.8, delays=0.03/0/0/8.7, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=11692-09, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 2E95413F47)
    Feb 28 10:48:06 server postfix/qmgr[10390]: 7177713EDA: removed
    Feb 28 10:48:06 server postfix/pickup[10389]: 3D1AF13EDA: uid=10066 from=<web14_alex>
    Feb 28 10:48:06 server postfix/cleanup[18630]: 3D1AF13EDA: message-id=<20090228094806.3D1AF13EDA@mail.mydomain.dom>
    Feb 28 10:48:06 server postfix/local[18631]: 2E95413F47: to=<web14_alex@server.mydomain.dom>, orig_to=<alex@3rddomain.com>, relay=local, delay=0.08, delays=0.01/0/0/0.06, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 28 10:48:06 server postfix/qmgr[10390]: 2E95413F47: removed
    I deleted all the procmailrc and other rc-files and let them regenerate when changeing some options in ispconfi, but still the same.

    Somebody can help?

    Edit: when I insert forward in the email-address it will be delivered to this email
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /var/www/web7/.procmailrc

    and

    ls -la /var/www/web7
     
  3. Lobanak

    Lobanak New Member

    server:~# ls -la /var/www/web7/.procmailrc
    -rw-r--r-- 1 root root 471 2009-02-28 11:09 /var/www/web7/.procmailrc
    server:~# ls -la /var/www/web7
    total 76
    drwxrwxrwx 10 web7_lobanak web7 4096 2009-02-28 11:09 .
    drwxr-xr-x 17 root root 4096 2009-02-25 08:36 ..
    -rw------- 1 web7_lobanak web7 6895 2009-02-13 12:59 .bash_history
    drwxr-xr-x 21 root root 4096 2009-01-06 12:04 bkup
    drwxr-xr-x 2 web7_lobanak web7 4096 2005-09-10 12:14 cgi-bin
    -rw------- 1 web7_lobanak web7 24 2009-02-28 11:09 .forward
    -rw-rw-r-- 1 root web7 542 2009-02-28 07:21 .htpasswd
    -rw------- 1 web7_lobanak web7 35 2009-01-23 13:32 .lesshst
    drwxr-xr-x 7 web7_lobanak web7 4096 2009-01-02 00:30 log
    lrwxrwxrwx 1 root root 39 2009-02-28 11:09 Maildir -> /var/www/web7/user/web7_lobanak/Maildir
    drwxrwxrwx 2 web7_lobanak web7 4096 2005-09-10 12:14 phptmp
    -rw-r--r-- 1 root root 471 2009-02-28 11:09 .procmailrc
    -rw-r--r-- 1 web7_lobanak web7 18 2009-01-23 13:32 .serverscriptpasses
    lrwxrwxrwx 1 root root 46 2009-02-28 11:09 .spamassassin -> /var/www/web7/user/web7_lobanak/.spamassassin/
    drwxr-xr-x 2 web7_lobanak web7 4096 2005-09-10 12:14 ssl
    drwxr-xr-x 3 web7_lobanak web7 4096 2009-01-15 15:58 tmp
    drwxr-xr-x 23 web7_lobanak web7 4096 2009-02-28 10:13 user
    lrwxrwxrwx 1 root root 47 2009-02-28 11:09 .vacation.cache -> /var/www/web7/user/web7_lobanak/.vacation.cache
    -rw------- 1 web7_lobanak web7 7458 2009-01-23 13:37 .viminfo
    drwxrwxr-x 23 web7_lobanak web7 4096 2009-02-13 12:52 web
     
  4. falko

    falko Super Moderator ISPConfig Developer

    The directory parmissions are wrong. Please run
    Code:
    chmod 755 /var/www/web7
     
  5. Lobanak

    Lobanak New Member

    Thanks a lot.

    Worked. Don't know when I have changed the permissions.
     

Share This Page