Problems with Yum following The Perfect Server - CentOS 5.3 x86_64 Guide

Discussion in 'HOWTO-Related Questions' started by GOPalmer, Jun 29, 2009.

  1. GOPalmer

    GOPalmer New Member

    Hello,

    I'm on page 3 of the http://www.howtoforge.com/perfect-server-centos-5.3-x86_64-ispconfig-3-p3 guide and i having a lot of problems with step 9 "Install Apache, MySQL, phpMyAdmin"

    I'm entering the following
    Code:
    yum install ntp httpd mysql-server php php-mysql php-mbstring php-mcrypt phpmyadmin rpm-build gcc mysql-devel openssl-devel cyrus-sasl-devel pkgconfig zlib-devel pcre-devel openldap-devel postgresql-devel expect libtool-ltdl-devel openldap-servers libtool gdbm-devel pam-devel gamin-devel
    With the below result
    Code:
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Parsing package install arguments
    Package ntp-4.2.2p1-9.el5.centos.2.x86_64 already installed and latest version
    No package httpd available.
    No package mysql-server available.
    No package php available.
    No package php-mysql available.
    No package php-mbstring available.
    No package php-mcrypt available.
    No package phpmyadmin available.
    Package rpm-build-4.4.2.3-9.el5.x86_64 already installed and latest version
    Package gcc-4.1.2-44.el5.x86_64 already installed and latest version
    No package mysql-devel available.
    Package openssl-devel-0.9.8e-7.el5.x86_64 already installed and latest version
    Package openssl-devel-0.9.8e-7.el5.i386 already installed and latest version
    Package cyrus-sasl-devel-2.1.22-4.x86_64 already installed and latest version
    Package cyrus-sasl-devel-2.1.22-4.i386 already installed and latest version
    Package 1:pkgconfig-0.21-2.el5.x86_64 already installed and latest version
    Package zlib-devel-1.2.3-3.x86_64 already installed and latest version
    Package zlib-devel-1.2.3-3.i386 already installed and latest version
    Package pcre-devel-6.6-2.el5_1.7.x86_64 already installed and latest version
    Package pcre-devel-6.6-2.el5_1.7.i386 already installed and latest version
    Package openldap-devel-2.3.43-3.el5.x86_64 already installed and latest version
    Package openldap-devel-2.3.43-3.el5.i386 already installed and latest version
    Package postgresql-devel-8.1.11-1.el5_1.1.x86_64 already installed and latest version
    Package postgresql-devel-8.1.11-1.el5_1.1.i386 already installed and latest version
    Package expect-5.43.0-5.1.x86_64 already installed and latest version
    Package expect-5.43.0-5.1.i386 already installed and latest version
    Package libtool-ltdl-devel-1.5.22-6.1.x86_64 already installed and latest version
    Package libtool-ltdl-devel-1.5.22-6.1.i386 already installed and latest version
    Package openldap-servers-2.3.43-3.el5.x86_64 already installed and latest version
    Package libtool-1.5.22-6.1.x86_64 already installed and latest version
    Package gdbm-devel-1.8.0-26.2.1.x86_64 already installed and latest version
    Package gdbm-devel-1.8.0-26.2.1.i386 already installed and latest version
    Package pam-devel-0.99.6.2-4.el5.x86_64 already installed and latest version
    Package pam-devel-0.99.6.2-4.el5.i386 already installed and latest version
    Package gamin-devel-0.1.7-8.el5.x86_64 already installed and latest version
    Package gamin-devel-0.1.7-8.el5.i386 already installed and latest version
    Nothing to do
    I'm not really sure what to do now. Have can i get this to work?

    Best Regards, George
     
  2. abix_adamj

    abix_adamj New Member

    If you're using VPS based on OpenVZ container, think about changing CentOS to Debian 5.0.1. I had a lot of problems with CentOs on OpenVZ and the solution was to change the distribution ;-(

    Adam
     
  3. GOPalmer

    GOPalmer New Member

    I'm not on a vps. Changing the os is not really an option for me.

    Thanks anyway.

    George
     
  4. falko

    falko Super Moderator

    Please check if the main CentOS repo is enabled in the /etc/yum.repos.d/ directory.
     
  5. GOPalmer

    GOPalmer New Member

    I think its enabled. Here is the file

    Code:
    # CentOS-Base.repo
    #
    # This file uses a new mirrorlist system developed by Lance Davis for CentOS.
    # The mirror system uses the connecting IP address of the client and the
    # update status of each mirror to pick mirrors that are updated to and
    # geographically close to the client.  You should use this for CentOS updates
    # unless you are manually picking other mirrors.
    #
    # If the #mirrorlist does not work for you, as a fall back you can try the 
    # remarked out baseurl= line instead.
    #
    #
    
    [base]
    name=CentOS-$releasever - Base
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
    baseurl=http://mirror.trouble-free.net/centos/$releasever/os/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=1 
    
    #released updates 
    [updates]
    name=CentOS-$releasever - Updates
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
    baseurl=http://mirror.trouble-free.net/centos/$releasever/updates/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=1 
    
    #packages used/produced in the build but not released
    [addons]
    name=CentOS-$releasever - Addons
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=addons
    baseurl=http://mirror.trouble-free.net/centos/$releasever/addons/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=1 
    
    #additional packages that may be useful
    [extras]
    name=CentOS-$releasever - Extras
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
    baseurl=http://mirror.trouble-free.net/centos/$releasever/extras/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=1 
    
    #additional packages that extend functionality of existing packages
    [centosplus]
    name=CentOS-$releasever - Plus
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus
    baseurl=http://mirror.trouble-free.net/centos/$releasever/centosplus/$basearch/
    gpgcheck=1
    enabled=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=2
    
    
    #contrib - packages by Centos Users
    [contrib]
    name=CentOS-$releasever - Contrib
    #mirrorlisthttp://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib
    baseurl=http://mirror.trouble-free.net/centos/$releasever/contrib/$basearch/
    gpgcheck=1
    enabled=0
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
    priority=2
    
    
     
  6. GOPalmer

    GOPalmer New Member

    I managed to get it to work in the end.

    I just got this eror installing ISPConfig

    Code:
    Shutting down Mail Virus Scanner (amavisd):                [FAILED]
    Starting Mail Virus Scanner (amavisd):                     [  OK  ]
    Stopping Clam AntiVirus Daemon:                            [FAILED]
    ERROR: TCP: bind() error: Address already in use
    Starting Clam AntiVirus Daemon:                            [FAILED]
    Stopping Courier authentication services: authdaemond
    Starting Courier authentication services: authdaemond
    Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Stopping httpd:                                            [  OK  ]
    [Tue Jun 30 15:58:30 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Tue Jun 30 15:58:30 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    Starting httpd:                                            [  OK  ]
    Stopping pure-ftpd:                                        [  OK  ]
    Starting pure-ftpd:                                        [  OK  ]
    Installation completed.
    
    Is this something i should worry about??

    Thank for all you help.

    Best Regards, George
     
  7. GOPalmer

    GOPalmer New Member

    I'm having even worse problems now. ISPConfig was working but now all i get is a blank page. Nothing has changed it just suddenly stopped working. :(
     
  8. falko

    falko Super Moderator

    Any errors in Apache's error log?
    What's the output of
    Code:
    netstat -tap
    ?
     

Share This Page