Problems with Xen 3.0 Debian Install

Discussion in 'HOWTO-Related Questions' started by sergiochacon, Mar 10, 2008.

  1. sergiochacon

    sergiochacon New Member

    Originally Posted by sergiochacon
    Hey Falko,

    I was trying the installation of xen 3 following your instructions on a Dell Poweredge 2300 that had Debian 4 and linux 2.6.8 installed. Everything went well until I got to make world. I got an error

    ...
    `/usr/src/xen-3.0.3_0-src'
    rm -rf tmp-linux-2.6.16.29 linux-2.6.16.29-xen
    make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src'
    make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src'
    make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src'
    make dist
    make[1]: Entering directory `/usr/src/xen-3.0.3_0-src'
    make -C xen install
    make[2]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
    make -f Rules.mk _install
    /bin/sh: line 1: gcc: command not found
    /bin/sh: line 1: gcc: command not found
    /bin/sh: line 1: gcc: command not found
    make[3]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
    make -C tools
    make[4]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools'
    make -C figlet
    make[5]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
    gcc -o figlet figlet.c
    make[5]: gcc: Command not found
    make[5]: *** [figlet] Error 127
    make[5]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
    make[4]: *** [default] Error 2
    make[4]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools'
    make[3]: *** [/usr/src/xen-3.0.3_0-src/xen/xen] Error 2
    make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
    make[2]: *** [install] Error 2
    make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
    make[1]: *** [install-xen] Error 2
    make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src'
    make: *** [world] Error 2
    host1:/usr/src/xen-3.0.3_0-src# make install
    make -C xen install
    make[1]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
    make -f Rules.mk _install
    /bin/sh: line 1: gcc: command not found
    /bin/sh: line 1: gcc: command not found
    /bin/sh: line 1: gcc: command not found
    make[2]: Entering directory `/usr/src/xen-3.0.3_0-src/xen'
    make -C tools
    make[3]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools'
    make -C figlet
    make[4]: Entering directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
    gcc -o figlet figlet.c
    make[4]: gcc: Command not found
    make[4]: *** [figlet] Error 127
    make[4]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools/figlet'
    make[3]: *** [default] Error 2
    make[3]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen/tools'
    make[2]: *** [/usr/src/xen-3.0.3_0-src/xen/xen] Error 2
    make[2]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
    make[1]: *** [install] Error 2
    make[1]: Leaving directory `/usr/src/xen-3.0.3_0-src/xen'
    make: *** [install-xen] Error 2
    host1:/usr/src/xen-3.0.3_0-src#

    Can you provide me with assistance? Is this a common error and is there anything I can do about it?
    Thanks for your help bro.
    Sergio
     
  2. sergiochacon

    sergiochacon New Member

    Moving along

    Well, I ran the tutorial again and found the error again, so I installed gcc again and it worked. So I was able to make world and then I did make install and got another error, so I installed patch and it is now doing its thing so I believe I might get lucky.
     
  3. sergiochacon

    sergiochacon New Member

    problem with xen install

    After "make world" command, everything seemed to be going fine but after a couple of hours of compiling I got an error that said "no enough space" to continue. I originally used an 18GB scsi drive.

    Changed to a 36GB scsi drive and retried but the same issue appeared. It seems though that it came at a different place in the compilation.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the size of the partition where you're compiling Xen? What's the output of
    Code:
    df -h
    ?
     
  5. sergiochacon

    sergiochacon New Member

    problem with xen install

    Thanks for your reply, Falko.

    I kept running out of space every time I tried to "make world" so I decided to reinstall debian with automatic partitioning. I also added the following to the Config.mk file:

    CFLAGS = -fno-stack-protector -mno-tls-direct-seg-ref

    before attempting make. It worked. I am moving along now buddy!

    Thanks for the manual by the way. It would have been very difficult without it.
     
  6. sergiochacon

    sergiochacon New Member

    problem with xen install

    Just when things were going well, i got a problem with setting up the template for the base system as of page 3. After successfully downloading from ftp2.de.debian.org/debian, found that when i apt-get install localesconfig, it does not exist, and when I tried to base-config, i get a terminated message.

    Any idea?
    I will try to create a base from another source in the meantime.
     
  7. sergiochacon

    sergiochacon New Member

    problem with xen install

    trying xen-tools
     
  8. falko

    falko Super Moderator ISPConfig Developer

    It's
    Code:
    apt-get install localeconf
     

Share This Page