Problems with Wordpress based web page after installing Ispconfig

Discussion in 'Installation/Configuration' started by Mole, Apr 10, 2008.

  1. Mole

    Mole New Member

    I agree that it could be no problem with ispconfig, but in which way I have to look?
    PHP.INI is fine, I think httpd.conf also fine, ispconfig config.in.php also fine, /etc/sysconfig/apache2 also fine...

    Nothing extra configured - standart new server (also reinstalled X times all packages except Base system files), configured as it is described in Prefect install Suse, installed ispconfig ass needed, added 'Addhandler' in config.inc.php file.

    But what is strange - before this page runns on the same server with original Apache + PHP config but with manual vhosts.conf file configuration... What exactly are different before Old_server_configuration and Last_configurations - I'he no idea, I think that know is normal server configuration according many goog manuals etc... and now many extra packages are installed!

    The Error - it seams, that it can not find "X" functions in /wp-includes/functions.php file, but WHY?
     
  2. Mole

    Mole New Member

    Also, when I run www.komunalserviss.lv/wp-admin/install.php, there is such Error;
    HTML:
    Fatal error: Call to undefined function __() in /wwwroot/web3/web/wp-admin/includes/file.php on line 3
    Here is file.php:

    PHP:
    <?php

    $wp_file_descriptions 
    = array ('index.php' => __'Main_in_LV.' ), 'style.css' => __'Styles_in_LV' ), 'comments.php' => __'Comments_in_LV' ), 'comments-popup.php' => __'Comments_in_LV' ), 'footer.php' => __'KÄjene (lapas apakÅ”a)' ), 'header.php' => __'Galvene(lapas augÅ”a)' ), 'sidebar.php'  __'IzvÄlne' ), 'archive.php' => __'ArhÄ«vs' ), 'category.php' => __'Kategorijas' ), 'page.php' => __'Lapa' ), 'search.php' => __'MeklÅ”ana rezultÄti' ), 'single.php' => __'Raksts' ), '404.php' => __'404' ), 'my-hacks.php' => __'my-hacks.php' ), '.htaccess' => __'.htaccss' ),^M
    [...]
    PHP does not recognize Array symbol ___
     
    Last edited: Apr 22, 2008
  3. Mole

    Mole New Member

    What else I can tell: as far I'm using Windows on my portable - I installed WAMP, copied ALL files from my server Wordpress page. Configured appropriate wp-config.php file, created mysql database etc. When run page - the same problem...
    Then I found earlier edition to my Wordpress web page, delete ALL files I'd copy before and copy these files to web page "room".

    Then I can run localhost/wordpress_page/wp-admin/install.php, install needed tables. And when run localhost/wordpress_page/index.php, then at least opens page (not normal), but with different error:

    HTML:
    Fatal error: Call to undefined function ddsg_create_sitemap() in C:\Program Files\wamp\www\www.komunalserviss.lv\wp-content\themes\default\footer.php on line 15
    This error can correct (disabling themes\plugins)...

    What was in php_info() page? I think - OK! IT is a standard SuSe yast -i apache (all packages), php (all packages), mysql (all packages), perl, python installation, only extra installation (but before I got this error) was cache!

    Maybe PHP need some configuration?
     
    Last edited: Apr 23, 2008
  4. Mole

    Mole New Member

    What else I can say - it seems, that there is problems with .php pages for this virtual server...? :confused:

    Because NEW install if wordpress and configuring wp-config.php file give such error: "ERROR: wp_ in wp-config.php can only contain numbers, letters, and underscores."

    When I correct it, then I got errors that there is no possibility to get X () functions from /wp-includes/functions.php file (I have this file)!
     
  5. Mole

    Mole New Member

    Maybe this is the problem:
    Code:
    XXserv1:/ # suexec2 -V
    -D AP_DOC_ROOT="/srv/www"
    -D AP_GID_MIN=96
    -D AP_HTTPD_USER="wwwrun"
    -D AP_LOG_EXEC="/var/log/apache2/suexec.log"
    -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
    -D AP_UID_MIN=96
    -D AP_USERDIR_SUFFIX="public_html"
    But my Document_root is /wwwroot/
    and USERDIR_SUFFIX for me (as ispconfig) is web (not public_html)?

    Here is /etc/apache2/mod_userdir.conf:
    Code:
    #
    # UserDir: The name of the directory that is appended onto a user's home
    # directory if a ~user request is received.
    #
    
    <IfModule mod_userdir.c>
            # Note that the name of the user directory ("public_html") cannot easily be
            # changed here, since it is a compile time setting. The apache package
            # would have to be rebuilt. You could work around by deleting
            # /usr/sbin/suexec, but then all scripts from the directories would be
            # executed with the UID of the webserver.
            #
            # To rebuild apache with another setting you need to change the
            # %userdir define in the spec file.
    
            # not every user's directory should be visible:
            UserDir disabled root
    
            # to enable UserDir only for a certain set of users, use this instead:
            #UserDir disabled
            #UserDir enabled user1 user2
    
    
            # the UserDir directive is actually used inside the virtual hosts, to
            # have more control
            #UserDir web
    
            <Directory /wwwroot/*/web>
    
                    AllowOverride FileInfo AuthConfig Limit Indexes
                    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    
                    <Limit GET POST OPTIONS PROPFIND>
                            Order allow,deny
                            Allow from all
                    </Limit>
    
                    <LimitExcept GET POST OPTIONS PROPFIND>
                            Order deny,allow
                            Deny from all
                    </LimitExcept>
    
            </Directory>
    
    </IfModule>
    Here is part of /etc/apache2/httpd.conf

    Code:
    [...]
    DocumentRoot "/wwwroot"
    
    #
    # Configure the DocumentRoot
    #
    <Directory "/wwwroot">
            # Possible values for the Options directive are "None", "All",
            # or any combination of:
            #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
            #
            # Note that "MultiViews" must be named *explicitly* --- "Options All"
            # doesn't give it to you.
            #
            # The Options directive is both complicated and important.  Please see
            # http://httpd.apache.org/docs-2.2/mod/core.html#options
            # for more information.
            Options None
            # AllowOverride controls what directives may be placed in .htaccess files.
            # It can be "All", "None", or any combination of the keywords:
            #   Options FileInfo AuthConfig Limit
            AllowOverride None
            # Controls who can get stuff from this server.
            Order allow,deny
            Allow from all
    </Directory>
    
    [...]
    How I can change that in suexec -V was my appropriate settings?
     
    Last edited: Apr 25, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    You'd either have to recompile suExec or move your web sites to /srv/www.
     
  7. Mole

    Mole New Member

    Recompiling Suexec did not solved the problem :eek: :(

    Code:
    srv:/ # suexec2 -V
    -D AP_DOC_ROOT="/wwwroot"
    -D AP_GID_MIN=100
    -D AP_HTTPD_USER="wwwrun"
    -D AP_LOG_EXEC="/var/log/apache2/access_log"
    -D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
    -D AP_UID_MIN=100
    -D AP_USERDIR_SUFFIX="web"
     
  8. Mole

    Mole New Member

    Checking test php (to verify dirname(_FILE_)):
    PHP:
    <?php
    header
    ("Content-type: text/plain");
    echo 
    PHP_OS ', PHP ' PHP_VERSION ."\n";
    //
    echo __FILE__ "\n";
    echo 
    dirname(__FILE__) . "\n";;
    echo 
    basename(__FILE__) . "\n";;
    echo 
    basename(dirname(__FILE__)) . "\n";
    ?>
    The result:
    Linux, PHP 5.1.2
    /wwwroot/web3/web/test.php
    /wwwroot/web3/web
    test.php
    web

    All seems to be OK! That's right! Also tried to replace this variable with full path (/wwwroot/webX/web), nothing...

    SUEXEC was not "giulty". I could (and also did) disable it at all (as it is needed in "perefect setup...") and say ISPCONFIG, that I do not use SUEXEC... If I disable it in ISPCONFIG and remove as package and stop service in server - then all what is in SUEXEC -V doesn't matter - Am I rigth?

    With permissions also have to be OK - I can do this:
    Code:
    chown -hR wwwrun:www /wwwroot/webX/web
    Code:
    chmod -R 755 /wwwroot/webX/web
    (if I use SUEXEC then wwwrun:www is appropriate ispconfiguser:ispconfiggroup, I replaced also 755 to 777...)
    The same problem...

    Anybody give me a gun?:eek:
     
  9. falko

    falko Super Moderator ISPConfig Developer

    That's right.

    I have no idea what's wrong, but I think it could have to do with SUSE (wouldn't be surprised...).
     
  10. Mole

    Mole New Member

    SUSE could be "guilty" if the webpage would not run at all, but it run before...:eek:
    At this moment only "extra package/software" is ispconfig, all LAMP is standard SUSE packages...

    One thing - I'm using SUSE SLES 10.0 with evalution period to 3 month. Now this time is over... Maybe this could be the problem (but registered version only includes Updates (AND) Maintanance)...
     
    Last edited: May 3, 2008
  11. Mole

    Mole New Member

    Full server reinstallation solved this problem!;)
     

Share This Page