Problems with wildcard SSL on ISPconfig

Discussion in 'Installation/Configuration' started by vmos, Nov 15, 2012.

  1. vmos

    vmos Member

    Hello, I've built an ispconfig server for a client (ubuntu 12, apache2) and I'm migrating their sites from another host on to this server.
    They have multiple sites using a wildcard certificate. I've got four files, .key, .csr, .cert and .bundle

    in ISPconfig, there are three fields, certificate, request and bundle. I've tried obvious combination and a few others but I keep getting the same error

    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error. (chrome)

    or

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long) (firefox)

    am I just putting the files in the wrong places or is there something more fundamental that I'm missing
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There are four files in ispconfig as well, take a look into the ssl folder of the site. If you use a existing ssl cert, you will have to replace the key file too. Thats described in detail in the manual as well.
     

Share This Page