Problems with Virtual Hosting With PureFTPd And MySQL (Incl. Quota And Bandwidth Mana

Discussion in 'HOWTO-Related Questions' started by ikkem, May 4, 2007.

  1. falko

    falko Super Moderator

    It seems PHP is not installed or not enabled on your system. What are the outputs of
    Code:
    ls -la /etc/apache2/mods-available
    and
    Code:
    ls -la /etc/apache2/mods-enabled
    ?
     
  2. ikkem

    ikkem New Member

    The output of the comands is....
    Thanks in advance.

    and
     
    Last edited: May 25, 2007
  3. falko

    falko Super Moderator

    Please delete /etc/apache2/mods-enabled/php5.conf~ and restart Apache.
     
  4. ikkem

    ikkem New Member

    I deleted /etc/apache2/mods-enabled/php5.conf~ and restarted apache #/etc/init.d/apache2 restart
    But I still get text instead of the inlogscreen....
    thanks in advance....
     
  5. falko

    falko Super Moderator

    Ok, please post the vhost configuration of the vhost where phpMyAdmin is installed.
    What's in/etc/apache2/mods-enabled/php5.conf? What's the output of
    Code:
    grep application/x-httpd-php /etc/mime.types
    ?
     
  6. ikkem

    ikkem New Member

    Hi....
    thanks for reacting the output of the requested comands is....
    and

    I could not find the location of the vhost file....:(
     
  7. ikkem

    ikkem New Member

    I wanted to ask how to change the port number in pureftp the standard port is 21 i wanted to change it into another number I cant seem to find a config file for that....
    thanks in advance....
     
  8. falko

    falko Super Moderator

    You don't have ISPConfig installed, do you? If not, /etc/apache2/mods-enabled/php5.conf must look like this:
    Code:
    <IfModule mod_php5.c>
      AddType application/x-httpd-php .php .phtml .php3
      AddType application/x-httpd-php-source .phps
    </IfModule>
    And in /etc/mime.types, you must uncomment the application/x-httpd-php* lines. Restart Apache afterwards.

    What's the output of
    Code:
    ls -la /etc/pure-ftpd/conf
    ?
     
  9. ikkem

    ikkem New Member

    I had but I removed it a few days ago.....

    the output is :
    Thanks in advance....
     
  10. falko

    falko Super Moderator

    Can you check the Pureftpd man page (
    Code:
    man pureftpd
    or
    Code:
    man pure-ftpd
    ) to find out how the options is called that lets you set the port?
     
  11. ikkem

    ikkem New Member

    I read the man pages you can let pure-ftpd bind to "ipaddress,port"
    from the manpages:-S [{ip address|hostname}] [,{port|service name}] This option is only effective when the server is launched as a standalone server.Connections are accepted on the specified IP and port. IPv4 and IPv6 are supported. Numeric and fully-qualified host names are accepted. A service name (see /etc/services) can be used instead of a numeric port number.
    I made a conf file:----->vi /etc/pure-ftpd/conf/Bind and put 127.0.0.1,1900 (ipaddress,port) into it and restarted pure-ftpd:----->/etc/init.d/pure-ftpd-mysql restart

    http://www.debianhelp.co.uk/pureftp.htm
    http://www.freebsdblog.org/archives/2005/12/change_ftp_port_1.html
     
  12. Jarek Buczyński

    Jarek Buczyński New Member

    Hi,

    Option ChrootEveryone is very usefully, but what if I'd like have one user (me :) ) who can view all file system include "root".

    Is it possible to do?

    --
    Regards
    Jarek
     
  13. lilltonka

    lilltonka New Member

    Download only user

    Hi all!

    First of all, thank you for providing all these great guides and how-to's.

    I have used the guide and have everything working accordingly (except that darn TLS that is bugging me, probably my router :p).

    I was wondering how I would go about to create a user that can download only, not an anonymous account, a regular user.

    I browsed the net but have not yet found a solution.

    Thanks in advance!
     
  14. falko

    falko Super Moderator

    I don't have a finished solution or a tutorial, but basically you need a user that has only read permissions and no write permissions.
     

Share This Page