Problems with "The Perfect Xen 3.0.3 Setup For Debian Sarge"

Discussion in 'HOWTO-Related Questions' started by PaulTomblin, Nov 18, 2006.

  1. PaulTomblin

    PaulTomblin New Member

    At first, I tried doing the binary install.

    The first problem is that it tells you to do a "depmod 2.6.16.29-xen". When you do, it says "depmod: QM_MODULES: Function not implemented".

    The major problem there is that when I start up the domU, it warns you that it's mounting the ext3 file system as ext2. I already lost one domU in the past because it wasn't ext3 and the file system corrupted when it didn't shut down properly, so I want ext3.

    Is there a way to make a ramdisk to get ext3? I tried using the same ramdisk that I'd made for the dom0, and it doesn't boot. Would it work if I copied my /lib/modules/2.6.16.29-xen to the domU?

    Ok, now I'm trying the source installation instead. And the first problem I'm encountering is that the list of packages to install says "gcc-3.3", but if you do that you don't actually get the "gcc" binary. You have to install "gcc" as well or instead.

    I'll let you know how that goes.
     
  2. PaulTomblin

    PaulTomblin New Member

    Second report

    I got as far as the part where you build and boot a xen0 kernel, and when it boots it says that it's unable to bring up the eth0 interface. Well, that's not much good to me. Back to the drawing board.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Which file system do you use on dom0?

    Did you select the correct driver for your network card during
    Code:
    make menuconfig
    ? It's also possible there's no driver available yet if you're using a very new network card.
     
  4. PaulTomblin

    PaulTomblin New Member

    ext3.

    The instructions don't say anything about selecting network drivers. It worked fine with the -xen kernel installed as per Chapter 4.1.

    BTW: I tried to make a initrd for the xen0 kernel, but I get the message
    Code:
    yaird error: Could not read output for /sbin/modprobe -v -n --show-depends --set-version 2.6.16.29-xen0 evdev (fatal)
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That's ok.

    No, they don't, but you should configure the kernel to your needs during
    Code:
    make menuconfig
    This is what I've found: http://kerneltrap.org/node/3891
    http://www.linuxquestions.org/questions/showthread.php?postid=1140501
     
  6. ptomblin

    ptomblin New Member

    Installing module-init-tools in my domU was all it took to get my binary install working correctly. You might want to make a mention of that in the howto.
     

Share This Page