problems with pure-ftpd-mysql and openvz

Discussion in 'General' started by grungy, Jan 8, 2009.

  1. grungy

    grungy Member HowtoForge Supporter

    I know you made clear in the ispconfig 3 setup how to solve this problem, but I rent my vps from a provider and cannot apply your patch.....

    So if a user has problems with pure-ftpd-mysql and has a openvz system (pure-ftpd: (?@?) [ERROR] Unable to switch capabilities : Operation not permitted) you will have to compile your pure-ftpd-mysql with --without-capabilities.

    short info:

    after you download the deb source:

    nano pure-ftpd-1.0.21/debian/rules

    line 12 add --without-capabilities

    optflags=--with-everything --with-largefile --with-pam --with-privsep --with-tls --without-capabilities

    then build your .deb package and install dpkg -i pure-ftpd-mysql_1.0.21-8_i386.deb
  2. jcombs_31

    jcombs_31 New Member

    Can you please explain how to build the package?

    I ended up getting it working, but there is no documentation stating that you need some more packages to build packages and I guess you expect that people know how to build packages. I just think it should be added into the documentation for newbs like me, or at least explain it in more detail here. I don't really want to do it because maybe I didn't do it the way it should be done.
    Last edited: Jan 19, 2009
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Normally it is not nescessary to build a new package.
  4. jcombs_31

    jcombs_31 New Member

    Maybe not, but I just so happened to be that exception using debian 4 on an openvz vps. I was able to compile it and install it fine, but I noticed now if I run apt-get update/upgrade it tries to overwrite my package with one from the repo. Is that normal or did I do something wrong?
  5. falko

    falko Super Moderator ISPConfig Developer

  6. djoey

    djoey New Member


    I downloaded the sources, and added the line as you mentioned, now i try to build the .deb package with the command dpkg -b dirname filename.deb then it gives me:

    dpkg -b pure-ftpd-1.0.21 pure-ftpd-mysql_1.0.21-8_i386.deb
    dpkg-deb: failed to open package info file `pure-ftpd-1.0.21/DEBIAN/control' for reading: No such file or directory

    Should I not build it as root?
  7. jcombs_31

    jcombs_31 New Member

  8. jcombs_31

    jcombs_31 New Member

  9. djoey

    djoey New Member

    Instead of using apt-pinning you can just set packages on hold:

    echo package hold | dpkg --set-selections

    To undo that:

    echo package install | dpkg --set-selections

    To view a list of "on hold" packages:

    dpkg --get-selections | grep hold

    this way you get your monitoring "green" again :)
    Last edited: Jan 21, 2009
  10. jcombs_31

    jcombs_31 New Member

    Thanks, this worked nice.
  11. kevinwalter

    kevinwalter New Member

    i cant find

    if i open the deb etc etc i see only:

    DEBIAN and here i cant find rules :S

    is there a soluiton or is there a good deb source link?

  12. falko

    falko Super Moderator ISPConfig Developer

    What exactly did you do so far?
    In what directory do you see the files you mentioned?
  13. grungy

    grungy Member HowtoForge Supporter

    short tutorial

    apt-get source pure-ftpd
    cd pure-ftpd-1.0.21/
    nano debian/rules
    apt-get build-dep pure-ftpd
    dpkg-buildpackage -uc -b
    cd ..
    dpkg -i pure-ftpd-mysql_1.0.21-11.4_i386.deb

Share This Page