Problems with postfix

Discussion in 'Installation/Configuration' started by vervem, Oct 15, 2005.

  1. vervem

    vervem New Member


    I'm using ISPconfig for my webshop named "".
    In my webshop, the costumers have the option of sending a mail to me ([email protected]).
    Only the mailserver is not the same server as de ISPconfig server, so this doesn't work.
    Even when i use the "external mailserver" setting in ISPconfig, it doesn't work.
    The problem is in "/etc/postfix/local-host-names". When i # "", it works fine for a short wile, then ISPconfig removes my #.
    My question:
    Is it possible to stop ISPconfig to rewrite my local-host-names file?
    Or is there any other sollution to my problem?

    Thanx already,

    Matthijs Verver
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You must set the Co-Domain to external too!
  3. vervem

    vervem New Member

    Thanx for the quick re:

    What does the option Co-Domain do?

    If i change Co-Domain, is the site still working then? Only the mx record is external.

  4. falko

    falko Super Moderator ISPConfig Developer

    It works like this: when you create the web site, the Co-Domain is created automatically so that you can access your web site using and
    Every user you create has then email addresses like [email protected] and [email protected].

    If you remove the Co-Domain, then you can't use anymore to reach your web site, and your user can receive emails only under [email protected].

    If you use an external mail server, then you have to tell and to use this external mail server. If you do this only for, then emails for will still arrive on your server.
  5. vervem

    vervem New Member

    I got it.
    It works fine now ! :D

    Thanx guys

  6. teknology

    teknology New Member

    Falko, you should write a book. Great tutorials!

Share This Page