Problems with pop login

Discussion in 'Installation/Configuration' started by darkcoder, May 15, 2006.

  1. darkcoder

    darkcoder New Member

    Recently I configured a Fedora 5 server with the http://www.howtoforge.com/perfect_setup_fedora_core_5, everythings looks to be working without problem, exept that I was not able to login a user to the pop3 account. Every time I tried from telnet to email clients I got the ERR Authentication failed.

    Al the services are running.
    Code:
    named    28622  0.0  0.2  47348  2648 ?        Ssl  15:05   0:00 /usr/sbin/named -u named -t /var/named/chrroot     28705  0.0  0.0   4772   776 ?        Ss   15:05   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd
    root     28706  0.0  0.0   4772   440 ?        S    15:05   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd
    root     28707  0.0  0.0   4772   392 ?        S    15:05   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd
    root     28708  0.0  0.0   4772   392 ?        S    15:05   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd
    root     28709  0.0  0.0   4772   392 ?        S    15:05   0:00 /usr/sbin/saslauthd -m /var/run/saslauthd
    root     28965  0.0  0.1   6728  1748 ?        Ss   15:18   0:00 /usr/libexec/postfix/master
    postfix  28967  0.0  0.1   6740  1672 ?        S    15:18   0:00 pickup -l -t fifo -u
    postfix  28968  0.0  0.1   6792  1768 ?        S    15:18   0:00 qmgr -l -t fifo -u
    postfix  28973  0.0  0.1   6740  1744 ?        S    15:18   0:00 tlsmgr -l -t unix -u
    dovecot  29614  0.0  0.0   4156  1016 ?        S    16:05   0:00 pop3-login
    postfix  29621  0.0  0.1   6724  1668 ?        S    16:05   0:00 proxymap -t unix -u
    dovecot  29628  0.0  0.0   4156  1016 ?        S    16:06   0:00 pop3-login
    dovecot  29629  0.0  0.0   4156  1016 ?        S    16:06   0:00 pop3-login
    
    and on maillog I got this message
    Code:
    May 15 16:06:14 pop dovecot: pop3-login: Aborted login: rip=::ffff:207.150.248.3, lip=::ffff:207.150.248.253
    May 15 16:07:18 pop dovecot: pop3-login: Disconnected: Inactivity: user=<yaponte@girlracerpr.org>, method=PLAIN, rip=::ffff:207.150.248.3, lip=::ffff:207.150.248.253
    
    The pop/imap server used is dovecot, the one that comes default with Fedora 5 and used by the guide.

    Any help would be appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Make sure you use the correct username and password.
    Do you use ISPConfig?
     
  3. darkcoder

    darkcoder New Member

    yes, I use ISPConfig, follow the Recent Fedora5 howto, add a domain which in this case was girlracerpr.org. I can log in without problems to the website and put content on it. Also was able to browse the page, but was unable to login to the pop server.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Make sure you use the correct username and password, something like web1_someuser. Don't use ISPConfig users (such as clients and resellers), they exist only in ISPConfig and not on Linux itself!
     
  5. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    I got the same problem.

    I created a "User & Email" account which was 'web1_testuser' and gave it a password.

    Noticed it doesn't create an /etc/passwd entry so i don't expect POP3 to work.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    strace /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    ?
     
  7. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    Well the output is hugely long...

    here's the crop off the top. I noticed there's complaints about missing files, I thought ispconfig complains if things are missing on install?
    If you need more output. I'd better attach it in an email or something.

    strace /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php |more
    execve("/root/ispconfig/php/php", ["/root/ispconfig/php/php", "-q", "/root/ispconfig/scripts/writecon"...], [/* 23 vars */]) = 0
    brk(0) = 0x8ff2000
    access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
    open("/root/ispconfig/openssl/lib/tls/i686/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/root/ispconfig/openssl/lib/tls/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/root/ispconfig/openssl/lib/i686/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/root/ispconfig/openssl/lib/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/usr/lib/mysql/tls/i686/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/usr/lib/mysql/tls/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/usr/lib/mysql/i686/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/usr/lib/mysql/libcrypt.so.1", O_RDONLY) = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY) = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=91886, ...}) = 0
    mmap2(NULL, 91886, PROT_READ, MAP_PRIVATE, 3, 0) = 0xc74000
    close(3) = 0
    open("/lib/libcrypt.so.1", O_RDONLY) = 3
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Do you see a segmentation fault somewhere in the output?
     
  9. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    No. it just goes into a loop.. here's part of it.


    setitimer(ITIMER_PROF, {it_interval={0, 0}, it_value={0, 0}}, NULL) = 0
    setitimer(ITIMER_PROF, {it_interval={0, 0}, it_value={0, 0}}, NULL) = 0
    rt_sigaction(SIGPROF, {0x82a1660, [PROF], SA_RESTART}, {0x82a1660, [PROF], SA_RESTART}, 8) = 0
    rt_sigprocmask(SIG_UNBLOCK, [PROF], NULL, 8) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    nanosleep({1, 0}, {1, 0}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    nanosleep({1, 0}, {1, 0}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    nanosleep({1, 0}, {1, 0}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    nanosleep({1, 0}, {1, 0}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    nanosleep({1, 0}, {1, 0}) = 0
    stat64("/root/ispconfig/.ispconfig_lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /root/ispconfig
    ?
     
  11. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    # ls -la /root/ispconfig
    total 104
    drwxr-xr-x 9 root root 4096 May 20 14:20 .
    drwxr-x--- 25 root root 4096 May 30 08:51 ..
    -rwxr-xr-x 1 root root 33136 May 6 15:32 cronolog
    -rwxr-xr-x 1 root root 9673 May 6 15:32 cronosplit
    drwxr-xr-x 12 root root 4096 May 6 12:58 httpd
    drwxr-xr-x 13 root root 4096 May 6 15:32 isp
    -rw-r--r-- 1 root root 0 May 30 13:16 .ispconfig_lock
    -rw-r--r-- 1 root root 18 May 26 20:55 .old_path_httpd_root
    drwxr-xr-x 6 root root 4096 May 6 12:53 openssl
    drwxr-xr-x 6 root root 4096 May 6 13:15 php
    drwxr-xr-x 5 root root 4096 May 6 15:32 scripts
    drwxr-xr-x 4 root root 4096 May 6 15:32 standard_cgis
    drwxr-xr-x 3 root root 4096 May 6 15:32 sv
    -rwx------ 1 root root 9486 May 6 15:32 uninstall
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    rm -f /root/ispconfig/.ispconfig_lock
    The lock file is blocking ISPConfig.
     
  13. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    OK, removed the lock file and now I get the seg fault.

    lstat64("/home", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    lstat64("/home/admispconfig", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    lstat64("/home/admispconfig/ispconfig", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    lstat64("/home/admispconfig/ispconfig/ispconfig.log", {st_mode=S_IFREG|0644, st_size=78556, ...}) = 0
    open("/home/admispconfig/ispconfig/ispconfig.log", O_WRONLY|O_APPEND|O_CREAT, 0666) = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=78556, ...}) = 0
    lseek(5, 0, SEEK_CUR) = 0
    lseek(5, 0, SEEK_CUR) = 0
    write(5, "02.06.2006 - 18:27:56 => WARN - "..., 154) = 154
    close(5) = 0
    getcwd("/root", 4096) = 6
    time(NULL) = 1149236876
    open("/etc/passwd", O_RDONLY) = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=2397, ...}) = 0
    lseek(5, 0, SEEK_CUR) = 0
    stat64("/etc/passwd", {st_mode=S_IFREG|0644, st_size=2397, ...}) = 0
    read(5, "root:x:0:0:root:/root:/bin/bash\n"..., 8192) = 2397
    close(5) = 0
    --- SIGSEGV (Segmentation fault) @ 0 (0) ---
    +++ killed by SIGSEGV +++
    Process 19030 detached
    root@microweb:~ #
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

  15. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    back again.. so busy i wish i had more time for this.

    I was using the latest SVN but now I've reinstalled fedora and put the ISPConfig-2.2.1.tar.gz and replaced the bundled 5.1.2 php with 5.1.4 tar.gz file.
    it installed fine

    now i got other problems.. argh. created a site and gave the reseller ftp login access with login details but can't login. no /etc/password account for that either.

    strace gave no problems with this php 5.1.4
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Resellers never have an FTP login in ISPConfig.

    Only (email) users where the admin checkbox is checked may login with FTP to the webroot directory of their website.
     
  17. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    argh, damn it. Forgive me, i only get to work on this very late at night.

    OK. what if I don't want a mail system for the domain ie. hosting the website only. I now have to make an email address only to get FTP access??
    So there no way to create an FTP user only for the domain without emails accounts?

    btw, also noticed the SVN copy didn't save the External Mailserver and LocalMailserver on the options section.. fyi.
     
  18. falko

    falko Super Moderator ISPConfig Developer

    You can select "External Mailserver" for the main domain and all Co-Domains. Then you only have FTP accounts. :)


    Either a problem with your installation, or a problem in the SVN. You should have used the latest stable version.
     

Share This Page