Problems with PHPmyadmin

Discussion in 'Installation/Configuration' started by juergen71, Dec 26, 2011.

  1. juergen71

    juergen71 New Member

    i have installed my first server with ubuntu 10.04 and the perfect server guide from howtoforge with ispconfig 3.0.4.1
    then installed the second server from the german howto:
    http://www.howtoforge.de/anleitung/...dar-mit-ispconfig-3-aufsetzen-debian-squeeze/

    because the second server runs only the secondary dns WITHOUT the gui from ispconfig. the dns thing works fine (because till help me :).

    BUT i have a problem with phpmyadmin on server 2.

    i compare the php configs of the 2 servers with phpinfo() and every line is exact the same on both servers, only some lines with hostnames etc ...but the mysql section or the ini files loaded are 100% identical.

    also check the extension_dir in the phpinfo, it is this:
    /usr/lib/php5/20090626
    and there is also the mysql.so located

    i do a new installation with
    Code:
    apt-get remove --purge php5-mysql phpmyadmin
    
    apt-get install php5-mysql phpmyadmin
    
    but this also have no effect.

    in the apache access log is this error:
    Code:
    [26/Dec/2011:10:55:43 +0100] "GET /phpmyadmin/error.php?lang=de&dir=ltr&type=Fehler&error=Die+Erweiterung+%5Ba%40http%3A%2F%2Fphp.net%2Fmysql%40Documentation%5D%5Bem%5Dmysql%5B%2Fem%5D%5B%2Fa%5D+kann+nicht+geladen+werden.+Bitte+%C3%BCberpr%C3%BCfen+Sie+Ihre+PHP-Konfiguration.+-+%5Ba%40.%2FDocumentation.html%23faqmysql%40documentation%5DDokumentation%5B%2Fa%5D HTTP/1.1" 200 923 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1"
    i search since some hours for this error, but also google can't help me.

    is it possible that from the second servers with ispconfig3 installation without gui there is a configuration that disable phpmyadmin?

    thanks for your help!

    regards
    juergen

    here is the section from phpinfo for mysql:
    Code:
    302 mysql
    
    303 MySQL Support enabled
    
    304 Active Persistent Links 0
    
    305 Active Links 0
    
    306 Client API version 5.1.41
    
    307 MYSQL_MODULE_TYPE external
    
    308 MYSQL_SOCKET /var/run/mysqld/mysqld.sock
    
    309 MYSQL_INCLUDE -I/usr/include/mysql
    
    310 MYSQL_LIBS -L/usr/lib -lmysqlclient_r
    
    311 Directive Local Value Master Value
    
    312 mysql.allow_local_infile On On
    
    313 mysql.allow_persistent On On
    
    314 mysql.connect_timeout 60 60
    
    315 mysql.default_host no value no value
    
    316 mysql.default_password no value no value
    
    317 mysql.default_port no value no value
    
    318 mysql.default_socket /var/run/mysqld/mysqld.sock /var/run/mysqld/mysqld.sock
    
    319 mysql.default_user no value no value
    
    320 mysql.max_links Unlimited Unlimited
    
    321 mysql.max_persistent Unlimited Unlimited
    
    322 mysql.trace_mode Off Off
    
    323 mysqli
    
    324 MysqlI Support enabled
    
    325 Client API library version 5.1.41
    
    326 Active Persistent Links 0
    
    327 Inactive Persistent Links 0
    
    328 Active Links 0
    
    329 Client API header version 5.1.41
    
    330 MYSQLI_SOCKET /var/run/mysqld/mysqld.sock
    
    331 Directive Local Value Master Value
    
    332 mysqli.allow_local_infile On On
    
    333 mysqli.allow_persistent On On
    
    334 mysqli.default_host no value no value
    
    335 mysqli.default_port 3306 3306
    
    336 mysqli.default_pw no value no value
    
    337 mysqli.default_socket no value no value
    
    338 mysqli.default_user no value no value
    
    339 mysqli.max_links Unlimited Unlimited
    
    340 mysqli.max_persistent Unlimited Unlimited
    
    341 mysqli.reconnect Off Off
     
    Last edited: Dec 26, 2011
  2. juergen71

    juergen71 New Member

    i dont know exactly how but i solve this issue, i do a

    sudo dpkg-reconfigure -plow phpmyadmin

    fill in some names etc ...and after this i delete this names from /etc/phpmyadmin/config-db.php

    only this was there now:

    Code:
    $dbuser='';
    $dbpass='';
    $basepath='';
    $dbname='';
    $dbserver='';
    $dbport='';
    $dbtype='mysql';
    
    after this i restart the server and now phpmyadmin is working.
     

Share This Page