Problems with php safe mode on, can't turn it off

Discussion in 'Installation/Configuration' started by findafriend, Mar 2, 2008.

  1. findafriend

    findafriend New Member

    Hi

    I have tried in the Apache Directives for the user to turn safe mode off by writing one of the two lines (not at same time) :

    php_admin_flag safe_mode Off
    php_flag safe_mode off

    I have looked into /etc/apache/vhosts/Vhosts_ispconfig.conf

    And can see that the lines are written to disc.
    i have also tried to restart apache inside the control panel to turn safe mode off for one site only, but whatever I try websitebaker (which im trying to install) says safe mode it turned on, and I need it turned off for this site.

    I have also tried to manually edit Vhosts_ispconfig.conf for the site. save it and restart apache from the controlpanel, but nothing seems to work. Websitebaker says, that PHP safe mode is turned on.

    How do i turn it off ?
    By the way Till, you have made this installation, there where problems with the site running php 5, so you turned that on to let it run php 4, but that should not have to do with this ?

    Ok i have just tried to install websitebaker and it gave me the following errors :

    Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 10092 is not allowed to access /var/www/web70/web/pages/posts owned by uid 33 in /var/www/web70/web/modules/news/install.php on line 164

    Warning: fopen(/var/www/web70/web/pages/posts/index.php) [function.fopen]: failed to open stream: No such file or directory in /var/www/web70/web/modules/news/install.php on line 164

    Warning: fwrite(): supplied argument is not a valid stream resource in /var/www/web70/web/modules/news/install.php on line 165

    Warning: fclose(): supplied argument is not a valid stream resource in /var/www/web70/web/modules/news/install.php on line 166

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web70/web/modules/news/install.php:164) in /var/www/web70/web/framework/class.login.php on line 304

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web70/web/modules/news/install.php:164) in /var/www/web70/web/framework/class.login.php on line 146

    sincerely

    MJ
     
  2. findafriend

    findafriend New Member

  3. findafriend

    findafriend New Member

    The script giving these problem despite both php safe mode have been turned on (or do isp config overwrite these permissions ?) is websitebaker.

    Also have the file permissions been set to highest as possible to test it, but that didnt work either.

    Anyone in for a suggestion ?
     
  4. findafriend

    findafriend New Member

    Ok some more errors :

    websitebaker :

    Pages :
    Warning: main() [function.main]: SAFE MODE Restriction in effect. The script whose uid is 33 is not allowed to access ../config.php owned by uid 10092 in /var/www/web70/web/pages/billeder.php on line 3

    Warning: main(../config.php) [function.main]: failed to open stream: Success in /var/www/web70/web/pages/billeder.php on line 3

    Fatal error: main() [function.require]: Failed opening required '../config.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/web70/web/pages/billeder.php on line 3

    Templates


    Warning: main() [function.main]: Unable to access /var/www/web70/web/temp/unzip/info.php in /var/www/web70/web/admin/templates/install.php on line 61

    Warning: main(/var/www/web70/web/temp/unzip/info.php) [function.main]: failed to open stream: No such file or directory in /var/www/web70/web/admin/templates/install.php on line 61

    Fatal error: main() [function.require]: Failed opening required '/var/www/web70/web/temp/unzip/info.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/web70/web/admin/templates/install.php on line 61
     
  5. till

    till Super Moderator

    To turn safe mode off for a website, just disable the PHP Safemode checkbox in the settings of the website. Never change something in /etc/apache/vhosts/Vhosts_ispconfig.conf, it will get overwritten.
     

Share This Page