Problems with multiple PHP versions with FPM

Discussion in 'General' started by EX-Mats, Jan 17, 2019.

  1. EX-Mats

    EX-Mats New Member

    Hi!
    I installed Debian 9, latest ISPConfig and PHP following this guide:
    https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/
    Then installed multiple versions of PHP (PHP 7.1, PHP 7.22 and PHP 7.3) following this guide:
    https://www.howtoforge.com/how-to-u...fpm-and-fastcgi-with-ispconfig-3-ubuntu-12.10
    Except for PHP 7.3 where i use the same instructions as for PHP 7.2 but with extra installation of libzip to get it to work.

    When I use FastCGI and switch between the different PHP-versions phpinfo tells me it works as it should. But when I try the same with FPM it doesn't matter what version I select I always get PHP 7.3.

    Not a big problem, I don't need to run FPM but its nagging me :)

    Can't find any errors in any log files, have double check the configurations made when following the guides, rebooted server etc.
    Still the same problem.

    Anyone got a clue?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    EX-Mats likes this.
  3. Jesse Norell

    Jesse Norell Well-Known Member

    Agreed, the packages are much easier to use/setup. As far as troubleshooting your problem, it might be related to the fpm init scripts/config, where the stopping/starting of the different daemons fails, and/or some config is wrong; re-do the tutorials carefully and you can probably get it to work. Or just add the repos like @Taleman linked to and you can be up and running in minutes.
     
    EX-Mats likes this.
  4. EX-Mats

    EX-Mats New Member

    Thanks for your input, really helped!
    Sorry for late feedback! (Got caught up with other things.)

    Tried to run the first guide once again just to see if I hade done something wrong.
    This time I checked with make test and I saw that there was some warnings.. And I got the same problems when I was done.

    So I start over again with the guide @Takeman recommended and then everything works as it should.
    There I found something new to me, how to reset/revert the PHP back to the original.

    That helped me with another old installation (that I didn't set up from the beginning) where ISP had stopped working.
    Someone had added more PHP versions and forget to do that, so when I tried that ISP config startet to work again.
     

Share This Page