Problems with mod_deflate on Apache2

Discussion in 'Server Operation' started by cmer, Sep 29, 2006.

  1. cmer

    cmer New Member


    I am trying to configure mod_deflate on Apache2/Ubuntu (apt-get was used for Apache) following the instructions found at

    Everything works fine... well, almost. I get no error or anything, but no content is mod_deflated either. Here's what I get in my log file:

    "GET /static/css/ibox.css HTTP/1.1" -/- (-%)
    "GET /static/css/ibox.css HTTP/1.1" -/- (-%)
    "GET /static/css/olivegreenlover.css HTTP/1.1" -/- (-%)
    "GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)
    "GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)
    "GET /static/css/olivegreenlover.css HTTP/1.0" -/- (-%)

    Anybody has an idea of what might be going on? The module is enabled, and here's what I have in my apache2.conf file:

    # mod_infoate settings
    AddOutputFilterByType DEFLATE text/html text/plain text/xml
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # temporary
    DeflateFilterNote Input input_info
    DeflateFilterNote Output output_info
    DeflateFilterNote Ratio ratio_info
    LogFormat '"%r" %{output_info}n/%{input_info}n (%{ratio_info}n%%)' deflate
    CustomLog /var/log/apache2/deflate_log deflate


  2. falko

    falko Super Moderator ISPConfig Developer

    Please put it into your vhost configuration and restart Apache.
    Also check your Apache's error log.

Share This Page