Problems with Let´s Encrypt / crt file not created

Discussion in 'ISPConfig 3 Priority Support' started by BeNeDeLuX, Jan 15, 2017.

  1. BeNeDeLuX

    BeNeDeLuX New Member HowtoForge Supporter

    Hello there,
    i use ISPConfig 3.1 on Debian Jessie with nginx. I would like to secure a website with a Let´s Encrypt Certifcate, but the process failed.
    Here is the Debug-Log. I change my real domains to mydomain.tld and my-alias-domain.tld.
    Code:
    15.01.2017-21:29 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:29 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.01.2017-21:30 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:30 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.01.2017-21:31 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:31 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.01.2017-21:32 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:32 - DEBUG - Found 1 changes, starting update process.
    15.01.2017-21:32 - DEBUG - Processed datalog_id 961
    15.01.2017-21:32 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.01.2017-21:33 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:33 - DEBUG - Found 1 changes, starting update process.
    15.01.2017-21:33 - DEBUG - Calling function 'ssl' from plugin 'nginx_plugin' raised by event 'web_domain_update'.
    15.01.2017-21:33 - DEBUG - Calling function 'update' from plugin 'nginx_plugin' raised by event 'web_domain_update'.
    15.01.2017-21:33 - DEBUG - Create Let's Encrypt SSL Cert for: mydomain.tld
    15.01.2017-21:33 - DEBUG - Let's Encrypt SSL Cert domains: mydomain.tld --domains www.mydomain.tld --domains my-alias-domain.tld --domains www.my-alias-domain.tld --domains eyeconique.de --domains www.eyeconique.de --domains iconic-vision.de --domains www.iconic-vision.de
    15.01.2017-21:33 - DEBUG - exec: /usr/bin/letsencrypt certonly -n --text --agree-tos --expand --authenticator webroot --server https://acme-v01.api.letsencrypt.org/directory --rsa-key-size 4096 --email postmaster@mydomain.tld --domains mydomain.tld --domains www.mydomain.tld --domains my-alias-domain.tld --domains www.my-alias-domain.tld --domains eyeconique.de --domains www.eyeconique.de --domains iconic-vision.de --domains www.iconic-vision.de --webroot-path /usr/local/ispconfig/interface/acme
    15.01.2017-21:37 - DEBUG - Enable SSL for: mydomain.tld
    15.01.2017-21:37 - DEBUG - Writing the vhost file: /etc/nginx/sites-available/mydomain.tld.vhost
    15.01.2017-21:37 - DEBUG - Writing the PHP-FPM config file: /etc/php5/fpm/pool.d/web34.conf
    15.01.2017-21:37 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    15.01.2017-21:37 - DEBUG - Restarting php-fpm: systemctl reload php5-fpm.service
    15.01.2017-21:37 - DEBUG - nginx status is: running
    15.01.2017-21:37 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    15.01.2017-21:37 - DEBUG - Checking nginx configuration...
    15.01.2017-21:37 - DEBUG - nginx config test failed!
    15.01.2017-21:37 - DEBUG - nginx restart return value is: 1
    15.01.2017-21:37 - DEBUG - nginx online status after restart is: running
    15.01.2017-21:37 - WARNING - nginx did not restart after the configuration change for website mydomain.tld. Reverting the configuration. Saved non-working config as /etc/nginx/sites-available/mydomain.tld.vhost.err
    15.01.2017-21:37 - WARNING - Reason for nginx restart failure: nginx: [emerg] BIO_new_file("/var/www/clients/client68/web34/ssl/mydomain.tld.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/var/www/clients/client68/web34/ssl/mydomain.tld.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)
    nginx: configuration file /etc/nginx/nginx.conf test failed
    15.01.2017-21:37 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    15.01.2017-21:37 - DEBUG - Checking nginx configuration...
    15.01.2017-21:37 - DEBUG - nginx configuration ok!
    15.01.2017-21:37 - DEBUG - Restarting httpd: systemctl restart nginx.service
    15.01.2017-21:37 - DEBUG - Processed datalog_id 962
    15.01.2017-21:37 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    15.01.2017-21:38 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    15.01.2017-21:38 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    
    The crt file does not exist after the whole process - the customers ssl directory is empty.
    Is there another way to debug the problem ?

    Thanks for your help!
     

Share This Page