Problems with .htaccess in virtual host

Discussion in 'General' started by X-admin, Sep 30, 2009.

  1. X-admin

    X-admin New Member

    Hi all!
    I fall into a problem like this:
    I Install ISPConfig following the post:
    Everything work fine!
    But some day, my customer asks me “ How to do safe mode off in his website”

    First, I simply think “ make a .htaccess file with directive php-flag safe_mode off, then place in web root folder of this site, but seemly it doesn’t work. Phpinfo() show safe mode = on at both Local and Master Value. File .htaccess work very well for rewrite rules. I change php_flag directive into php_admin_flag, then server report Internal Server Error, website doesnot work

    From my knowledge, in think, perhaps I’m using suPHP because in the httpd.conf, there is a directive LoadModule suexec_module modules/ but not any mod_php though both modules was complied (httpd -t -D DUMP_MODULES). But in the, I’m using $go_info["server"]["apache2_php"] = 'addtype' not suphp, and I still chmod 777 for files and folders, this action is as opposed to suPHP methods

    So, in the Vhosts_isponfig.conf, I change php_admin_flag safe_mode Off, restart apache. OK, at this time, phpinfo() show Safe_mode = off but open_basedir and the rest of directives is removed automatically, this was dangerous. Half a day, System automatically set Safe_mode=On and restore all directives before

    So, who can tell me what php methods I’m using, can I use .htaccess file to do safe_mode off for each website? and explain me directive $go_info["server"]["apache2_php"] = 'addtype’? filter? engine?
    Many thanks!!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    To switch off safemode, simply uncheck the safemode checkbox in the website setings. No .htaccess needed.

Share This Page