1. Howdy,
    I'm running ISPConfig 2.2.33 now with over 3000 domainnames and having a lot problems.

    My first problem is that newly created users cannot upload files because they seem to have no rights though the admin checkbox is set. So I'm restarting everything and nothing helps but if I make a new http request on "user & email" in the ISP Web of the related domainname the user misteriously can upload files...this happens randomly on all available domainnames and I have no f*cking clue :).

    The second problem is that deleting a web can lead to strange problems.
    I deleted host "foobar.com" and re-created it and got a different user name "web3150" e.g. and I had "web350x" something before. When I uploaded my files with the new account details they got uploaded but they were not visible in the /var/www/www.foobar.com/web directory. I created a symlink to workaround the problem.

    I also can't access "foobar.com" because there is "ServerName www.foobar.com" in the vhost configuration of ispconfig but there is no "ServerAlias foobar.com" and I can't edit the file because it's auto-generated (of course).

    And another problem is that I create new webs which is a IDN and which isn't visible in this autogenerated vhost configuration...

    You see, I'm really having a lot problems I can't solve myself. The server is a very powerful one and almost has no load...

    I really hope you can give me some hints.

  2. Code:
    [root@~]# time /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 6289909 bytes) in /root/ispconfig/scripts/lib/classes/ispconfig_template.lib.php on line 218
    real    2m31.906s
    user    0m19.090s
    sys     0m0.696s
    I now raised the values for memory_limit, max_input_time, max_execution_time in /root/ispconfig/php/php.ini.

    And I now get:

    [root@~]# time /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    tar: Removing leading `/' from member names
    real    2m39.830s
    user    0m22.040s
    sys 0m1.562s
    Well, well! This seems to work!

  3. mhmhmh...I am still experiencing problems with ftp. Some users aren't able to upload due to "permission denied" messages but this is a random "bug". Sometimes this specific user can upload and sometimes he cannot.

    The trick to re-enable his upload abilities is to visit the user page where you can tick the "admin" setting which is always ticked though but only visiting that "page" helps...dunno really why.

    Any idea? Thanks!
  4. falko

    falko Super Moderator ISPConfig Developer

    To what directory are you trying to upload? Is the user the site admin or only a "normal" user?
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /var/www/www.the-domain-name.com/web/
  6. Well, I just noticed that this apache and web3528 user and group are set for all > 3000 domainnames but I remember this wasn't the case some days ago...

    The "admin" user of this foobar.com domainname is "web903_foo-bar.com" btw...

    I believe it's all about this /root/ispconfig/scripts/writeconf.php script because some hours ago I had one website where the "shared ip" message of isp config was shown and after I executed this script the website showed just fine :/...the script takes 2.35mins and sometimes just 40 seconds.

    Thanks for your help. I really appreciate it.
    Last edited: Sep 15, 2009
  7. falko

    falko Super Moderator ISPConfig Developer

    What happens when you run
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    manually? Maybe you need to raise PHP's memory limit.
  8. Please let me know where the permissions are set in what script. To some extent the permissions are just fine but then it's the same user and group set for all following domainnames.

    We already believe the script is pushing all the "permissions" into an array which then again fails at some point due to the amount of domainnames.

    Thanks in advance.
  9. falko

    falko Super Moderator ISPConfig Developer

    I think you must look in the function make_docroot() in /root/ispconfig/scripts/lib/config.lib.php.
  10. I really appreciate your help. We actually were looking in that file already but with no success at all. We turned on error reporting with notices and really tried to fight these strange behaviours but we were already losing too much time (and probably money, too) so we migrated all webs to plesk (9.2.2) in two days. My script just finished.

    Thanks for your patience and help.

    Andreas Schipplock.

Share This Page