problems with db backups

Discussion in 'General' started by nhybgtvfr, Aug 18, 2017.

  1. nhybgtvfr

    nhybgtvfr Member

    Hi.

    i'm running a multi-server setup, currently on 3.1.3
    i have several webservers, and a separate central db server.
    all servers are configured so that backups go to /var/backup, which is a mounted drive, exported from an nfs server.
    all servers are mounting the same drive.
    websites are being backed up ok, db backups are not being created.

    i've logged onto the db server and from /usr/local/ispconfig/server run php cron_debug.php --cronjob=500-backup-inc.php
    this creates the db backups, in the right folders without any errors.

    from the control panel, if i then delete the latest website and db backups for a site, the files are deleted from the mounted backup drive.
    their deleted from the webservers/db servers web_backup table, they're not deleted from the master db's web_backup table.

    these servers do have permission to update the master db, i rerun the update.php script for 3.1.3 on the db server yesterday and updated mysql permissions to ensure that, but it's behaviour is unchanged today.
    the servers are receiving updates from the master db, i've changed backup schedules in the control panel and checked the changes appeared ok in each webservers, dbservers own databases. they do.
    i've gone through the auth.log, cron.log, syslog etc on the servers, i can't find any problems.
    any ideas on what's going on here? and how to fix it?

    thanks.
    lee.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make a bug report in the bug tracker so we can check that.
     

Share This Page