Problems with creating/deleting email accounts

Discussion in 'Installation/Configuration' started by mxc, Jul 17, 2006.

  1. mxc

    mxc ISPConfig Developer ISPConfig Developer

    Hi all,

    It seems that we have somehow corrupted an entry in the database for dns. We have deleted a MX record and emptied the recycle bin. When we try and recreate the entry we kept on getting error messages that it already exists.

    I have looked at the pri. zone file and there is no entry in there. In addition it appears not to add the domain to the /etc/postfix/local-host-names file or the user to /etc/postfix/virtusertable file.

    We had a look at the database tables prefixed with dns_ but they are quite cryptic and doc_id appears to refer to different entity records in each table.

    Help please.
     
  2. mxc

    mxc ISPConfig Developer ISPConfig Developer

    oh yes --- it also wont create users for these domains. The database has the users in its tables and the web app show these users but mail just bounces from these accounts say "relay denied" and as said above there is no entry from them in the postfix config file.


    I also get "Duplicate Email Address" when trying to create a user who has been deleted from the domain. The recycle bin is also empty :(
    and the user is not in /home/adminispconfig/users
     
    Last edited: Jul 17, 2006
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    PLease enable " server requires authentication" in the SMTP settings of your mail client.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked that the MX is not in one of the recycle bins in the DNS-Manager part of ISPConfig?

    The MX records are not used for the postfix configuration.
     
  5. mxc

    mxc ISPConfig Developer ISPConfig Developer

    Hi Till,

    Thanks for the reply. I have checked the dns manager recycle bin is empty. The relay denied error message is printed in the maillog for mail sent to user@domain --- really wierd.


    I managed to overcome the duplicate email error by deleting the record from the isp_isp_user table. Somehow the user was not showing in the application but they where still in the table?

    Will continue to investigate. What tables are used to create the /etc/postifix/local-host-names and /etc/postfix/virtusertable files?
     
  6. mxc

    mxc ISPConfig Developer ISPConfig Developer

    Ok some more results of my investigation.

    1) It appears that this mess happens when a user accidently creates a web site with the domain name www.<domain> then deletes this site and recreates it, without empting the recycle bin, as just <domain>. It may be that they just edit the current record and remove www. This seems to confuse the isp_isp_domain table.

    2) I had to update the table isp_isp_domain and set the domain_host to null. This seems to fix postfix problems.

    3) I still have problems trying to delete and recreate the mx records. I keep being told the MX record is already registered. Its almost impossible to tell which record needs to be deleted from dns_mx as I am not sure what the doc_id links to. This doc_id appears refer to different entities in each table.

    " This or a similar MX Record does already exist in this zone." :(

    4) I found some orphaned cname records in dns_cname which I deleted. I really cant see how these tables are linked? The doc_id seems completely random and doesnt seem to link to primary keys in another table.
    Will report back later.
     
    Last edited: Jul 17, 2006

Share This Page