Problems with client websites

Discussion in 'General' started by jeeva, Sep 27, 2009.

  1. jeeva

    jeeva New Member


    Using ISPconfig3 + debian5 preconfigured-preinstalled distro from

    I've created a user, e.g. user1
    then I've created a website for user1, e.g.
    created a shell for user1 with no jail.
    setup the DNS, etc.

    So when I go to, i get

    Welcome to your website!
    This is the default index page of your website.
    This file may be deleted or overwritten without any difficulty. This is produced by the file index.html in the web directory.
    For questions or problems please contact support.
    Powered by ISPConfig
    When I FTP or SSH into user1. I get my directory list of /web /home /cgi-bin /etc /ssl /tmp /var, etc

    cd web
    /web$ rm -rf *
    now /web is blank
    I upload my website to /web, which is ofcourse full of files now including a new index.html & index.php.

    when i go to, I still get the "Welcome to your website - ISPconfig", eventhough I've replaced the files.

    What have I done wrong?

  2. tyre

    tyre New Member

    is the only site on the server? Or is a different domain (e.g. the main server domain.

    The reason I asked is I just had a problem similar, in that i had, I would add, and would show content. Change index.html on the to see if this is indeed the case.

    The problem was, as till pointed out, that I didn't have the server's IP setup in the system settings, and so since I had * selected as the IP - it was resolving to the main domains page, and not that of the user/domain that i had created.
  3. Stown

    Stown ISPConfig Developer ISPConfig Developer

    How do we even can setup a main domein? I have this same problem, i have now domains that point with the dns to my ispconfig server without the created domain in ispconfig, when i go to that domains, i get that is one of the 4 domains i setup in ispconfig.

    How can i change the main domain and when a domain points to my server ip it should be the message "Apache works" right?
  4. Mccy_McFlinn

    Mccy_McFlinn New Member

    Hello Stown,

    It all depends how you've configured apache. The default index.html for apache is the "it works!" page.

    It sounds like you've assigned the external IP address of your server to one of the sites you're hosting ( This has made that site the default site to be displayed if anyone navigates to the IP address of your server or uses a domain name that has a DNS record pointing to the server with no site configured as is your setup below.

    I'd check the default config file in /etc/apache2/sites-available. Make sure that it shows <Virtualhost *:80>. Then check the vhost file in the same directory. Make sure it shows <Virtualhost *:80> as it sounds like it's probably showing <Virtualhost> (where is your external ip address).

    Assuming that all host files show *:80 then the default index page will be displayed when navigating to the IP address of the server. You might want to change the default page to something more descriptive or personalised than the "it works!" page but that's just my personal choice.

    Any problems or questions then let me know.
  5. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Okay thank you. But what if i want that only works on and not on and This way i am creating a main domein or not? That should not be possible, looks like a bug or not?
    Last edited: Sep 28, 2009
  6. Mccy_McFlinn

    Mccy_McFlinn New Member

    This isn't a bug, this is how Apache is designed. I'd have to do some reading with regards to the finer details as I have far more experience with IIS. I'll check up and find how to specify a default domain for specified IP Addresses in apache and get back to you shortly.
  7. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Alright, now i did what you said. I edited from to * and now the points to the next domain you know. Now i did this with al the domains from to * and now points back to so it is no difference.
  8. Mccy_McFlinn

    Mccy_McFlinn New Member

    Ok, what does the default file say in /etc/apache2/sites-available. Make sure to check sites-enabled for the default file too - it may be named 001-default.
  9. Stown

    Stown ISPConfig Developer ISPConfig Developer

    How do you mean check the default file? I have only the domain vhosts and ispconfig vhost
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Apache is always using the first vhost for a given IP address if you enter just the IP. Which one is used first depends on the domain name as apache is sorting it alphabetically.

    So the easiest way to have a specific vhost for an IP, add a new website with a domain name that is definately the first one like: aaaaaaaaaaaaa.tld and upload the content there that shall be shown when the IP is used.
  11. Mccy_McFlinn

    Mccy_McFlinn New Member

    Ah ok. Well we can create a default file in sites-available with the content below (or you can specify your own details). Then link it in sites-enabled and restart apache.

    VirtualHost *:80>
            ServerAdmin webmaster@localhost
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            ErrorLog /var/log/apache2/error.log
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
            CustomLog /var/log/apache2/access.log combined
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from ::1/128
  12. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Is it not maybe an idea too add a <select> dropdown in server ip configs to change the default master domain for it? That is more controlable.
  13. Mccy_McFlinn

    Mccy_McFlinn New Member

    That is normally controlled the by default vhost file that's installed with apache. I'm not entirely sure why yours is not on your server.
  14. Stown

    Stown ISPConfig Developer ISPConfig Developer

    Aha, so i should have that file. Alright, could be because i recently reinstalled apache and ispconfig. When i get home i take a look in the old site-available folder ;-)
  15. Mccy_McFlinn

    Mccy_McFlinn New Member

    Perfect. Let me know if you require any further assistance. And for the record till's advice is perfectly sound and perfectly viable as an alternative solution especially as it's then controllable from the ISPConfig interface.

  16. reason8

    reason8 Member

    I am having this very same problem but on a second machine that I have just recently configured using the Perfect Server guide for OpenSuse 11.1

    In addition, the new files created on either websites are "Not Found" and giving me a 404 error but the default ISPConfig3 page "Welcome to your website!" is loaded on all websites via a browser. Even after deleting the index.html file originally created with a new domain the page is still loading.

    I have added the server IP and selected them for each account with so resolution of the problem. As I said, I have another box running the exact same Linux OS and version of ISPConfig 3 with the original box running perfectly.

    Could someone help me with this? Thanks!
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the system log in the monitoer? Have all items been processed in the jobqueue?
  18. reason8

    reason8 Member

    Thanks for tht response. I just realized that the second web server is trying to access port 80 which is being used by the first. Anyway to rectify this problem? I looked at the proxy reversal method but it was for debian and I could not get it to work with open suse 11.1

Share This Page