Problems with backup and monitor

Discussion in 'Installation/Configuration' started by Sergio W., Sep 20, 2021.

  1. Sergio W.

    Sergio W. New Member

    Hi,
    I'm just having 2 problems, maybe related, with a new ISPconfing installation, created with the automatic installation (nginx, PHP 7.4 & PHP 8).
    There also the htf_report.txt
    The server.php is running without problems, but the automatic backup is not working.
    I can launch the backup via the command:
    php /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php

    And it works, but doesn't automatically.
    Then the server is always red on the monitor page, It's saying that there is an error, but there aren't errors on the log, only debugs (because I previously had the debug level activated in order to see if there are errors).

    Can anybody help solving this?
    Thanks!
     

    Attached Files:

  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share your crontab?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    And post which error shows up there.
     
  4. Sergio W.

    Sergio W. New Member

    Sure, thanks!
    Crontab
    Code:
    [email protected] ~ # crontab -l
    55 0 * * * "/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh" > /dev/null
    * * * * * /usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    * * * * * /usr/local/ispconfig/server/cron.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    0 0 * * * /usr/local/ispconfig/server/scripts/create_daily_nginx_access_logs.sh &> /dev/null
    
    Regarding the monitor page I have no errors, only tons of debug.
    Code:
    State: error (0 unknown, 0 info, 0 warning, 0 critical, 1 error)
    
    Ok
    The state of your Hard-Disk space is ok [More...]
    Your virus protection is ok [More...]
    Your Mail queue load is ok [More...]
    Your RAID is ok [More...]
    Your Server load is ok [More...]
    All needed services are online [More...]
    Your system is up to date. [More...]
    
    Error
    There are errors in your system log [More...]
    
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, and now click on more in the error message and post the result. There must be records listed there.
     
  6. Sergio W.

    Sergio W. New Member

    That's weird, there are no results.
    [​IMG]
     
  7. Sergio W.

    Sergio W. New Member

    Any advice?
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Examine the log files in /var/log -directory. Useful file is for example syslog. Other files of interest are the latest after the event you want to examine, find the files with command
    Code:
    ls -lth /var/log | head
    Also: the htf_report shows
    Code:
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 8.0.10
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.23
    which means you are running PHP version 8.0 on command line. That is not supported on Ubuntu 20.04. Change default PHP back to what it is originally on Ubuntu 20.04.
    Code:
    update-alternatives --config php
    and
    update-alternatives --config php-cgi
     
  9. Sergio W.

    Sergio W. New Member

    Hi @Taleman , thanks for your support! That was the first change I made to setup back the 7.4 version (the automatic installer setted the 8.0), but the problems explained are still there. Also I examined log files finding nothing significally.
    It's the first time I'm using the automatic installer and first time I'm having this problem.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure? The installer has always set the correct PHP version here in the past and I don't have any issues on systems that are installed by using it, so I doubt that your issue is related to the auto installer.

    Regarding the original error, are there any warnings in the system log?
     
  11. Sergio W.

    Sergio W. New Member

    I'm pretty sure, I executed the installer with this command:
    Code:
    wget -O - https://get.ispconfig.org | sh -s -- --use-nginx --use-php=7.4,8.0 --use-ftp-ports=41100-41200 --unattended-upgrades --no-mail --no-dns --interactive
    And It was default on php 8.0.

    I only have debugs on the system log, no warnings.
     
    ahrasis likes this.
  12. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Well, in my experience, that is the Ubuntu usual behavior when Ondrej Sury multiple php versions are installed and/or updated.

    However, I do think the ISPConfig official installer does fix that after installing them as I haven't heard of this happened like in your case.

    In any event, though I know update-alternatives should work permanently on Debian, I am still using monit to monitor default php on Ubuntu.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, I'll see if I'm able to reproduce this. Might be related to the --use-php flag.
     
    ahrasis likes this.
  14. Sergio W.

    Sergio W. New Member

  15. till

    till Super Moderator Staff Member ISPConfig Developer

    I just made a test install using your exact installation command, PHP version is 7.4 and not 8.0.

    Code:
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.6
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 7.4.23
    [INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.23
    and I don't have any issues with system log errors. The monitor shows red though because mail service is not installed, but this is to be expected and can be changed by disabling mail under System > server services > mail server.
     
  16. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you checked what the PHP versions are now? Run again the htf_report or examine with the update-alternatives.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run both commands:

    update-alternatives --config php
    update-alternatives --config php-cgi

    again and check that both are set to PHP 7.4, if one of them is still PHP 8, then this will cause various issues.
     
  18. Sergio W.

    Sergio W. New Member

    Yes they are

    [​IMG]

    There is also the updated htf_report.txt
     

    Attached Files:

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try this, run this command as root:

    crontab -e

    indert a comment, e.g.:

    # comment

    and save it. Then check in ispconfig Ui after about an hour if the error message is gone and also check next day if backups are running. I had it in the past, it's very rare, that cron fails to apply a changed config and by editing the crontab and saving it after a modification, will force cron to reload in a way that it stats working again.
     
  20. Sergio W.

    Sergio W. New Member

    Very good, thanks!
    Will check in a few hours and make you know.
     

Share This Page