Problems with AWStats

Discussion in 'Server Operation' started by Cletus, Dec 14, 2011.

  1. Cletus

    Cletus New Member

    Dear all,

    I have AWStats configured on my Centos 5.7 box with ISPConfig 3 installed. After a lot of googleing i still cant get AWstats to work properly. Webalizer does work fine.

    when going to the /stats directory of your site you can login and you will see the jump thingy and below that an 404 error.

    I checked the daily cron thing on my server and started it manually to see error messages and i see this error message:

    Code:
    [root@duskwood spruitjes.org]# /usr/local/ispconfig/server/cron_daily.sh
    PHP Warning:  rename(/var/www/clients/client3/web3/web/stats/awstats.spruitjes.org.html,/var/www/clients/client3/web3/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
    PHP Warning:  rename(/var/www/clients/client6/web8/web/stats/awstats.soosrsa.nl.html,/var/www/clients/client6/web8/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
    finished.
    The sites are already up and running for a few weeks and with AWStats selected already longer than a day so i don't think that the 24 hour generation is the issue in this case.

    Can somebody give me the golden tip?

    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the paths to the awstats scripts in ISPConfig under System > Server Config match the real paths on your server.
     
  3. Cletus

    Cletus New Member

    Dear Till,

    Thanks for your answer, i already did some directory checking before posting this thread.

    The following configuration was active:

    awstats conf folder: /etc/awstats
    awstats data folder: /var/lib/awstats
    awstats.pl script: /usr/lib/cgi-bin/awstats.pl
    awstats_buildstaticpages.pl script: /usr/share/awstats/tools/awstats_buildstaticpages.pl

    This however generated the same errors as displayed above:

    I changed the directories to the following ones before i posted this thread and the error messages displayed above are with this directory settings. (Standard Centos 5.7 + ISPConfig 3 installation via: http://www.howtoforge.com/perfect-server-centos-5.7-x86_64-ispconfig-3)

    awstats conf folder: /etc/awstats
    awstats data folder: /var/www/awstats
    awstats.pl script: /var/www/awstats/awstats.pl
    awstats_buildstaticpages.pl script: /usr/bin/awstats_buildstaticpages.pl

    Can you tell me if there are any wrong path's?

    Thanks!
     
  4. Cletus

    Cletus New Member

    After a night of waiting i still get the 404 error :(

    Path's should be correct as far as i know with my newbie linux knowledge :)

    When manually executing the script the same error appears. Funny thing is though that i get a dropdownbox with the date of 2011-12 but below that the 404.

    Anyone? :)
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /usr/bin/awstats_buildstaticpages.pl

    and

    ls -la /usr/share/awstats/tools/awstats_buildstaticpages.pl
     
  6. Cletus

    Cletus New Member

    Dear Till,

    I only can find the first one:

    Code:
    [root@duskwood /]# find / -name awstats_buildstaticpages.pl
    /usr/bin/awstats_buildstaticpages.pl
    [root@duskwood /]#
    Code:
    [root@duskwood /]# ls -la /usr/bin/awstats_buildstaticpages.pl
    -rwxr-xr-x 1 root root 19594 Aug  4  2010 /usr/bin/awstats_buildstaticpages.pl
    Code:
    [root@duskwood /]# ls -la /usr/share/awstats/tools/awstats_buildstaticpages.pl
    ls: /usr/share/awstats/tools/awstats_buildstaticpages.pl: No such file or directory
    [root@duskwood /]#
     
  7. Cletus

    Cletus New Member

    Anyone? :)
     
  8. Donald

    Donald New Member

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    @Donald: Your link is for CPanel but the first poster uses ISPConfig. Cpanel is a different controlpanel.

    @Cletus: The script path is fine.

    Please post the output of:

    ls /etc/awstats
    ls -la /var/www/awstats/awstats.pl
     
  10. Cletus

    Cletus New Member

    Hi All,

    Thanks :)

    Here are the outputs:

    ls /etc/awstats (and an ls -l /etc/awstats)
    Code:
    [root@duskwood ~]# ls /etc/awstats
    awstats.forum.wow-nerds.nl.conf     awstats.photo.guild-error.com.conf
    awstats.localhost.localdomain.conf  awstats.soosrsa.nl.conf
    awstats.model.conf                  awstats.spruitjes.org.conf
    [root@duskwood ~]# ll /etc/awstats
    total 152
    -rw-r--r-- 1 root root   191 Dec 13 18:50 awstats.forum.wow-nerds.nl.conf
    -rw-r--r-- 1 root root 61665 Apr  9  2011 awstats.localhost.localdomain.conf
    -rw-r--r-- 1 root root 61665 Apr  9  2011 awstats.model.conf
    -rw-r--r-- 1 root root   208 Dec 22 00:30 awstats.photo.guild-error.com.conf
    -rw-r--r-- 1 root root   175 Dec 22 00:30 awstats.soosrsa.nl.conf
    -rw-r--r-- 1 root root   184 Dec 22 00:30 awstats.spruitjes.org.conf
    [root@duskwood ~]#
    ls -la /var/www/awstats/awstats.pl
    Code:
    [root@duskwood ~]# ls -la /var/www/awstats/awstats.pl
    -rwxr-xr-x 1 root root 657790 Oct 16  2010 /var/www/awstats/awstats.pl
    [root@duskwood ~]#
    Thanks! :)
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats both ok. I've no idea why it does not work on your server, maybe the installed awstats pckage is broken somehow.
     
  12. djoey

    djoey New Member

    Hi,

    I had the same problem.
    all created awstats.domain.tld.conf files are looking for an include. This include is supposed to be /etc/awstats/awstats.conf this didn't exist for me on centos.
    I have copied /etc/awstats/awstats.model.conf to /etc/awstats/awstats.conf and then it worked.
     
  13. ferro_i

    ferro_i New Member

    Tanks, djoey
    Your solution worked for me (centos 6.2 apache)
     

Share This Page