Problems with Aliases and Forwards

Discussion in 'General' started by ipstatic, Nov 13, 2009.

  1. ipstatic

    ipstatic New Member

    Hello All,
    I am having an issue with aliases and forwards where the messages are not being delivered. I have noticed two things.

    First, when sending from one of the virtual accounts to an aliased account, Postfix does not recognize the account is on the box.

    bob@example.com sends an email to alias@example.com (which is an alias). Instead of trying to deliver the mail locally, Postfix uses the relayhost we have setup.

    Second, when I telnet to the mail server and send an email to alias@example.com, the mail server will accept it. However, it will deliver it to a mailbox named alias, not to bob's mailbox.

    Here is the main.cf:

    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf


    Here is testing the SQL select:
    select destination from mail_forwarding where source='alias@example.com';
    +--------------------------+
    | destination |
    +--------------------------+
    | bob@example.com |
    +--------------------------+

    Thanks
     
  2. falko

    falko Super Moderator

    Can you post your full main.cf?

    Any errors in your mail log?
     

Share This Page