Problems w/ setting up server

Discussion in 'Installation/Configuration' started by frlstream, Jan 1, 2018.

  1. frlstream

    frlstream New Member

    Hi guys,

    We are coming from Vesta based server and we have some troubles setting up our ispconfig 3 server.
    We followed the following tut: https://www.howtoforge.com/tutorial/perfect-server-ubuntu-with-nginx-and-ispconfig-3/2/

    We got the following problems:

    #1 firewall is not working, it blocks everything
    TCP 20,21,22,25,53,80,110,143,443,587,993,995,3306,8080,8081,10000
    UDP 53,3306
    When set to active it blocks all ports.
    When disabled or deleted all is good.

    Side note: The router is setup correctly on the internal IP adress (192.168.2.xx), the server is static en the router is bind bij Mac adress

    #2 Login only possible from internal IP
    This applies for the ispconfig console, ftp, mail, phpmyadmin, remote SSH direct into the server via putty is possible.

    #3 Mail is not working
    mxtoolbox diag the following:
    [​IMG] mx. frieslandstream.nl DNS Record not found
    [​IMG] dmarc frieslandstream.nl DNS Record not found
    [​IMG] dns frieslandstream.nl SOA Serial Number Format is Invalid
    [​IMG] dns frieslandstream.nl SOA Expire Value out of recommended range

    We hope you can lead us in the right direction
     
  2. ahrasis

    ahrasis Well-Known Member

    That is my build as well and it is all working well with dynamic ip. Is your server in dmz or ports are forwarded to it via router?
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The IP-addreses 192.168.0.0/16 are from RFC 1918 Private Address space. http://www.faqs.org/rfcs/rfc1918.html
    Those addresses are not routable from Internet. They work from your internal net as you have tested. To get to your server from outside there must be a box with routable IP adrress where you do forwarding to that private addess space server.
    There seems to be DNS entry for that host, but no MX record.
    The host command should show also "mail is handled by" -line if MX record is set up for that domain. MX record points to the mail server that receives mail for @frieslandstream.nl addresses,
     
  4. frlstream

    frlstream New Member

    The server is behind a router with all the ports directed it's way. In our case:
    TCP 20,21,22,25,53,80,110,143,443,587,993,995,3306,8080,8081,10000
    UDP 53,3306
     
  5. ahrasis

    ahrasis Well-Known Member

    How did you set your firewall?
     
  6. frlstream

    frlstream New Member

    Sorry for the late reply, been a busy couple of weeks. Starting the new year.
    In my router I deleted all port entries, after setting everything up, crosschecking everything, thinks started working. Both firewalls on the server and router are working fine now. Don't know why. Problem solved. Its the same as before, but its working now. Ow and I turned DMZ on, maybe that did the trick.

    @Taleman I'll be working on this problem tonight
    #3 Mail is not working
    mxtoolbox diag the following:
    [​IMG] mx. frieslandstream.nl DNS Record not found
    [​IMG] dmarc frieslandstream.nl DNS Record not found
    [​IMG] dns frieslandstream.nl SOA Serial Number Format is Invalid
    [​IMG] dns frieslandstream.nl SOA Expire Value out of recommended range

    Also SOAP isn't working, but I will investigate (google) the problem fist for my self.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that the php soap extension is installed.
     
  8. frlstream

    frlstream New Member

    We are running SOAP on PHP 7.0.22
    Code:
    soap
    
    Soap Client.                        enabled
    Soap Server                              enabled
    Directive                                   Local Value         Master Value
    soap.wsdl_cache                        1                      1
    soap.wsdl_cache_dir                   /tmp                 /tmp
    soap.wsdl_cache_enabled            1                     1
    soap.wsdl_cache_limit                 5                     5
    soap.wsdl_cache_ttl                    86400              86400
    Meanwhile we got it working, forgot the enable remote access checkbox *N00B*
     
    Last edited: Jan 15, 2018

Share This Page