Problems using Filezilla

Discussion in 'ISPConfig 3 Priority Support' started by Daninor, Aug 5, 2019.

  1. Daninor

    Daninor New Member

    Hello, I am having a problem using Filezilla with pureftpd.

    This suddently started happening, and it only happens in Filezilla. I have been reading that it is a problem with the PureFTPD version, but I did not find any solutions. Do you have any ideas? What info do you need to help me?


    Status: Resolving address of cp.xxxx.com
    Status: Connecting to xxxxxxxxxx:21...
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 1 of 50 allowed.
    Response: 220-Local time is now 19:01. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: AUTH TLS
    Response: 234 AUTH TLS OK.
    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Command: USER xxxxxxxx
    Error: GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.
    Status: Server did not properly shut down TLS connection
    Error: Could not read from socket: ECONNABORTED - Connection aborted
    Error: Could not connect to server
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's actually an incompatibility problem introduced by latest FileZilla in conjunction with pure-ftpd and TLS 1.3. There are basically two options, either change the client side by downgrading FileZilla or using a different FTP client or you try to get the latest pure-ftpd version either by compiling it or by trying to use the package from a newer version of your OS.
     
  3. Daninor

    Daninor New Member

    I am using Ubuntu 18.04. Do you know how often they release updates to the PureFTP package? Or how do I change the package?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I can't tell you how often they release updates. It might be that you have to try to install a version from Ubuntu 19.04 by apt pinning. But have not tried that yet as I don't use FileZilla.
     
    Daninor likes this.
  5. Daninor

    Daninor New Member

    Thanks for your reply. I'll wait for them to release an update for it, and use another client in the meantime.
    Topic can be closed.
     

Share This Page