Problems updating 2.2.19 to 2.227

Discussion in 'Installation/Configuration' started by esezako, Dec 1, 2008.

  1. esezako

    esezako New Member

    Hi, this is my first post.
    I have a devian etch with ispc 2.2.19.
    I have tried to update to the version 2.2.27 and the server has stopped working.
    It has eliminated the folder /root/ispconfig/scripts/, the file cronolog, and more things.
    The majority of the things that are done throw of ispconfig do not execute (add webs, modify quotas, ...)
    During the update I did not see errors and nevertheless continue with the version 2.2.19.
    Help please!! It is a server in production with more than 80 sites!!

    Sorry for my bad english
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the exact error message that you got on the screen as the update failed.

    Before you try to run the update script again, make sure that you run;

    mkdir /root/ispconfig

    or you might loose all your settings.
  3. esezako

    esezako New Member

    Hello, which are the steps that I must follow? I am afraid of losing all the information.

    I was going to do this:

    cd /home/install_ispconfig/

    The directory /root/ispconfig already exists
  4. esezako

    esezako New Member

    Any How to upgrade ISPConfig? Please. Thanks
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. esezako

    esezako New Member

    It's necesary that the apache and mysql are offline?
  7. esezako

    esezako New Member

    Well, already it is solved.

    Looking ispconfig_install.log I saw this:

    vie nov 28 17:36:05 CET 2008 - [ISPConfig] - Could not connect to db ispconfig

    And recorde that to liberate space before the upgrade I erased the files of log of mysql, but not the file index. Because of it the connection trumped to the BD.

    I have returned to execute ./setup and the whole Ok

    Thank you for everything

Share This Page