Problems to send and to receive e-mail with ispconfig

Discussion in 'Installation/Configuration' started by chua_jose, Jan 4, 2008.

  1. chua_jose

    chua_jose New Member

    Hello to all, I have a problem with the e-mails. I can neither send nor receive mail.
    When sending a mail from for example squirrelmail, it continues waiting and after 5 minutes there goes out a message that says "Error" Nothing more.
    it´s my main.cf:
    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = $myhostname, localhost.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    smtpd_sasl_authenticated_header = yes
    myhostname = xxxxxxxxxx.com
    home_mailbox = Maildir/
    mailbox_command =
    virtual_maps = hash:/etc/postfix/virtusertable
    This is my log file:
    Code:
    Jan  4 10:14:58 SD1111100130 postfix/smtpd[22852]: connect from localhost.localdomain[127.0.0.1]
    Jan  4 10:14:58 SD1111100130 postfix/smtpd[22852]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan  4 10:15:19 SD1111100130 postfix/smtpd[22867]: connect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 10:15:19 SD1111100130 postfix/smtpd[22867]: setting up TLS connection from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 10:15:29 SD1111100130 postfix/smtpd[22867]: SSL_accept error from cm103174.red91-117.mundo-r.com[91.117.103.174]: -1
    Jan  4 10:15:29 SD1111100130 postfix/smtpd[22867]: lost connection after CONNECT from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 10:15:29 SD1111100130 postfix/smtpd[22867]: disconnect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 10:15:49 SD1111100130 postfix/smtpd[22867]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 10:15:49 SD1111100130 postfix/smtpd[22867]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 10:15:58 SD1111100130 postfix/smtpd[22852]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
    Jan  4 10:15:58 SD1111100130 postfix/smtpd[22852]: warning: TLS library problem: 22852:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:
    Jan  4 10:15:58 SD1111100130 postfix/smtpd[22852]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jan  4 10:15:58 SD1111100130 postfix/smtpd[22852]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  4 10:17:30 SD1111100130 dovecot: pop3-login: Aborted login: rip=::ffff:91.117.103.174, lip=::ffff:213.60.254.125
    

    When in the line of commands I write
    telnet localhost 25, i recibe:
    Code:
    [root@SD1111100130 etc]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    
    And it does not continue.

    I use de perfect instalation of Centos5 (my system is RH Entrerprise 5 64 Bit)

    In Ispconfig - management - status - services it´s all ok
    Code:
    Web-Server: Online
    FTP-Server: Online
    SMTP-Server: Online
    POP3-Server: Online
    BIND-Server: Online
    mySQL-Server:Online
    But in my nagios:
    Code:
    	
    SMTP CRITICAL 	01-04-2008 10:16:04 	0d 19h 8m 17s 	    3/3 	CRITICAL - Socket timeout after 10 seconds
    POP3  OK 	   01-04-2008 10:18:16 	    0d 17h 52m 5s 	1/3 	POP OK - 0,678 second response time on port 110 [+OK Dovecot ready.]  
    If I scan my server whit nmap:
    Code:
    Discovered open port 25/tcp on xx.xx.xx.xx
    Discovered open port 53/tcp on xx.xx.xx.xx
    Discovered open port 21/tcp on xx.xx.xx.xx
    Discovered open port 22/tcp on xx.xx.xx.xx
    Discovered open port 443/tcp on xx.xx.xx.xx
    Discovered open port 80/tcp on xx.xx.xx.xx
    Discovered open port 81/tcp on xx.xx.xx.xx
    Discovered open port 8009/tcp on xx.xx.xx.xx
    Discovered open port 110/tcp on xx.xx.xx.xx
    Can someone help me?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change the mydestination line in main.cf to:

    mydestination = /etc/postfix/local-host-names

    and restart postfix.
     
  3. chua_jose

    chua_jose New Member

    thanks for your help

    I continue without being able to send nor receive mail

    now in maillog:
    Code:
    Jan  4 11:49:16 SD1111100130 dovecot: Killed with signal 15
    Jan  4 11:49:16 SD1111100130 dovecot: Dovecot v1.0.rc15 starting up
    Jan  4 11:50:16 SD1111100130 postfix/smtpd[25884]: connect from localhost.localdomain[127.0.0.1]
    Jan  4 11:50:16 SD1111100130 postfix/smtpd[25884]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan  4 11:50:19 SD1111100130 postfix/smtpd[25887]: connect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 11:50:19 SD1111100130 postfix/smtpd[25887]: setting up TLS connection from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 11:50:29 SD1111100130 postfix/smtpd[25887]: SSL_accept error from cm103174.red91-117.mundo-r.com[91.117.103.174]: -1
    Jan  4 11:50:29 SD1111100130 postfix/smtpd[25887]: lost connection after CONNECT from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 11:50:29 SD1111100130 postfix/smtpd[25887]: disconnect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 11:50:36 SD1111100130 postfix/smtpd[25887]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 11:50:36 SD1111100130 postfix/smtpd[25887]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 11:51:16 SD1111100130 postfix/smtpd[25884]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
    Jan  4 11:51:16 SD1111100130 postfix/smtpd[25884]: warning: TLS library problem: 25884:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:
    Jan  4 11:51:16 SD1111100130 postfix/smtpd[25884]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jan  4 11:51:16 SD1111100130 postfix/smtpd[25884]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  4 11:51:16 SD1111100130 dovecot: imap-login: Login: user=<xxxxxx.com_jose>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Jan  4 11:51:16 SD1111100130 dovecot: IMAP(xxxxxxxxx.com_jose): Disconnected: Logged out
    Jan  4 11:51:30 SD1111100130 dovecot: imap-login: Login: user=<xxxxxxxx.com_jose>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Jan  4 11:51:31 SD1111100130 dovecot: IMAP(xxxxxxx.com_jose): Disconnected: Logged out
    Jan  4 11:51:32 SD1111100130 dovecot: imap-login: Login: user=<xxxxxxxxxxxx.com_jose>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Jan  4 11:51:32 SD1111100130 dovecot: IMAP(xxxxxxx.com_jose): Disconnected: Logged out
    Jan  4 11:51:37 SD1111100130 postfix/smtpd[25884]: connect from localhost.localdomain[127.0.0.1]
    Jan  4 11:51:37 SD1111100130 postfix/smtpd[25884]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan  4 11:52:30 SD1111100130 dovecot: pop3-login: Aborted login: rip=::ffff:91.117.103.174, lip=::ffff:213.60.254.125
    Jan  4 11:52:37 SD1111100130 postfix/smtpd[25884]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
    Jan  4 11:52:37 SD1111100130 postfix/smtpd[25884]: warning: TLS library problem: 25884:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:
    Jan  4 11:52:37 SD1111100130 postfix/smtpd[25884]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jan  4 11:52:37 SD1111100130 postfix/smtpd[25884]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  4 11:52:51 SD1111100130 dovecot: imap-login: Login: user=<xxxxxxx.com_jose>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
    Jan  4 11:52:51 SD1111100130 dovecot: IMAP(xxxxxxxxxxxx.com_jose): Disconnected: Logged out
    
    
    thanks
     
    Last edited: Jan 4, 2008
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please recreate the postfix SSL certificates as they are broken or missing as described in the perfect setup guide for your linux distribution.
     
  5. chua_jose

    chua_jose New Member

    I have done as it is indicated in the perfect guide of system for my distribution, but it continues without it works

    Code:
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3649]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3649]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3652]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3652]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3653]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3653]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3654]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:38 SD1111100130 postfix/smtpd[3654]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:18:41 SD1111100130 postfix/smtpd[3655]: connect from localhost.localdomain[127.0.0.1]
    Jan  4 12:18:41 SD1111100130 postfix/smtpd[3655]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan  4 12:19:36 SD1111100130 postfix/smtpd[3670]: connect from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:19:36 SD1111100130 postfix/smtpd[3670]: setting up TLS connection from 74.101.14.62.static.jazztel.es[62.14.101.74]
    Jan  4 12:19:41 SD1111100130 postfix/smtpd[3655]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
    [B]Jan  4 12:19:41 SD1111100130 postfix/smtpd[3655]: warning: TLS library problem: 3655:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:[/B]
    Jan  4 12:19:41 SD1111100130 postfix/smtpd[3655]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Jan  4 12:19:41 SD1111100130 postfix/smtpd[3655]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  4 12:20:19 SD1111100130 postfix/smtpd[3655]: connect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 12:20:19 SD1111100130 postfix/smtpd[3655]: setting up TLS connection from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 12:20:29 SD1111100130 postfix/smtpd[3655]: SSL_accept error from cm103174.red91-117.mundo-r.com[91.117.103.174]: -1
    Jan  4 12:20:29 SD1111100130 postfix/smtpd[3655]: lost connection after CONNECT from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Jan  4 12:20:29 SD1111100130 postfix/smtpd[3655]: disconnect from cm103174.red91-117.mundo-r.com[91.117.103.174]
    Also I have detected that with the program nmap shows the following thing:
    PORT STATE SERVICE VERSION
    21/tcp open ftp ProFTPD
    22/tcp open ssh OpenSSH 4.3 (protocol 2.0)
    25/tcp open ssl OpenSSL
    53/tcp open domain
    80/tcp open http Apache httpd 2.2.3 ((Red Hat))
    |_ HTML title: Site doesn't have a title.
    81/tcp open http Apache httpd 1.3.39 ((Unix) PHP/5.2.4 mod_ssl/2.8.30 OpenSSL/0.9.7m)
    |_ HTML title: 400 Bad Request
    110/tcp open pop3 Dovecot pop3d
    113/tcp closed auth
    443/tcp open ssl OpenSSL

    is it ok??


    I have Rh Enterprise 5 64 bit, and i try with:
    The Perfect Setup - CentOS 4.3 (64-bit)
    The Perfect Setup - CentOS 5.0 (32-bit)
    CentOS 5.1 Server Setup: LAMP, Email, DNS, FTP, ISPConfig (a.k.a. The Perfect Server)
    Fedora 8 Server Setup: LAMP, Email, DNS, FTP, ISPConfig (a.k.a. The Perfect Server)

    Code:
     [root@SD1111100130 ~]# uname -m
    x86_64
    

    Thank you for your help, I am a bit lost.
    It does a little time I installed ispconfig and did not find any problem

    thanks
     
    Last edited: Jan 4, 2008
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to connect to your server without SSL, to see if the overall setup works.
     
  7. chua_jose

    chua_jose New Member

    If attempt to connect without ssl, I can accede neither to the mail nor to the panel of control of the ispconfig.

    Code:
    Bad Request
    Your browser sent a request that this server could not understand.
    
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    
        Hint: https://www.xxxxxxxxxxxx.net:81/
    :(
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am talking about your mail application (thunderbird, outlook, outlook express opera mail, etc) and not the webbrowser.
     
  9. chua_jose

    chua_jose New Member

    i use webmail squirrelmail.

    but if i configure outlook i recive this message:

    Code:
    It was not possible to find the host "pop.xxxxxxxx.com". Verify the name of the servant. It counts: 'pop.xxxxxxxxxx.com', Servant: 'pop.xxxxxxxx.com', Protocol: POP3, Port: 995, Security (SSL): Yes, Mistake of socket: 11004, Number of mistake: 0x800CCC0D
    or without SSL:

    Code:
    It was not possible to find the host "pop.xxxxxxxx.com". Verify the name of the servant. It(he,she) counts: 'pop.xxxxxxxxxxxxxx.com', Servant: 'pop.xxxxxxxxxx.com', Protocol: POP3, Port: 110, Security (SSL): Not, Mistake of socket: 11004, Number of mistake: 0x800CCC0D
     
    Last edited: May 6, 2008
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you created a DNS A-Record for pop.hostingacela.com that points to your server? If not, you will have to create this dns A-Record or use the IP address as pop3 and smtp server address instead.
     
  11. Rockdrala

    Rockdrala New Member

    lol















    ...

    I guess that fixed it for him.
     
  12. chua_jose

    chua_jose New Member

    If I write in the server pop:
    xxxxxxxx.com
    yes it works, but if I write
    pop.xxxxxxxxx.com
    does not work.
    If I create an entry DNS A Record, yes it works
    There is some way of doing it automatic for all the domains that are given of discharge?
    and doing it automatic for ftp too?


    Now already I can send and receive mail ok


    I checked in ISP-domain:
    Create DNS and Create DNS-MX
    and check in management - server -settings -dns
    Default MX

    How change ANSWER SECTION MX www.xxxxxxxxxxxxxx.com to xxxxxxxxxxxxxx.com

    Thanks for all
     
    Last edited: Jan 5, 2008
  13. dongsky

    dongsky New Member

  14. falko

    falko Super Moderator ISPConfig Developer

    The link doesn't work. Can you post your maillog here directly?
     
  15. mrthangvn

    mrthangvn New Member

    I have the same problem when i try:
    [root@localhost ~]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    Connection closed by foreign host.
    Nothing happen.

    Here's my main.cf

    and log:
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Please remove inet_interfaces = localhost from your main.cf and restart Postfix.
     
  17. mrthangvn

    mrthangvn New Member

    Thanks, but it still doesnt works:(
     
  18. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? Are there any other errors in your mail log?

    Can you post your main.cf again?
     

Share This Page