Problems to Install Zimbra in UBUNTU 7.04

Discussion in 'HOWTO-Related Questions' started by Stack A Brown, May 25, 2007.

  1. Stack A Brown

    Stack A Brown New Member

    I followed How To Install Zimbra Collaboration Suite (ZCS) On Ubuntu here.

    Everything goes great until halfway step 3.

    Code:
    Checking for prerequisites...
        NPTL...FOUND
        sudo...MISSING
        libdin...MISSING
        curl....MISSING
        fetchmail....MISSING
        gmp....MISSING
        /usr/lib/libstdc++.so.5...MISSING
    
    ###ERROR####
    
    One or more prerequisite packages are missing.
    Please install them before running this installer.
    
    Installation Cancelled
    
    I used this package of Zimbra:
    Code:
    wget http://downloads.zimbra.com/4.5.5_GA/zcs-NETWORK-4.5.5_GA_838.UBUNTU6.tgz
    unpack:
    tar zcs-NETWORK-4.5.5_GA_838.UBUNTU6.tgz
    cd zcs/
    ./install.sh
    How install missing packages to continue installation of Zimbra?

    Thanks for you help!

    Stack A Brown
    Monterrey - Mexico
     
    Last edited: May 25, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Stack A Brown

    Stack A Brown New Member

    This is all steps I do to install Zimbra in Ubuntu 7.04, I follow the installation guide, what is the error!

    Code:
    login as: root
    [email protected]'s password:
    Last login: Mon May 28 14:37:04 2007
    Linux mail.indmex.com 2.6.20-15-server #2 SMP Sun Apr 15 07:41:34 UTC 2007 i686
    
    The programs included with the Ubuntu system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
    applicable law.
    [email protected]:~# vi /etc/apt/sources.list
    [email protected]:~# apt-get update
    Ign cdrom://Ubuntu-Server 7.04 _Feisty Fawn_ - Release i386 (20070415) feisty/main Translation-es
    Ign cdrom://Ubuntu-Server 7.04 _Feisty Fawn_ - Release i386 (20070415) feisty/restricted Translation-es
    .
    .
    .
    Descargados 3B en 2s (1B/s)
    Leyendo lista de paquetes... Hecho
    [email protected]:~# /etc/init.d/postfix stop
    -bash: /etc/init.d/postfix: No such file or directory
    [email protected]:~# update-rc.d -f postfix remove
     Removing any system startup links for /etc/init.d/postfix ...
    
    [B][email protected]:~# apt-get install curl fetchmail libpcre3 libgmp3c2 libexpat1 libxml2 libtie-ixhash-perl[/B]
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Reading state information... Hecho
    Se instalarán los siguientes paquetes extras:
      ca-certificates libcurl3 libidn11 openssl
    Paquetes sugeridos:
      fetchmailconf postfix mail-transport-agent resolvconf
    Paquetes recomendados
      xml-core
    Se instalarán los siguientes paquetes NUEVOS:
      ca-certificates curl fetchmail libcurl3 libexpat1 libgmp3c2 libidn11 libpcre3 libtie-ixhash-perl libxml2
      openssl
    0 actualizados, 11 se instalarán, 0 para eliminar y 10 no actualizados.
    Se necesita descargar 812kB/3346kB de archivos.
    Se utilizarán 8471kB de espacio de disco adicional después de desempaquetar.
    ¿Desea continuar [S/n]? s
    Des:1 http://es.archive.ubuntu.com feisty/main fetchmail 6.3.6-1ubuntu2 [365kB]
    Des:2 http://es.archive.ubuntu.com feisty/main libgmp3c2 2:4.2.1+dfsg-4build1 [436kB]
    Des:3 http://es.archive.ubuntu.com feisty/main libtie-ixhash-perl 1.21-2 [11,9kB]
    Descargados 812kB en 12s (65,9kB/s)
    Preconfigurando paquetes ...
    Seleccionando el paquete openssl previamente no seleccionado.
    (Leyendo la base de datos ...
    14353 ficheros y directorios instalados actualmente.)
    Desempaquetando openssl (de .../openssl_0.9.8c-4build1_i386.deb) ...
    Creating directory /etc/ssl
    Seleccionando el paquete ca-certificates previamente no seleccionado.
    Desempaquetando ca-certificates (de .../ca-certificates_20061027_all.deb) ...
    Seleccionando el paquete libidn11 previamente no seleccionado.
    Desempaquetando libidn11 (de .../libidn11_0.6.5-1build1_i386.deb) ...
    Seleccionando el paquete libcurl3 previamente no seleccionado.
    Desempaquetando libcurl3 (de .../libcurl3_7.15.5-1ubuntu2_i386.deb) ...
    Seleccionando el paquete curl previamente no seleccionado.
    Desempaquetando curl (de .../curl_7.15.5-1ubuntu2_i386.deb) ...
    Seleccionando el paquete fetchmail previamente no seleccionado.
    Desempaquetando fetchmail (de .../fetchmail_6.3.6-1ubuntu2_i386.deb) ...
    Seleccionando el paquete libexpat1 previamente no seleccionado.
    Desempaquetando libexpat1 (de .../libexpat1_1.95.8-3.4build1_i386.deb) ...
    Seleccionando el paquete libgmp3c2 previamente no seleccionado.
    Desempaquetando libgmp3c2 (de .../libgmp3c2_2%3a4.2.1+dfsg-4build1_i386.deb) ...
    Seleccionando el paquete libpcre3 previamente no seleccionado.
    Desempaquetando libpcre3 (de .../libpcre3_6.7-1ubuntu2_i386.deb) ...
    Seleccionando el paquete libtie-ixhash-perl previamente no seleccionado.
    Desempaquetando libtie-ixhash-perl (de .../libtie-ixhash-perl_1.21-2_all.deb) ...
    Seleccionando el paquete libxml2 previamente no seleccionado.
    Desempaquetando libxml2 (de .../libxml2_2.6.27.dfsg-1ubuntu3_i386.deb) ...
    Configurando openssl (0.9.8c-4build1) ...
    
    Configurando ca-certificates (20061027) ...
    Updating certificates in /etc/ssl/certs....done.
    
    [COLOR="Red"][B]Configurando libidn11 (0.6.5-1build1) ...
    
    Configurando libcurl3 (7.15.5-1ubuntu2) ...
    
    Configurando curl (7.15.5-1ubuntu2) ...
    Configurando fetchmail (6.3.6-1ubuntu2) ...
    Adding system user `fetchmail' (UID 104) ...
    Adding new user `fetchmail' (UID 104) with group `nogroup' ...
    Creating home directory `/var/lib/fetchmail' ...
    Edit /etc/default/fetchmail to start fetchmail
    
    Configurando libexpat1 (1.95.8-3.4build1) ...
    
    Configurando libgmp3c2 (4.2.1+dfsg-4build1) ...
    
    Configurando libpcre3 (6.7-1ubuntu2) ...
    
    Configurando libtie-ixhash-perl (1.21-2) ...
    Configurando libxml2 (2.6.27.dfsg-1ubuntu3) ...[/B][/COLOR]
    [email protected]:~# cd /usr/src
    [email protected]:/usr/src# wget http://umn.dl.sourceforge.net/sourceforge/zimbra/zcs-4.5.5_GA_838.UBUNTU6.tgz
    --15:05:48--  http://umn.dl.sourceforge.net/sourceforge/zimbra/zcs-4.5.5_GA_838.UBUNTU6.tgz
               => `zcs-4.5.5_GA_838.UBUNTU6.tgz'
    Resolving umn.dl.sourceforge.net... 128.101.240.209
    Connecting to umn.dl.sourceforge.net|128.101.240.209|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 221,124,238 (211M) [application/x-gzip]
    
    100%[==================================================================>] 221,124,238  126.17K/s    ETA 00:00
    
    15:34:52 (123.80 KB/s) - `zcs-4.5.5_GA_838.UBUNTU6.tgz' saved [221124238/221124238]
    
    [email protected]:/usr/src# tar xvfz zcs-4.5.5_GA_838.UBUNTU6.tgz
    zcs/
    zcs/packages/
    zcs/packages/zimbra-logger_4.5.5_GA_838.UBUNTU6_i386.deb
    .
    .
    .
    zcs/util/utilfunc.sh
    zcs/util/globals.sh
    zcs/util/addUser.sh
    [email protected]:/usr/src# cd zcs/
    [email protected]:/usr/src/zcs# ./install.sh
    
    Operations logged to /tmp/install.log.5044
    Checking for existing installation...
        zimbra-ldap...NOT FOUND
        zimbra-logger...NOT FOUND
        zimbra-mta...NOT FOUND
        zimbra-snmp...NOT FOUND
        zimbra-store...NOT FOUND
        zimbra-apache...NOT FOUND
        zimbra-spell...NOT FOUND
        zimbra-core...NOT FOUND
    ./util/utilfunc.sh: line 381: rpm: command not found
    
    
    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.
    
    License Terms for the Zimbra Collaboration Suite:
            http://www.zimbra.com/license/collaboration_suite_collective_license_1.0.html
    
    
    Press Return to continue
    
    Checking for prerequisites...
        NPTL...FOUND
        sudo...MISSING
        libidn...MISSING
        curl...MISSING
        fetchmail...MISSING
        gmp...MISSING
        /usr/lib/libstdc++.so.5...MISSING
    
    ###ERROR###
    
    One or more prerequisite packages are missing.
    Please install them before running this installer.
    
    Installation cancelled.
    
    [email protected]:/usr/src/zcs#
    
     
  4. Stack A Brown

    Stack A Brown New Member

    ok, I change this
    Code:
    vi /etc/lsb-release
    change
    [B]DISTIB_RELEASE=7.04[/B]
    to
    [B]DISTIB_RELEASE=6[/B]
    but now this is the error:
    Code:
    [email protected]:/usr/src/zcs# ./install.sh
    
    Operations logged to /tmp/install.log.4427
    Checking for existing installation...
        zimbra-ldap...NOT FOUND
        zimbra-logger...NOT FOUND
        zimbra-mta...NOT FOUND
        zimbra-snmp...NOT FOUND
        zimbra-store...NOT FOUND
        zimbra-apache...NOT FOUND
        zimbra-spell...NOT FOUND
        zimbra-core...NOT FOUND
    
    
    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.
    
    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra_network_eval_license.pdf
    
    
    Press Return to continue
    
    Checking for prerequisites...
        NPTL...FOUND
        sudo...FOUND sudo-1.6.8p12-4ubuntu5
        libidn11...FOUND libidn11-0.6.3-1
        curl...FOUND curl-7.15.4-1ubuntu2.1
        fetchmail...FOUND fetchmail-6.3.4-1ubuntu4.1
        libpcre3...FOUND libpcre3-6.4-2ubuntu1
        libgmp3c2...FOUND libgmp3c2-2:4.2.1+dfsg-3
        libexpat1...FOUND libexpat1-1.95.8-3.2
        libxml2...FOUND libxml2-2.6.26.dfsg-2ubuntu4
        libstdc++6...FOUND libstdc++6-4.1.1-13ubuntu5
        [B]libstdc++5...MISSING[/B]
        openssl...FOUND openssl-0.9.8b-2ubuntu2
    
    ###ERROR###
    
    One or more prerequisite packages are missing.
    Please install them before running this installer.
    
    Installation cancelled.
    Now What!
     
  5. Stack A Brown

    Stack A Brown New Member

    ok, run this
    Code:
    apt-get install libstdc++5
    Now tried again and work!
     

Share This Page