problems sending mail from mail client Eudora

Discussion in 'Server Operation' started by thedoc351, Sep 15, 2010.

  1. thedoc351

    thedoc351 New Member

    I am having a problem with smtp. I can send and receive mail using squirrelmail. I can receive mail with Eudora but can't send. Eudora gives me the message can not connect to mail.domain.com connecton timed out(10060)

    the output of my mail log is:
    Sep 14 22:05:01 server pop3d: Connection, ip=[::ffff:127.0.0.1]
    Sep 14 22:05:01 server pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Sep 14 22:05:01 server imapd: Connection, ip=[::ffff:127.0.0.1]
    Sep 14 22:05:01 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Sep 14 22:05:01 server postfix/smtpd[9935]: connect from localhost[127.0.0.1]
    Sep 14 22:05:01 server postfix/smtpd[9935]: lost connection after CONNECT from localhost[127.0.0.1]
    Sep 14 22:05:01 server postfix/smtpd[9935]: disconnect from localhost[127.0.0.1]

    Here is the output of
    dig mx pcmedicalclinic.info

    ; <<>> DiG 9.6-ESV-R1 <<>> mx pcmedicalclinic.info
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46327
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;pcmedicalclinic.info. IN MX

    ;; ANSWER SECTION:
    pcmedicalclinic.info. 7200 IN MX 0 mail.pcmedicalclinic.info.

    ;; AUTHORITY SECTION:
    pcmedicalclinic.info. 1985 IN NS ns2.zoneedit.com.
    pcmedicalclinic.info. 1985 IN NS ns17.zoneedit.com.

    ;; ADDITIONAL SECTION:
    mail.pcmedicalclinic.info. 2086 IN A xx.xx.xxx.xxx
    ns17.zoneedit.com. 1173 IN A 209.126.159.118

    ;; Query time: 52 msec
    ;; SERVER: 24.247.24.53#53(24.247.24.53)
    ;; WHEN: Tue Sep 14 21:32:41 2010
    ;; MSG SIZE rcvd: 140

    I have also tried restarting amavisd.

    Your help is greatly appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is port 25 open on the server? What's the output of
    Code:
    netstat -tap
    ? Does this happen only with Eudora, or with other email clients such as Outlook, Thunderbird as well?
     
  3. thedoc351

    thedoc351 New Member

    problems sending mail with eudora

    Thank you for the response. The output of netstat -tap is as follows:
    tcp 0 0 *:40420 *:* LISTEN 1642/rpc.statd
    tcp 0 0 localhost:10024 *:* LISTEN 9420/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 2659/master
    tcp 0 0 *:mysql *:* LISTEN 12414/mysqld
    tcp 0 0 localhost:spamd *:* LISTEN 2032/spamd.pid
    tcp 0 0 *:sunrpc *:* LISTEN 1631/portmap
    tcp 0 0 *:ftp *:* LISTEN 6769/pure-ftpd (SER
    tcp 0 0 server.pcmedserv:domain *:* LISTEN 2585/mydns
    tcp 0 0 localhost:domain *:* LISTEN 2585/mydns
    tcp 0 0 *:ssh *:* LISTEN 1847/sshd
    tcp 0 0 localhost:761 *:* LISTEN 2705/famd
    tcp 0 0 *:smtp *:* LISTEN 2659/master
    tcp 0 300 server.pcmedserver.:ssh 71-10-52-17.dhcp.:50481 ESTABLISHED 20901/0
    tcp 0 0 localhost:49074 localhost:mysql ESTABLISHED 9421/amavisd (ch1-a
    tcp 0 0 localhost:mysql localhost:49074 ESTABLISHED 12414/mysqld
    tcp 60 0 localhost:57300 localhost:10025 CLOSE_WAIT 9421/amavisd (ch1-a
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2562/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 2580/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 2568/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2550/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 10503/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 10503/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 10503/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 6769/pure-ftpd (SER
    tcp6 0 0 localhost:domain [::]:* LISTEN 2585/mydns
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1847/sshd

    and no this does not only happen with eudora it is with all email clients. I can only use squirrelmail to send out messages.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What about your firewall? Is port 25 open? Can you post the output of
    Code:
    iptables -L
    ?
     
  5. thedoc351

    thedoc351 New Member

    iptables

    port 25 is in fact open and forwarded from my linux router to my webserver. This is on a commercial account and no ports are blocked by the ISP.

    Chain FORWARD (policy DROP)
    target prot opt source destination
    ACCEPT icmp -- anywhere anywhere limit: avg 10/sec burst 5
    TCPMSS tcp -- anywhere anywhere tcp flags:SYN,RST/SYN TCPMSS clamp to PMTU
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:imap2
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:imap2
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:smtp
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:25
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:pop3
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:pop3
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:ftp
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:fsp
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:ssh
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:ssh
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:http-alt
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:http-alt
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:https
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:https
    ACCEPT tcp -- anywhere 192.168.0.100 tcp dpt:www
    ACCEPT udp -- anywhere 192.168.0.100 udp dpt:www
    OUTBOUND all -- anywhere anywhere
    ACCEPT tcp -- anywhere 192.168.0.0/24 state RELATED,ESTABLISHED
    ACCEPT udp -- anywhere 192.168.0.0/24 state RELATED,ESTABLISHED
    that is the forward section of my iptables
     
  6. thedoc351

    thedoc351 New Member

    a little more info for you. This is the output of netstat -antuwp | egrep "(^[^t])|(tcp.*LISTEN)" on the webserver:

    tcp 0 0 0.0.0.0:40420 0.0.0.0:* LISTEN 1642/rpc.statd
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 9420/amavisd (maste
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 2659/master
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 12414/mysqld
    tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 2032/spamd.pid
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1631/portmap
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 6769/pure-ftpd (SER
    tcp 0 0 192.168.0.100:53 0.0.0.0:* LISTEN 2585/mydns
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 2585/mydns
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1847/sshd
    tcp 0 0 127.0.0.1:761 0.0.0.0:* LISTEN 2705/famd
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2659/master
    tcp6 0 0 :::993 :::* LISTEN 2562/couriertcpd
    tcp6 0 0 :::995 :::* LISTEN 2580/couriertcpd
    tcp6 0 0 :::110 :::* LISTEN 2568/couriertcpd
    tcp6 0 0 :::143 :::* LISTEN 2550/couriertcpd
    tcp6 0 0 :::8080 :::* LISTEN 8117/apache2
    tcp6 0 0 :::80 :::* LISTEN 8117/apache2
    tcp6 0 0 :::8081 :::* LISTEN 8117/apache2
    tcp6 0 0 :::21 :::* LISTEN 6769/pure-ftpd (SER
    tcp6 0 0 ::1:53 :::* LISTEN 2585/mydns
    tcp6 0 0 :::22 :::* LISTEN 1847/sshd
    udp 0 0 192.168.0.100:53 0.0.0.0:* 2585/mydns
    udp 0 0 127.0.0.1:53 0.0.0.0:* 2585/mydns
    udp 0 0 0.0.0.0:46135 0.0.0.0:* 1642/rpc.statd
    udp 0 0 0.0.0.0:970 0.0.0.0:* 1642/rpc.statd
    udp 0 0 0.0.0.0:111 0.0.0.0:* 1631/portmap
    udp 0 0 192.168.0.100:123 0.0.0.0:* 2720/ntpd
    udp 0 0 127.0.0.1:123 0.0.0.0:* 2720/ntpd
    udp 0 0 0.0.0.0:123 0.0.0.0:* 2720/ntpd
    udp6 0 0 ::1:53 :::* 2585/mydns
    udp6 0 0 fe80::201:6cff:fed4:123 :::* 2720/ntpd
    udp6 0 0 ::1:123 :::* 2720/ntpd
    udp6 0 0 :::123 :::* 2720/ntpd
     
  7. thedoc351

    thedoc351 New Member

    and on my debian router this is the output of the same command:

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1956/portmap
    tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 3753/perl
    tcp 0 0 0.0.0.0:52049 0.0.0.0:* LISTEN 1974/rpc.statd
    tcp 0 0 xx.xx.xx.xx:53 0.0.0.0:* LISTEN 3023/named
    tcp 0 0 192.168.0.1:53 0.0.0.0:* LISTEN 3023/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 3023/named
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 3067/sshd
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 3094/cupsd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 3377/exim4
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 3023/named
    tcp6 0 0 :::53 :::* LISTEN 3023/named
    tcp6 0 0 :::22 :::* LISTEN 3067/sshd
    tcp6 0 0 ::1:631 :::* LISTEN 3094/cupsd
    tcp6 0 0 ::1:953 :::* LISTEN 3023/named
    udp 0 0 0.0.0.0:10000 0.0.0.0:* 3753/perl
    udp 0 0 127.0.0.1:921 0.0.0.0:* 3053/lwresd
    udp 0 0 0.0.0.0:43545 0.0.0.0:* 3007/avahi-daemon:
    udp 0 0 xx.xxx.xx.xx:53 0.0.0.0:* 3023/named
    udp 0 0 192.168.0.1:53 0.0.0.0:* 3023/named
    udp 0 0 127.0.0.1:53 0.0.0.0:* 3023/named
    udp 0 0 0.0.0.0:67 0.0.0.0:* 9529/dhcpd3
    udp 0 0 0.0.0.0:68 0.0.0.0:* 3523/dhclient
    udp 0 0 0.0.0.0:48615 0.0.0.0:* 1974/rpc.statd
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 3007/avahi-daemon:
    udp 0 0 0.0.0.0:878 0.0.0.0:* 1974/rpc.statd
    udp 0 0 0.0.0.0:111 0.0.0.0:* 1956/portmap
    udp 0 0 0.0.0.0:631 0.0.0.0:* 3094/cupsd
    udp6 0 0 :::51625 :::* 3007/avahi-daemon:
    udp6 0 0 :::53 :::* 3023/named
    udp6 0 0 :::5353 :::* 3007/avahi-daemon:
    raw 0 0 0.0.0.0:1 0.0.0.0:* 7 9529/dhcpd3
     
  8. thedoc351

    thedoc351 New Member

    okay changed the port to 587 for mail and now Thunderbird finds server information but now there is another problem. I get: Could not get password for mail.pcmedicalclinic.info from Thunderbird when trying to send mail.
    in mail.log there is this:
    server postfix/smtpd[17226]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Sep 16 22:39:41 server postfix/smtpd[17226]: warning: 71-10-52-17.dhcp.bycy.mi.charter.com[71.10.52.17]: SASL LOGIN authentication failed: generic failure

    here is output of telnet:
    ehlo localhost
    250-server.pcmedserver.info
    250-PIPELINING
    250-SIZE
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN

    here is the output of /etc/postfix/sasl/smtpd.conf:
    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: mysql
    sql_hostnames: 127.0.0.1
    sql_user: ispconfig
    sql_passwd: 72728ba9fb352157cdf3b994ce7787a2
    sql_database: dbispconfig
    sql_select: select password from mail_user where email = '%u'

    I am sure there are many reasons for this error but I am running out of time. this has to be operational before the weekend. Your help is appreciated.

    I hope this is enough for you to pinpoint my problem. Thanks again!
     
  9. thedoc351

    thedoc351 New Member

    All Fixed

    Thank you Falko for all your help but I did manage to get my mail server working. I had to enable chroot in the /etc/postfix/master.cf file. Once I did that it all worked.
     

Share This Page