Problems sending emails from local test server.

Discussion in 'Installation/Configuration' started by iandoug, May 2, 2022.

  1. iandoug

    iandoug New Member

    Hi
    Spent day going around in circles but got nowhere.
    ISPConfig on Debian 11, running on local LAN to practice setup before doing it on actual server.

    Most things work except sending mails (server-generated).
    The hostname is debian.ztilan . Would that be a problem? It is listed in /etc/hosts under 127.0.0.1 but mail is not sent ... somewhere between postfix and amavis, someone is not happy. Internet searches offer various ideas but so far not working.

    Error on reprocessing mailqueue is like:
    Code:
    postqueue -p  
    
    E73CE817B1     1095 Thu Apr 28 18:20:03  [email protected] 
    (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=07070-11-70 - Temporary MTA failure on relaying, From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=07070-11-70 (in reply to end of DATA command)) 
                                            [email protected]
    

    mail.log
    Code:
    May  2 17:00:28 debian postfix/error[2611]: 84B388088D: to=<[email protected]>, orig_to=<root>, relay=none, delay=10224, delays=10223/0.17/0/0.14, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused) 
    May  2 17:00:28 debian postfix/error[2612]: 7032B8171B: to=<[email protected]>, orig_to=<root>, relay=none, delay=2425, delays=2424/0.18/0/0.19, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused) 
    May  2 17:00:28 debian postfix/error[2613]: D63248173F: to=<[email protected]>, relay=none, delay=1216, delays=1216/0.19/0/0.18, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused) 
    May  2 17:00:28 debian postfix/error[2610]: EA105818C7: to=<[email protected]>, orig_to=<root>, relay=none, delay=1216, delays=1215/0.26/0/0.13, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused) 
    May  2 17:00:28 debian postfix/error[2614]: A372C8172B: to=<[email protected]>, relay=none, delay=1216, delays=1216/0.2/0/0.18, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    
    Relevant bits from checker script:
    Note: reprocessing the queue seems to crash amavis. It was okay before.
    Note 2: I disabled IMAP, don't need it.

    Code:
    ##### SERVER ##### 
    IP-address (as per hostname): ***.***.***.*** 
    [WARN] could not determine server's ip address by ifconfig 
    [INFO] OS version is Debian GNU/Linux 11 (bullseye) 
     
    [INFO] uptime:  17:04:43 up 25 min,  1 user,  load average: 0.05, 0.13, 0.19 
     
    [INFO] memory: 
                  total        used        free      shared  buff/cache   available 
    Mem:           3.7Gi       1.4Gi       1.4Gi       4.0Mi       870Mi       2.1Gi 
    Swap:          975Mi          0B       975Mi 
     
    [INFO] systemd failed services status: 
     UNIT           LOAD   ACTIVE SUB    DESCRIPTION 
    ● amavis.service loaded failed failed Interface between MTA and virus scanner/content filters 
    1 loaded units listed. 
    ##### ISPCONFIG ##### 
    ISPConfig version is 3.2.8p1 
    
    ##### PORT CHECK ##### 
    
    [WARN] Port 443 (Webserver SSL) seems NOT to be listening 
    [WARN] Port 143 (IMAP server) seems NOT to be listening 
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening 
    
    ##### MAIL SERVER CHECK ##### 
    
    [WARN] I found no "submission" entry in your postfix master.cf 
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this. 
    
    ##### RUNNING SERVER PROCESSES ##### 
    [INFO] I found the following mail server(s): 
           Postfix (PID 1315) 
    [INFO] I found the following pop3 server(s): 
           Dovecot (PID 340) 
    [WARN] I could not determine which imap server is running. 
    
    ##### LISTENING PORTS ##### 
    (only           () 
    Local           (Address) 
    [localhost]:25          (1315/master) 
    [anywhere]:995          (340/dovecot) 
    [localhost]:10023               (987/postgrey) 
    [localhost]:3306                (462/mariadbd) 
    [localhost]:11211               (345/memcached) 
    [anywhere]:110          (340/dovecot) 
    [anywhere]:80           (470/nginx:) 
    [anywhere]:8080         (470/nginx:) 
    [localhost]:465         (1315/master) 
    [anywhere]:8081         (470/nginx:) 
    [anywhere]:21           (997/pure-ftpd) 
    [anywhere]:22           (417/sshd:) 
    *:*:*:*::*:25           (1315/master) 
    *:*:*:*::*:995          (340/dovecot) 
    *:*:*:*::*:10023                (987/postgrey) 
    [localhost]10           (340/dovecot) 
    *:*:*:*::*:80           (470/nginx:) 
    *:*:*:*::*:8080         (470/nginx:) 
    *:*:*:*::*:465          (1315/master) 
    *:*:*:*::*:8081         (470/nginx:) 
    *:*:*:*::*:21           (997/pure-ftpd) 
    *:*:*:*::*:22           (417/sshd:) 
    

    Any ideas where I can check for what?

    Thanks, Ian
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Try starting amavis, and watch the mail log for errors if it fails.
     
  3. iandoug

    iandoug New Member

    Hi
    Thanks for reply.
    Been doing that all day :)
    I just found and tried this:
    https://www.howtoforge.com/community/threads/bullseye-for-ispconfig.87450/page-2#post-427169

    But still no joy.
    will a FQDN like "testserver.something" work, even if there is no such top-level domain?
    Recent errors on queue flush:

    Code:
    May  2 19:30:55 debian amavis[6538]: (06538-07) (!)connect to 127.0.0.1:* failed, attempt #1: Can't connect to socket 127.0.0.1:* using module IO::Socket::IP: Connection refused 
    May  2 19:30:55 debian amavis[6532]: (06532-11) (!)connect to 127.0.0.1:* failed, attempt #1: Can't connect to socket 127.0.0.1:* using module IO::Socket::IP: Connection refused 
    May  2 19:30:55 debian amavis[6532]: (06532-11) (!)Jj6eeb49uoq3 FWD from <[email protected]> -> <[email protected]>,  451 4.5.0 From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=06532-11 
    May  2 19:30:55 debian amavis[6538]: (06538-07) (!)cRNrV_oUNDWD FWD from <[email protected]> -> <[email protected]>,  451 4.5.0 From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=06538-07 
    May  2 19:30:55 debian amavis[6532]: (06532-11) Blocked MTA-BLOCKED {TempFailedInbound}, [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: Jj6eeb49uoq3, Hits: 1.178, size: 1095, 302 ms 
    May  2 19:30:55 debian amavis[6538]: (06538-07) Blocked MTA-BLOCKED {TempFailedInbound}, [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: cRNrV_oUNDWD, Hits: 1.178, size: 1095, 308 ms 
    May  2 19:30:55 debian postfix/lmtp[5682]: 0FD4B815F3: to=<[email protected]>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=97852, delays=97675/3.8/173/0.3, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=06532-11 - Temporary MTA failure on relaying, From MTA() during fwd-connec
    t (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=06532-11 (in reply to end of DATA command)) 
    May  2 19:30:55 debian postfix/lmtp[5680]: 081B3818D0: to=<[email protected]>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=13852, delays=13675/3.5/173/0.31, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=06538-07 - Temporary MTA failure on relaying, From MTA() during fwd-conne
    ct (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=06538-07 (in reply to end of DATA command)) 
    May  2 19:33:40 debian postfix/scache[4725]: statistics: start interval May  2 19:23:40 
    May  2 19:33:40 debian postfix/scache[4725]: statistics: domain lookup hits=1370 miss=40 success=97% 
    May  2 19:33:40 debian postfix/scache[4725]: statistics: address lookup hits=0 miss=42 success=0% 
    May  2 19:33:40 debian postfix/scache[4725]: statistics: max simultaneous domains=1 addresses=1 connection=2 
    

    Mmm.. I guess I should not have disabled lmtp .... let me put that back. Thought it was something IMAP related.

    Thanks, Ian
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Ah, sorry, missed that - so you mean you start up amavis, flush the mail queue and amavis crashes? Any errors logged? Is it always processing the same message when it crashes, or different ones? You might check other logs like syslog for clues, eg. out of memory killer or something.
     
  5. iandoug

    iandoug New Member

    It looks like giving it a "FQDN" fixed the crashing problem. It would be nice if these programs wrote reasons why they crash.
     
  6. iandoug

    iandoug New Member

    in mail.log
    Code:
    May  2 21:21:03 debian postfix/qmgr[3640]: warning: connect to transport private/amavis: No such file or directory
    

    Should there be an amavis folder here?
    Code:
    [email protected]:/var/spool/postfix# ll private/ 
    total 0 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 anvil 
    srw-rw---- 1 postfix postfix 0 May  2 20:50 auth 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 bounce 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 bsmtp 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 defer 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 discard 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 dovecot 
    srw------- 1 postfix postfix 0 May  2 20:50 dovecot-lmtp 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 error 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 ifmail 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 lmtp 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 local 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 maildrop 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 mailman 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 proxymap 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 proxywrite 
    srw-rw---- 1 postfix postfix 0 May  2 20:50 quota-status 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 relay 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 retry 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 rewrite 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 scache 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 scalemail-backend 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 smtp 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 tlsmgr 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 trace 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 uucp 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 verify 
    srw-rw-rw- 1 postfix postfix 0 May  2 19:16 virtual
    

    Maybe I must just switch to Ubuntu if Debian 11 is so full of headaches... existing server is CentOS 6.

    Thanks, Ian

     
  7. iandoug

    iandoug New Member

    Anyone have any ideas? I don't know what is the actual problem ... postfix of amavis or something else ...
    Code:
    [email protected]:/var/log# echo "This is the body of the email" | mail -s "This is the subject line" [email protected] 
    

    Is Amavis supposed to created the socket private/amavis?


    Code:
    [email protected]:/var/log# tail mail.log  
    May  3 22:05:03 localhost postfix/submission/smtpd[206335]: connect from localhost[::1] 
    May  3 22:05:03 localhost postfix/submission/smtpd[206335]: lost connection after CONNECT from localhost[::1] 
    May  3 22:05:03 localhost postfix/submission/smtpd[206335]: disconnect from localhost[::1] commands=0/0 
    May  3 22:08:57 localhost postfix/pickup[202548]: 86554807A5: uid=0 from=<root> 
    May  3 22:08:57 localhost postfix/cleanup[206397]: 86554807A5: message-id=<[email protected]> 
    May  3 22:08:57 localhost postfix/qmgr[3640]: 86554807A5: from=<[email protected]>, size=425, nrcpt=1 (queue active) 
    May  3 22:08:57 localhost postfix/qmgr[3640]: warning: connect to transport private/amavis: No such file or directory 
    May  3 22:08:57 localhost postfix/error[206400]: 86554807A5: to=<[email protected]>, relay=none, delay=0.22, delays=0.15/0.02/0/0.06, dsn=4.3.0, status=deferred (mail transport unavailable)
    


    Code:
    [email protected]:/var/log# systemctl status amavis 
    ● amavis.service - Interface between MTA and virus scanner/content filters 
        Loaded: loaded (/lib/systemd/system/amavis.service; enabled; vendor preset: enabled) 
        Active: active (running) since Mon 2022-05-02 19:27:09 SAST; 1 day 2h ago 
          Docs: http://www.ijs.si/software/amavisd/#doc 
       Process: 5614 ExecStartPre=/usr/bin/find /var/lib/amavis -maxdepth 1 -name amavis-* -type d -exec rm -rf {} ; (code=exited, status=0/SUCCESS) 
       Process: 5615 ExecStartPre=/usr/bin/find /var/lib/amavis/tmp -maxdepth 1 -name amavis-* -type d -exec rm -rf {} ; (code=exited, status=0/SUCCESS) 
      Main PID: 5616 (/usr/sbin/amavi) 
         Tasks: 3 (limit: 4450) 
        Memory: 211.6M 
           CPU: 1h 25min 24.761s 
        CGroup: /system.slice/amavis.service 
                ├─  5616 /usr/sbin/amavisd-new (master) 
                ├─205392 /usr/sbin/amavisd-new (ch9-avail) 
                └─205394 /usr/sbin/amavisd-new (ch9-avail) 
    


    Thanks, Ian
     
  8. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No, ispconfig uses port 10024 and 10026 on loopback interface to talk to amavis by default. Creating a filesystem socket would be more secure in ways, at least on hosts which share web and mail services, but it would be an entirely custom setup to do so.
    Sounds like you have been playing with your postfix config; this might be related to you disabling lmtp earlier. Normally the 'amavis' transport isn't used, lmtp is, but you might verify that and what you have for 'postconf -M amavis'.
     
  9. iandoug

    iandoug New Member

    Yes I have tried many things ... assorted "solutions" on the web, none work yet.
    Discovered that hostname and hosts file needed tweaking, hostname -f is now correct.
    Code:
    [email protected]:/var/log# postconf -M amavis       
    postconf: warning: unmatched request: "amavis"
    
    so reset
    content_filter = lmtp:[127.0.0.1]:10024
    back to lmtp, then
    
    [email protected]:/var/log# postconf -M lmtp
    lmtp       unix  -       -       y       -       -       lmtp
    

    But still the issue persists. BTW there is a ton of mail from www-data complaining about a missing Apache log file, I use Nginx not Apache, don't know if bug in install process for AWStats or if I missed something during install. I changed the line in awstats.conf to use nginx log.

    Test message sent earlier still stuck.
    Code:
    May  3 23:40:45 debian postfix/error[3191]: 16CD8807B5: to=<[email protected]>, relay=none, delay=2598, delays=2598/0.02/0/0.06, dsn=4.3.0, status=deferred (mail transport unavailable)
    May  3 23:40:45 debian postfix/error[3192]: CE0D5807B7: to=<[email protected]>, relay=none, delay=2598, delays=2598/0.03/0/0.11, dsn=4.3.0, status=deferred (mail transport unavailable)
    May  3 23:40:45 debian postfix/error[3196]: 4ABC2807B6: to=<[email protected]>, relay=none, delay=2689, delays=2689/0.06/0/0.1, dsn=4.3.0, status=deferred (mail transport unavailable)
    May  3 23:40:45 debian postfix/error[3194]: CBB8E807C8: to=<[email protected]>, orig_to=<root>, relay=none, delay=1241, delays=1241/0.04/0/0.11, dsn=4.3.0, status=deferred (mail transport unavailable)
    May  3 23:40:45 debian postfix/error[3198]: 8DE4A807B0: to=<[email protected]>, relay=none, delay=2688, delays=2688/0.07/0/0.09, dsn=4.3.0, status=deferred (mail transport unavailable)
    

    I wonder if some issues are caused by installing this on internal LAN without FQDN ... or because there are some differences between Debian 10 and Debian 11 ... I followed the 10 guide, with some personalisation ... eg don't want IMAP.


    Thanks, Ian
     
  10. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What issue persists? It was my understanding that you fixed your initial issue of amavis crashing by changing your hostname:
     
  11. iandoug

    iandoug New Member

    Mail is not sent ... either to root locally or to me on my live server. See #9 above.
    Thanks, Ian
     
  12. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    message logs in #9 above appear to be exactly what you said, messages sent earlier that are still in your queue. If your current messages are working, and those are all test messages, just delete them with postsuper -d.
     
  13. iandoug

    iandoug New Member

    I already deleted 700+ messages from the queue earlier today.

    Mails are still tot being sent. Extract:

    Code:
    May  4 04:15:45 debian postfix/qmgr[1373]: F1C24807CA: from=<[email protected]>, size=403, nrcpt=1 (queue active)
    May  4 04:15:46 debian amavis[1335]: (01335-10) (!)connect to 127.0.0.1:* failed, attempt #1: Can't connect to socket 127.0.0.1:* using module IO::Socket::IP: Connection refused
    May  4 04:15:46 debian amavis[1335]: (01335-10) (!)ubclSKRwnt9F FWD from <[email protected]> -> <[email protected]>,  451 4.5.0 From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=01335-10
    May  4 04:15:46 debian amavis[1335]: (01335-10) Blocked MTA-BLOCKED {TempFailedOpenRelay}, [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: ubclSKRwnt9F, Hits: 0.378, size: 403, 954 ms
    May  4 04:15:46 debian postfix/lmtp[1844]: F1C24807CA: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=652, delays=651/0.04/0/0.95, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=01335-10 - Temporary MTA failure on relaying, From MTA() during fwd-connect (All attempts (1) faile
    d connecting to smtp:127.0.0.1:*): id=01335-10 (in reply to end of DATA command))
    May  4 04:15:46 debian amavis[1334]: (01334-09) (!)connect to 127.0.0.1:* failed, attempt #1: Can't connect to socket 127.0.0.1:* using module IO::Socket::IP: Connection refused
    May  4 04:15:46 debian amavis[1334]: (01334-09) (!)D79VMkF5m04y FWD from <[email protected]> -> <[email protected]>,  451 4.5.0 From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=01334-09
    May  4 04:15:46 debian amavis[1334]: (01334-09) Blocked MTA-BLOCKED {TempFailedOpenRelay}, [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: D79VMkF5m04y, Hits: 1.178, size: 407, 1559 ms
    May  4 04:15:46 debian postfix/lmtp[1843]: 6A7A6807D1: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=653, delays=652/0.05/0.01/1.6, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=01334-09 - Temporary MTA failure on relaying, From MTA() during fwd-connect (All attempts (1) fai
    led connecting to smtp:127.0.0.1:*): id=01334-09 (in reply to end of DATA command))
    

    So I don't know which config has the error(s). Not supposed to be an "open relay" either, unless that means something else.

    Thanks, Ian
     
  14. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I am using email relay for servers behind LAN NAT because port 25 is normally closed.
     
  15. iandoug

    iandoug New Member

    @adrasis
    Thanks for idea. My firewall is not blocking port 25:
    Code:
    telnet smtp.afrihost.co.za 25
    Trying 169.1.1.74...
    Connected to smtp.afrihost.co.za.
    Escape character is '^]'.
    220 pure ESMTP joy (smtp01)
    

    Also works on the box itself, so it is not blocked by local firewall.

    Local mail is also not delivered, so either port 25 is not the problem or there is more than one problem.

    Thanks, Ian
     
    Last edited: May 4, 2022
  16. iandoug

    iandoug New Member

    Following hints on a Centos site.
    Code:
    netstat -tulpn | grep 1002 
    tcp        0      0 127.0.0.1:10023         0.0.0.0:*               LISTEN      878/postgrey --pidf  
    tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      373/amavisd-new (ma  
    tcp        0      0 127.0.0.1:10026         0.0.0.0:*               LISTEN      373/amavisd-new (ma  
    tcp6       0      0 ::1:10023               :::*                    LISTEN      878/postgrey --pidf 
    

    versus
    Code:
    cat /etc/postfix/main.cf | grep 1002 
    greylisting = check_policy_service inet:127.0.0.1:10023 
    address_verify_virtual_transport = smtp:[127.0.0.1]:10025 
    address_verify_transport_maps = static:smtp:[127.0.0.1]:10025 
    content_filter = lmtp:[127.0.0.1]:10024
    
    So Postfix is expecting something to be listening on port 25, but nothing is.
    Where/what should that be?

    Thanks, Ian
     
  17. iandoug

    iandoug New Member

  18. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Postfix itself (smtpd) listens on port 25, that is unrelated to your issue.

    Your logs show amavis is now running and getting messages, and unable to forward them to the downstream mta, which is postfix listening on ports 10025 and 10027 (which your commands show it is not). You seem to have things quite mixed up there, I would probably try making a quick backup of main.cf and master.cf, undo any changes you identify as having made yourself, then run the ISPConfig installer to reconfigure services and hope you end up with a fully working postfix/amavis config. If not, see where things are at at that point, ie. post fresh logs and problem description; if so, make your future customisations little by little and test as you go so you identify what breaks when you change something.
     
  19. iandoug

    iandoug New Member

    Mail never worked on initial install, which is why I started fiddling.

    I decided to remove Postfix, amavis and Dovecot, and re-install.
    Then while apt was doing its thing, it wanted to install libhyperscan. Which produced a popup I had forgotten about .. .it does not work on the CPU in this box. (old HP microserver). I skipped it on the original setup.

    So possibly this is one of the root causes of my issues ....

    I guess I must go ahead and try to set
    up ISPconfig on the actual live server, which will have a real FQDN (so letsencrypt will work) and a modern CPU.

    Do you guys have an ETA for the Debian 11 manual install document? Since there are some differences to Debian 10.

    Thanks, Ian
     
  20. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    I don't.
     

Share This Page