Problems sending and recieving mail

Discussion in 'Installation/Configuration' started by JamesH106, Feb 19, 2007.

  1. JamesH106

    JamesH106 New Member

    Hi.

    I have followed the Perfect Ubuntu setup to the letter, but I am still getting errors.

    I have an odd setup, which may be giving errors to do with DNS.. it is:

    idealcare.co.uk = 65.23.158.81 (Web server externally hosted)
    mail.idealcare.co.uk = 81.149.181.143 (Mail server hosted in Head Office)

    ..obviously I have MX set up properly.

    We are migrating from Exchange Server which previously worked but was unreliable.

    I have installed ISPConfig and made a new user (web1_user), and configured Outlook. But when sending mails I get this:

    Code:
    The following recipient(s) cannot be reached:
    
          [email protected]' on 19/02/2007 17:20
                550 <[email protected]>: Recipient address rejected: User unknown in local recipient table
    
          [email protected]' on 19/02/2007 17:20
                554 <[email protected]>: Relay access denied
    Any help is greatly appreciated. It's driving me mad.



    Thanks for reading.
    James.
     
  2. fireba11

    fireba11 Member HowtoForge Supporter

    it's pretty straightforward ... the first user is expected to be local but unknown .. thus not defined, the second is elsewhere but since you are most likely not authenticated the relaying of the mail to the outside server is refused
     
  3. JamesH106

    JamesH106 New Member

    How do I define it?

    I have SMTP authentication enabled in outlook.
     
  4. JamesH106

    JamesH106 New Member

    Can anybody help? I'm really having trouble with this.


    Thanks.

    EDIT: I have set outlook to authenticate, but it keeps asking for my user name and password because the server is denying the login. I know I am using the right username and pass (web1_whatever), whats the deal with this?
     
    Last edited: Feb 19, 2007
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Problem 1:
    the address [email protected] does not exist. To be exact, the user internal-email does not exist in ISPConfig. I think the most easy way is to give user web1_whatever an alias internal-email.
    Go to Advanced settings of the email user and add this alias in the specified text box and hit save.

    Problem 2:
    The sending server is not recognized as a mail server for your domain. Which server is sending the emails:
     
  6. JamesH106

    JamesH106 New Member

    Thanks for your reply!

    I set that up, and now I can send/recieve e-mails internally.. BUT it only works if I send to [email protected], how can I make the server pick e-mail up from idealcare.co.uk?

    EDIT: I changed the hostname in the website info (in ISPConfig) from mail to nothing. Internal e-mail works now, but I'm still having problems with external.

    mail.idealcare.co.uk = 81.149.181.143 (lets call it server2)

    ..is the one sending the e-mails. I suppose I should have made it clear that server2 is the one I'm trying to configure (and the one that runs ISPConfig).



    Thanks a lot for your help - I really appreciate it.

    :) James
     
    Last edited: Feb 20, 2007
  7. JamesH106

    JamesH106 New Member

    I have set outlook to authenticate with the same credentials as the pop3 server, and to use TLS, but the server keeps rejecting my login.

    Any ideas? And do you need the output of any config files?


    Any help is very helpful.

    Thanks.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you try to authenticate?
     
  9. JamesH106

    JamesH106 New Member

    I'm going to re-install this server on saturday, when I will have as long as I want/need without any distractions and I can properly concentrate.

    I also realised I didn't properly follow your guide, because I installed the LAMP and DNS server. Possible that there could have been conflicts.

    Thanks for your help. If I experience any problems on saturday I'll start a new thread.

    Thanks! :)
     

Share This Page