Problems pure-ftpd-mysql on Ubuntu 9.0

Discussion in 'Installation/Configuration' started by frehovl, May 13, 2009.

  1. frehovl

    frehovl New Member

    Hi.

    I have installed Ispconfig 3 following this guide.
    http://www.howtoforge.com/perfect-server-ubuntu-9.04-ispconfig-3

    Everything seems to run fine except pure-ftpd.
    Ispconfig reports that pure-ftpd is not running.

    I try to restart the serivce, and get no error messages.
    Code:
    user@totally:~$ sudo /etc/init.d/pure-ftpd-mysql restart
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    Ispconfig still reports errors on pure-ftpd. To get any errormessages i've have to run "aptitude install".

    Code:
    user@totally:~$ sudo aptitude install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following partially installed packages will be configured:
      pure-ftpd-mysql
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Setting up pure-ftpd-mysql (1.0.21-11.4ubuntu1) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/                                                                                                                     db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Setting up pure-ftpd-mysql (1.0.21-11.4ubuntu1) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/                                                                                                                     db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    anyone who knows how i might fix this problem? :)
     
  2. frehovl

    frehovl New Member

    Ubuntu 9.04 that is :p
     
  3. falko

    falko Super Moderator

    What's the output of
    Code:
    netstat -tap
    ?
     
  4. frehovl

    frehovl New Member

    here comes the output.

    Code:
    root@totally:/home/user# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      2611/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      3364/master     
    tcp        0      0 *:mysql                 *:*                     LISTEN      2686/mysqld     
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      2778/spamd.pid  
    tcp        0      0 *:http-alt              *:*                     LISTEN      2755/apache2    
    tcp        0      0 *:www                   *:*                     LISTEN      2755/apache2    
    tcp        0      0 totally.lifelnes:domain *:*                     LISTEN      3291/mydns      
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      3291/mydns      
    tcp        0      0 *:ssh                   *:*                     LISTEN      2583/sshd       
    tcp        0      0 *:smtp                  *:*                     LISTEN      3364/master     
    tcp        0      0 *:https                 *:*                     LISTEN      2755/apache2    
    tcp        0      0 totally.lifelness:38978 im.bitlbee.org:ircd     ESTABLISHED 20828/irssi     
    tcp        0    288 totally.lifelness.n:ssh ti0125a340-1242.b:49437 ESTABLISHED 13045/sshd: user [p
    tcp        0      0 totally.lifelness:39674 irc.servercentral.:ircd ESTABLISHED 20828/irssi     
    tcp        0      0 totally.lifelness.n:ssh ti0125a340-1242.b:64118 ESTABLISHED 12779/sshd: fredrik
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3248/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      3286/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3264/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3226/couriertcpd
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      3291/mydns      
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2583/sshd       
    I also have problems reaching domains i add on port 81.

    I'm running the server on a machine hosted at netdirekt.de, it's at fresh ubuntu 8.04 install upgraded to 8.10 and 9.04 with "do-release-upgrade -d". After the upgrade i ran the perfect server how to. Don't know if it matters, but thought i should mention it.
     
  5. till

    till Super Moderator

    1) Which exact perfect server howto did you use?
    2) ISPconfig 3 does not use port 81, it uses port 8080. You seem to mix this up with ispconfig 2.
     
  6. frehovl

    frehovl New Member

    Ah, that explains why :)

    I just read it in the ispconfig faq that you could reach a admin panel by typing in a customer_domain.com:21

    I'm running ispconfig 3 on ubuntu 9.04, by following "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]". See link in first post.
     
  7. falko

    falko Super Moderator

    Pureftpd isn't running. Please try this:

    Code:
    sudo /etc/init.d/pure-ftpd-mysql stop
    sudo /etc/init.d/pure-ftpd-mysql start
     
  8. frehovl

    frehovl New Member

    That's what I don't understand. I don't get any errormessages when I stop/start or restart the service.

    Code:
    root@totally:/home/user# /etc/init.d/pure-ftpd-mysql stop
    Stopping ftp server: pure-ftpd.
    root@totally:/home/user# /etc/init.d/pure-ftpd-mysql start
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    root@totally:/home/user# /etc/init.d/pure-ftpd-mysql restart
    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    root@totally:/home/user#
    New netstat output after stop/start.

    Code:
    root@totally:/home/user# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      2611/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      3364/master
    tcp        0      0 *:mysql                 *:*                     LISTEN      2686/mysqld
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      2778/spamd.pid
    tcp        0      0 *:http-alt              *:*                     LISTEN      2755/apache2
    tcp        0      0 *:www                   *:*                     LISTEN      2755/apache2
    tcp        0      0 totally.lifelnes:domain *:*                     LISTEN      3291/mydns
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      3291/mydns
    tcp        0      0 *:ssh                   *:*                     LISTEN      2583/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      3364/master
    tcp        0      0 *:https                 *:*                     LISTEN      2755/apache2
    tcp        0      0 localhost.localdo:mysql localhost.localdo:58790 ESTABLISHED 2686/mysqld
    tcp        0      0 totally.lifelness:38978 im.bitlbee.org:ircd     ESTABLISHED 20828/irssi
    tcp        0    300 totally.lifelness.n:ssh 83.163.121.148.in-:4467 ESTABLISHED 21126/sshd: user [p
    tcp        0      0 localhost.localdo:41215 localhost.localdoma:www TIME_WAIT   -
    tcp        0      0 localhost.localdo:58790 localhost.localdo:mysql ESTABLISHED 2708/amavisd (ch6-a
    tcp        0      0 totally.lifelness.n:ssh 83.163.121.148.in-:1631 ESTABLISHED 2826/sshd: fredrik
    tcp        0      0 totally.lifelness:39674 irc.servercentral.:ircd ESTABLISHED 20828/irssi
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3248/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      3286/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3264/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3226/couriertcpd
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      3291/mydns
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2583/sshd
    tcp6       0      0 localhost:34290         localhost:domain        TIME_WAIT   -
    

    The only place I get an error is when I try to run aptitude an update the "broken" package.

    Code:
    root@totally:/home/user# aptitude install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following partially installed packages will be configured:
      pure-ftpd-mysql
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Setting up pure-ftpd-mysql (1.0.21-11.4ubuntu1) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Setting up pure-ftpd-mysql (1.0.21-11.4ubuntu1) ...
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--configure):
     subprocess post-installation script returned error exit status 252
    Errors were encountered while processing:
     pure-ftpd-mysql
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    
     
  9. falko

    falko Super Moderator

    Does
    Code:
    /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    show any errors?
     
  10. frehovl

    frehovl New Member

    Nope :(

    No errors at all.

    Code:
    root@totally:/home/user# /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B
    root@totally:/home/user#
     
  11. falko

    falko Super Moderator

    Any errors in your logs?
    Is it a physical server or a virtual machine?
     
  12. dustin.lavigne

    dustin.lavigne New Member

    Bump!

    Hi Guys!! I'm having the exact same problem... Can anyone review this thread and try to point me in the right direction for a solution??

    Thanks for your efforts!!:)
     
  13. falko

    falko Super Moderator

    Is this a physical server or a virtual machine? If it's a virtual machine, which virtualization technique do you use (OpenVZ/Virtuozzo, Xen, KVM, VMware, etc.)?
     
  14. dustin.lavigne

    dustin.lavigne New Member


    Hi falko!

    Thanks for your input on this topic. To answer your question, it is a VPS hosted on the OpenVZ platform.

    After a few more hours of searching after I posted this thread, I found that you can recompile ProFTPd with the --without-capabilities option to fix this problem.

    This solution did work for me. Thanks again, however, for taking the time to respond to my post! :)
     
  15. grafzahl

    grafzahl New Member

    I had the same problem on Lenny with a VPS Machine. Create a new deb-package solve the problem.

    Now there is a new problem:
    'apt-get upgrade' wants to reinstall pure-ftpd-mysql. If i do this, i get the version with capabilities on. ISPConfig3 also give me a warning. What can i do? Is there a way to disable lookup for pure-ftpd-mysql in dpkg?

    Greets,
    Grafzahl

    Edit:
    Problem solved. I must set the package on hold in dpkg. Now there are no warnings in apt-get and ISPConfig3.
    Code:
    echo pure-ftpd-mysql hold | dpkg --set-selections
     
    Last edited: Jan 17, 2010

Share This Page