Problems on Lenny install with MySql

Discussion in 'Installation/Configuration' started by ar3inc, Apr 26, 2010.

  1. ar3inc

    ar3inc New Member

    I am using falko's The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3], which I get it is perfect. But some how I have melted it up and hope that someone can help me. I have tried this 3 times, researched google but have not found anything to help. At this point I'm going insane - just trying the same actions expecting different results.

    I trace the problem back step 9 on the MySQL install/set up. I am using a Linksys router and set the static IP to 192.168.1.80. Server is named beta.ar3inc.com. I plan to only use this box on my internal network.

    I modify /etc/mysql/my.cnf
    Code:
    ...
    skip-external-locking
    #
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address		= 127.0.0.1
    #
    # * Fine Tuning
    ...
    and I keep getting;
    Code:
    beta:~# /etc/init.d/mysql restart
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..
    beta:~# netstat -tap | grep mysql
    tcp        0      0 *:mysql                 *:*                     LISTEN      2572/mysqld
    
    If I retry the 2 above commands again the LISTEN value will keep increasing until I reboot. What am I doing wrong or leaving out? Thank you
     
  2. mike_p

    mike_p Member

    I'm not sure I understand the problem. What do you mean by the 'LISTEN value'.

    The number following the word 'LISTEN' is the PID. As far as I know, every time you stop and start a service it's going to be assigned a new PID. So the value should change every time.

    According to your netstat output , mysql is running okay.

    What problem are you actually experiencing? What doesn't work?
     
  3. ar3inc

    ar3inc New Member

    well, &*^%!!! Please forgive my ignorance and allow my clarify. So in...
    Code:
    LISTEN      2572/mysqld
    2572 is the PID and can be whatever number. Correct?
    The actual problem I ran into was towards the end on the actual ispconfig install. I had other problem with the MySql connecting so I assumed the root was this step. I have already restarted install and halted at the point in question. I guess I will just resume everything and let you know.
     
  4. mike_p

    mike_p Member

    So how is it going??

    Earlier this month I went through about 10 cycles of reformating the hard disk, installing Centos5.4 and runnning the Perfect server guide, but each time making adjustments until I was entirely happy with the result. I've gained a lot of experience that I'm more than happy to share with others!!
     
  5. ar3inc

    ar3inc New Member

    Thanks, Mike!!

    That is exactly why I am doing this wanting to gain that experience.

    I'm running into problems in step 12. After I modify inetd.conf. After trying to change the perms, I get "chmod: cannot access `/qouta.*': No such file or directory."

    Before I embarrass myself more, I am going to just throw it out. I understand what the file is doing but have no clue what it means. I just copied and pasted the guide. Am I suppose to personalize the values based on my machine? I am sure I am. Where can I find more info about the meaning and roles of the file?
     
  6. mike_p

    mike_p Member

    If that is exactly the response you get it's probably because of a typo: "qouta" instead of "quota"
     
  7. ar3inc

    ar3inc New Member

    oh-kay now i feel really stupid. thanks thou.

    Is this a normal/good response to the "quotacheck -avugm" command?
    Code:
    quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
    quotacheck: WARNING - Quotafile //quota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING - Quotafile //quota.group was probably truncated. Cannot save quota settings...
    quotacheck: Scanning /dev/hda1 [/] done
    quotacheck: Checked 3276 directories and 33437 files
    Saddly I typo'd the word like three times in the install too, but I caught those myself.
     
  8. ar3inc

    ar3inc New Member

    I got it installed!!! :D
     
  9. mike_p

    mike_p Member

    Congratulations on the birth of your new control panel! :)
     
  10. ar3inc

    ar3inc New Member

    Just I furture reference to others out there that might hit the same stopping point as me...
    I was able to get through everything up to the ISPConfig install (not paying close attention to the results on each command) and then I received errors.

    On step 13 the installation of MyDNS. I had to create the config file for it. I tried the "make conf" command the program suggested but for whatever reason that failed with an error about no rule. So i copied the conf file from the article Running A MySQL-Based DNS Server: MyDNS and bamm it worked.
     
  11. Mark_NL

    Mark_NL New Member

    If people would be actually take the time in reading the how-to's .. halve of the posts on this forum would not be here, I've been here for a while now and noticed that about 60% of the problems are bye people rushing through the how-to's (especially not trying to understand what they're actually doing, but just copy paste the commands from the site into theire consoles, i bet that if they put a "chmod 0755 /bin/su", everyone would do it) and forgetting steps. ;-)

    If you run "make *" and get an error about no rule, then you probably forgot to run ./configure first. ;)

    anyway, grats with your new ispc installation, it's awesome.
     

Share This Page