Problems installing suPHP on centos 5.2 ISPconfig

Discussion in 'Installation/Configuration' started by usul, Jan 6, 2009.

  1. usul

    usul New Member

    Problems installing suPHP 0.7.0 on centos 5.2 ISPconfig

    Hello World:)

    I apologize for my Google English!:rolleyes:

    I'm trying to install suPHP for the management of permits for Joomla and magenta.

    I installed on Server:
    Centos 5.2 updated with php 5.2.8, Apache 2.0 API Handler
    ISPConfig 2.2.29

    I tried to run your post:

    http://www.howtoforge.com/install-suphp-on-various-linux-distributions-for-use-with-ispconfig-2.2.20-and-above

    http://www.howtoforge.org/suphp_fedora7_centos5_with_ispconfig


    with both when I run the command:
    After a series of controls the operation concludes with the following error

    to control the path of APR I launched:
    after checking on http://man.root.cz/1/apr-1-config/ I think I have understood that there is no parameter, but what?:confused:


    Additional questions, I will have to install APC cache, get the best magenta and beyond, given me advice on this? perhaps some links.

    They told me that it would be better suexec + fast-cgi php-cgi instead of suPHP, but with APC suexec works?


    Thank you in advance.


    Problem-dependent configuration suphp.conf, see last post.
     
    Last edited: Jan 9, 2009
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which ISPConfig version?
     
  3. usul

    usul New Member

    internal error 500

    ISPCONFIG version 2.2.29 and the problem described above is passed ..
    I had installed APR.!:mad::(:p

    However, I proceeded with the installation of suphp-0.7.0 without errors.

    When you restart Aapache showed a bug in Vhosts_ispconfig.conf, precisely where it was stated 'php_admin_flag'.
    Off functions ISPconfig PHP, and Apache is divided reactivated the PHP Apache has restarted several times without error.

    Now received internal error 500, even the simple file info.php.

    I checked the logs and I did not find any errors you enclosed a few lines

    error.log

    suphp.log is empty!


    I understand that suExe is active, so should I turn it off, but how?

    If I wanted to return to its previous state of the installation suPHP, how do I delete what I have done?


    Which if I'm doing the right thing:
    I need a system that controls access to joomla and magenta, and both have to install an APC cache and I have not much experience of linux.
    What to choose suPHP or suexec together with what else?

    There is a guide that provides the optimal configuration for ISPconfig?

    Thank you very much

    Diary of the actions carried out
     
    Last edited: Jan 7, 2009
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You lokked in the wrong logfile. Please post the error from the error log of the website.
     
  5. usul

    usul New Member

    :eek:
    file error Web site .. I had that check!:D


    I found that I have the same error
    http://www.howtoforge.com/forums/showthread.php?t=29801
     
    Last edited: Jan 7, 2009
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate Application.cpp
    ?
     
  7. usul

    usul New Member

    I do not know, probably is part of the script called previously joomla_hisa_it_1_1.php type or magenta-check.php.

    Repeated now required info.php me the following error


    By reading some documents, I have the impression that there is a configuration problem on the site www.suphp.org cautions that we need to change the configuration has changed because of the way of writing code, such as the "" but I did not understand much, even making the changes required that highlights in green, nothing has changed.

    I attach the configuration file


    footnote 1
    I wonder should I disable suEXEC? and how?

    Thanks for your attention
     
  8. usul

    usul New Member

    hooray! It works.

    hooray!
    It works.

    the error was determined by the configuration on suPHP with the file with the changes

    important with the version 0.7.0 of suPHP insert "":D


    thanks for your attention
     
    Last edited: Jan 9, 2009
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What exactly did you change? Looks like the original file...
     
  10. fryfrog

    fryfrog New Member

    The difference is the addition of " " around the options. I just dealt with this issue on my own ISPConfig server and this fixed it.

    Old and Busted:
    Code:
    ;Handler for php-scripts
    x-httpd-php=php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper
    
    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self
    
    New Hotness:
    Code:
    ;Handler for php-scripts
    x-httpd-php="php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper"
    
    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    
     
  11. saul

    saul New Member

    Code:
    ;Handler for php-scripts
    x-httpd-php="php:/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper"
    
    ;Handler for CGI-scripts
    x-suphp-cgi="execute:!self"
    
    [/QUOTE]


    This just worked for me 27 - Oct - 2010 - after upgrading ispconfig 2 to the latest version.

    Thanks!
     
  12. mini14

    mini14 New Member

    Same here..about 15 minutes ago.. those little magical quotes ;)

    Reminds me of the old days (dinosaurs were outside the computer lab I think!) The old dreaded "Syntax error" invariably was caused by incorrect punctuation!
     

Share This Page