problems installing Quota:

Discussion in 'Installation/Configuration' started by iDen, Aug 10, 2009.

  1. iDen

    iDen New Member

    System Fedora 11 x32
    trying to install Quota
    tried several times
    getting next errors (last output):

    Please help solve it :(

    Code:
    [root@FBox den]# [COLOR="Red"]rm -f /quota.user[/COLOR]
    [root@FBox den]# [COLOR="Red"]rm -f /quota.group[/COLOR]
    [root@FBox den]# [COLOR="Red"]touch /aquota.user /aquota.group[/COLOR]
    [root@FBox den]# [COLOR="Red"]chmod 600 /aquota.*[/COLOR]
    [root@FBox den]# [COLOR="Red"]mount -o remount /[/COLOR]
    [root@FBox den]# [COLOR="Red"]quotacheck -avugm[/COLOR]
    quotacheck: Your kernel probably supports journaled quota but you are not using                                                                                                  it. Consider switching to journaled quota to avoid running quotacheck after an u                                                                                                 nclean shutdown.
    quotacheck: WARNING -  Quotafile //aquota.user was probably truncated. Cannot sa                                                                                                 ve quota settings...
    quotacheck: WARNING -  Quotafile //aquota.group was probably truncated. Cannot s                                                                                                 ave quota settings...
    quotacheck: Scanning /dev/mapper/vg_fbox-System [/] quotacheck: lstat Cannot sta                                                                                                 t `//home/den/.gvfs': Permission denied
    Guess you'd better run fsck first !
    exiting...
    Code:
    [root@FBox den]# [COLOR="Red"]quotaon -avug[/COLOR]
    quotaon: Cannot find quota file on / [/dev/mapper/vg_fbox-System] to turn quotas                                                                                                  on/off.
    quotaon: Cannot find quota file on / [/dev/mapper/vg_fbox-System] to turn quotas                                                                                                  on/off.
    Code:
    [root@FBox den]#[COLOR="Red"] ls -la /[/COLOR]
    total 110
    drwxr-xr-x.  22 root root  4096 2009-08-10 13:04 .
    drwxr-xr-x.  22 root root  4096 2009-08-10 13:04 ..
    -rw-------    1 root root     0 2009-08-10 13:41 aquota.group
    -rw-------    1 root root     0 2009-08-10 13:41 aquota.user
    -rw-r--r--    1 root root     0 2009-08-10 08:57 .autofsck
    -rw-r--r--    1 root root     0 2009-07-25 08:04 .autorelabel
    drwxr-xr-x.   2 root root  4096 2009-08-10 09:32 bin
    drwxr-xr-x.   5 root root  1024 2009-08-08 21:32 boot
    drwx------.   3 root root  4096 2009-07-25 00:49 .dbus
    drwxr-xr-x   18 root root  4360 2009-08-10 08:59 dev
    drwxr-xr-x. 134 root root 12288 2009-08-10 13:41 etc
    drwxr-xr-x.   3 root root  4096 2009-07-25 00:50 home
    drwxr-xr-x.  17 root root 12288 2009-08-10 09:32 lib
    drwx------.   2 root root 16384 2009-07-24 23:19 lost+found
    drwxr-xr-x.   2 root root  4096 2009-07-25 21:08 media
    drwxr-xr-x.   2 root root  4096 2009-03-04 17:13 mnt
    drwxr-xr-x.   2 root root  4096 2009-03-04 17:13 opt
    dr-xr-xr-x  173 root root     0 2009-08-10 08:56 proc
    drwxr-x---.  13 root root  4096 2009-08-09 23:35 root
    drwxr-xr-x.   2 root root 12288 2009-08-10 09:32 sbin
    drwxr-xr-x.   2 root root  4096 2009-07-24 23:22 selinux
    drwxr-xr-x.   2 root root  4096 2009-03-04 17:13 srv
    drwxr-xr-x   12 root root     0 2009-08-10 08:56 sys
    drwxrwxrwt.  22 root root  4096 2009-08-10 10:28 tmp
    drwxr-xr-x.  13 root root  4096 2009-07-24 23:34 usr
    drwxr-xr-x.  26 root root  4096 2009-08-09 23:25 var
    
    Code:
    [root@FBox den]#[COLOR="Red"] vi /etc/fstab[/COLOR]
    
    #
    # /etc/fstab
    # Created by anaconda on Fri Jul 24 23:22:39 2009
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
    #
    UUID=30a9149b-8e4b-4b37-9520-383100a39703 /boot                   ext3    defaults        1 2
    /dev/mapper/vg_fbox-System /                       ext4    defaults,usrquota,grpquota        1 1
    /dev/mapper/vg_fbox-Swap swap                   swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  defaults        0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    
    Code:
    [root@FBox den]#[COLOR="Red"] fdisk -l[/COLOR]
    
    Disk /dev/sda: 80.0 GB, 80000000000 bytes
    255 heads, 63 sectors/track, 9726 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x4c774c76
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1          26      204800   83  Linux
    Partition 1 does not end on cylinder boundary.
    /dev/sda2              26        6016    48115712   8e  Linux LVM
    /dev/sda3            6016        9726    29802131    c  W95 FAT32 (LBA)
    
    Disk /dev/sdb: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00092007
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        4865    39078081    7  HPFS/NTFS
    
    Disk /dev/dm-0: 1073 MB, 1073741824 bytes
    255 heads, 63 sectors/track, 130 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/dm-0 doesn't contain a valid partition table
    
    Disk /dev/dm-1: 48.1 GB, 48192552960 bytes
    255 heads, 63 sectors/track, 5859 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/dm-1 doesn't contain a valid partition table
    
     
  2. falko

    falko Super Moderator

    Have you tried with /quota.user and /quota.group instead of /aquota.user and /aquota.group?
     
  3. cbj4074

    cbj4074 HowtoForge Supporter

    I realize that it's been awhile, but this topic is still relevant. I'm fiddling with quota and quotatool on Ubuntu 12.04.1 LTS and am running into the same problem.

    Steps to reproduce (is bears mention that I'm testing this in VirtualBox):

    1.) Install quota and quotatool.

    Code:
    # apt-get install quota quotatool
    
    2.) Modify /etc/fstab to contain appropriate quota/mount information.

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    nodev,noexec,nosuid 0       0
    /dev/mapper/ubuntu12-root /               ext4    errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0       1
    # /boot was on /dev/sda1 during installation
    UUID=ab42ed0f-4a35-424c-b031-75ca34898c6b /boot           ext2    defaults        0       2
    /dev/mapper/ubuntu12-swap_1 none            swap    sw              0       0
    
    3.) Enable quota.

    Code:
    # touch /aquota.user /aquota.group
    # chmod 600 /aquota.*
    # mount -o remount /
    # quotacheck -avugm
    quotacheck: WARNING -  Quotafile //aquota.user was probably truncated. Cannot save quota settings...
    quotacheck: WARNING -  Quotafile //aquota.group was probably truncated. Cannot save quota settings...
    # quotaon -avug
    quotaon: Cannot find quota file on / [/dev/mapper/ubuntu12-root] to turn quotas on/off.
    quotaon: Cannot find quota file on / [/dev/mapper/ubuntu12-root] to turn quotas on/off.
    
    I tried your suggestion, Falko, using quota.group and quota.user, but the result doesn't seem to change.

    I noticed also that the letter "j" appears in my /etc/fstab line, e.g., "usrjquota", which I assume is supposed to be there. I am working from a how-to that I compiled years ago, and I can't remember the significance, so maybe more recent software requires something different, and that's part of the issue.

    Any thoughts?
     
  4. cbj4074

    cbj4074 HowtoForge Supporter

    The solution to this problem is as described at http://forums.debian.net/viewtopic.php?f=5&t=59985 .

    Code:
    # modprobe quota_v2
    
    Check if the module was loaded (no point in proceeding if not):

    Code:
    # lsmod | grep quota
    quota_v2               13402  2
    quota_tree             18351  1 quota_v2
    
    Add quota to module configuration:

    Code:
    # echo 'quota_v2' >> /etc/modules
    
    Delete the files created previously (/aquota.group and /aquota.user ):

    Code:
    # rm /aquota.user /aquota.group
    
    (The next command will re-create those files with the correct permissions and ownership.)

    Check quotas:

    Code:
    # quotacheck -avugm
    
    Enable quotas:

    Code:
    # quotaon -avug
    
    Thanks to http://forums.debian.net user "pabloncho" for the solution!
     

Share This Page