Problems after upgrading ISPConfig3 3.0.2 to 3.0.3

Discussion in 'Installation/Configuration' started by pjoseph, Sep 7, 2011.

  1. pjoseph

    pjoseph New Member


    First, I am linux literate; my preferred flavors are Ubuntu Server and Xubuntu Desktop.

    I first installed ISPConfig3 about 6 months ago. I purchased a copy of the manual and found two of the most through tutorials. While comparing all three, I successfully installed a multi-server setup.

    • A - Master: Web, DNS and Database
    • B - Slave: Mail, DNS and Database
    • C - Slave: DNS and Database
    • D - Slave: File Server

    This past week I ran on D, C, B, and A. All worked smooth. Then, I had the issue of swapping out a UPS. All were shutdown fine. On reboot, A and C are still perfect; B and D are sick.

    I have retraced steps, viewed logs, and tested a number of scenerios. Now, I am baffled, and frustrated. I would just like to get B and D back in operation.

    I finally decided that I should backup, and fresh install. I have, but in restoring data I feel I have only made things worse.

    I would like a suggestion on the best way to get there from someone whose has already had their share of being bested by a computer.

    At current, B will accept ssh connections, but every 30 seconds, it will go to sleep for 30 seconds, and then back again. D will not accept ssh connections until I restart ssh, and then is good for about two minutes, then it dies. A and C are on the same network, and my ssh connections are all from my desktop. Neither has any issue.

    My most recent update was an attempt to make sure passwords were all correct. I downloaded a copy of 3.0.3 and ran update.php. Which dies with
    PHP Notice:  Uninitialized string offset: 0 in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
    PHP Fatal error:  Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
    I read a comment by Till that the mysql password might need to be corrected. I have checked
    and found it to be correct. I also tested it via cli and was able to mysql prompt.

    Unless, someone can give me a better solution, I assume that I am to reinstall Ubuntu Server, then install ISPConfig# 3.0.3, and finally restore my data. As I have already done this, does anyone have any trick or things that I need to be on the look out for?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I think that a reinstall is not the solution for that. Please edit the root crontab by running "crontab -e" and comment out the cronjob by adding a # in front. Then wait a few minutes and check if the ssh problem is solved.

    Regarding the update you did, how did you install it? Did you install it on the shell by executing the script or did you install it trough the ispconfig interface?

Share This Page