Problems after upgrade of php and ispconfig 3

Discussion in 'General' started by stigge2000, Apr 14, 2011.

  1. stigge2000

    stigge2000 Member

    Hello everybody!

    I have a very strange problem right now... i guess it all started
    when I tried to upgrade the php to version 5.3.x and i had to unistall
    the php-mhash. But to do this i had to uninstall phpmyadmin first and re-install it later... and redo the changes in the perfect setup guide (cookies -> http)... anyway I also updated to the latest version of ispconfig 3.

    Symtoms:
    1) Can't connect via FTP, it accepts my login but refuses to download the file/folder list and gives me a timeout message.
    2) No one of the sites i have work, they all show the default ispconfig "welcome to your website" file.

    I dont think its a DNS problem, coz the mail works on all accounts... but I just cant seem to figure out whats wrong... plz help.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Enable logging in pure-ftpd and then check the errors in the syslog file.
    2) Login to ispconfig, go to system > server IP, select a ip and disable the "namevirtulahost" checkbox and save. Then enable the checkbox again and save. Wait a few minutes to see if the sites work again.
     
  3. stigge2000

    stigge2000 Member

    Thanks... but no change, and the syslog only says:
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive transfers in your FTP client?
     
  5. stigge2000

    stigge2000 Member

    Hmm... seems like ACTIVE works, and all my files are there :) great!
    But when i try to visit the site I still get the defaule ISPCONFIG page.. any idea?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the default index.html page of the website.
     
  7. stigge2000

    stigge2000 Member

    lol... i wish i could, but it's not there
     
  8. ncoc.nl

    ncoc.nl Member

    Same problem

    Hi everyone,

    I have the same problem, hosting around 13 sites and all of them are pointing to the default website, also the redirectors (subdomains) are pointing to the default website/ipaddres

    In the first place i did a update of the OS (debian 5.0.x)

    >> Update status from of the other ISP config server
    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following packages will be upgraded:
    dhcp3-client dhcp3-common
    2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Inst dhcp3-client [3.1.1-6+lenny4] (3.1.1-6+lenny5 Debian-Security:5.0/oldstable) []
    Inst dhcp3-common [3.1.1-6+lenny4] (3.1.1-6+lenny5 Debian-Security:5.0/oldstable)
    Conf dhcp3-common (3.1.1-6+lenny5 Debian-Security:5.0/oldstable)
    Conf dhcp3-client (3.1.1-6+lenny5 Debian-Security:5.0/oldstable)
    ---

    When finished I did a reboot and afterwards the update of ISPConfig to version 3.0.3.3 (The version installed was 3.0.3.2)

    The update ran without problems but after the reboot (I always do when updating) the problem occurs, I do not have the FTP problems mentioned above.

    It looks like the Virtual Host file is not loaded.

    I Have 2 other servers and I don't want to run into the same problems.
    Any suggestions?

    Ronald

    [edit]
    I found this in /var/log/ispconfig/cron.log:

    [Fri Apr 15 14:19:10 2011] [warn] VirtualHost 10.150.11.40:80 overlaps with VirtualHost 10.150.11.40:80, the first has precedence, perhaps you need a NameVirtualHost directive
     
    Last edited: Apr 15, 2011
  9. ncoc.nl

    ncoc.nl Member

    Problem solved (for me)

    What I did:

    I opened the 1st domain in the list: ISPconfig->Sites->Website and changed the PHP option from CGI to Fast-CGI, saved and the problems are gone!
    It also keeps working with the option back to CGI.

    However, it works fine now, the only question is: what caused the problem and why is this the (or a) solution???

    Does anybody have an answer?

    Ronald
     
  10. stigge2000

    stigge2000 Member

    I amso tried that now, but no change at all... i can even go to system/server ip config and disable the whole ip... no change :(
     
  11. stigge2000

    stigge2000 Member

    can someone post their httpd.conf file or some other relevant config file, i think i haveto start all over and go trough them all line by line to see where it fails... time is running out :(
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you selected * or the IP address in the websites? If you selected *, try to use the IP instaed. be aware that * and IP can not be mixed on a server.
     
  13. stigge2000

    stigge2000 Member

    yes tried that too... no change
    i have about 80 sites hosted right now... all of them are showing the same page and my phone are starting to bug me so i pulled the plug for now
     
  14. ncoc.nl

    ncoc.nl Member

    Till, that can be a solution, my websites are all on the IP, not on the *

    regarding the httpd.conf, it's empty, in the apache.conf are these lines:

    # Include module configuration:
    Include /etc/apache2/mods-enabled/*.load
    Include /etc/apache2/mods-enabled/*.conf

    # Include all the user configurations:
    Include /etc/apache2/httpd.conf

    # Include ports listing
    Include /etc/apache2/ports.conf

    can you take a look if they are there?

    Ronald
     
  15. stigge2000

    stigge2000 Member

    HEY!!! Suddently right now it started to work... all of them work now... WTH is going on? out of the blue.. hope it stays like this :) maybe it was the IP trick Till talked about


    THANKS!
     
  16. ncoc.nl

    ncoc.nl Member

    Glad to hear it's working now!

    Changing the config can take a while...

    Ronald
     

Share This Page