Problems after updating from 3.0.5.4p8

Discussion in 'ISPConfig 3 Priority Support' started by biforme, Jun 26, 2018.

  1. biforme

    biforme New Member HowtoForge Supporter

    After updating the master from version 3.0.5.4p8 to 3.1.12 no action is performed on the web servers in a multiserver setup.
    How can I restore the working version on the master?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you update the slaves already? All servers in a multiserver setup must use the same ISPConfig version. If the versions are different, then updates will stop until you update the other servers.
     
  3. biforme

    biforme New Member HowtoForge Supporter

    Hi Till,
    yes the slave and master have the same version.
    In attachment the jobqueue
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. biforme

    biforme New Member HowtoForge Supporter

    The result in DEBUG mode on master:

    Code:
    26.06.2018-08:45 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    26.06.2018-08:45 - DEBUG - Found 2 changes, starting update process.
    26.06.2018-08:45 - DEBUG - Calling function 'server_ip' from plugin 'apache2_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Writing the conf file: /etc/apache2/sites-available/ispconfig.conf
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'apps_vhost_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'network_settings_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Network configuration disabled in server settings.
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'postfix_server_plugin' raised by event 'server_update'.
    postfix/postfix-script: refreshing the Postfix mail system
    26.06.2018-08:45 - DEBUG - Processed datalog_id 9307
    26.06.2018-08:45 - DEBUG - Calling function 'server_ip' from plugin 'apache2_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Writing the conf file: /etc/apache2/sites-available/ispconfig.conf
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'apps_vhost_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'network_settings_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Network configuration disabled in server settings.
    26.06.2018-08:45 - DEBUG - Calling function 'update' from plugin 'postfix_server_plugin' raised by event 'server_update'.
    26.06.2018-08:45 - DEBUG - Processed datalog_id 9308
    26.06.2018-08:45 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    26.06.2018-08:45 - DEBUG - Restarting httpd: /etc/init.d/apache2 restart
    26.06.2018-08:45 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
    DEBUG mode on slave:
    Code:
    26.06.2018-08:41 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    26.06.2018-08:41 - DEBUG - Info: PHP.ini changed: /etc/php5/apache2/php.ini, mode mod vers .
    26.06.2018-08:41 - DEBUG - Calling function 'php_ini_changed' from plugin 'apache2_plugin' raised by action 'php_ini_changed'.
    26.06.2018-08:41 - DEBUG - Info: No webs affected by php.ini change.
    26.06.2018-08:41 - DEBUG - Info: PHP.ini changed: /etc/php5/cgi/php.ini, mode  vers .
    26.06.2018-08:41 - DEBUG - Calling function 'php_ini_changed' from plugin 'apache2_plugin' raised by action 'php_ini_changed'.
    26.06.2018-08:41 - DEBUG - Info: No webs affected by php.ini change.
    26.06.2018-08:41 - DEBUG - Info: PHP.ini changed: /etc/php5/cgi/php.ini, mode fast-cgi vers .
    26.06.2018-08:41 - DEBUG - Calling function 'php_ini_changed' from plugin 'apache2_plugin' raised by action 'php_ini_changed'.
    26.06.2018-08:41 - DEBUG - Info: No webs affected by php.ini change.
    26.06.2018-08:41 - DEBUG - Info: PHP.ini changed: /opt/php55/lib/php.ini, mode fast-cgi vers /opt/php55/lib.
    26.06.2018-08:41 - DEBUG - Calling function 'php_ini_changed' from plugin 'apache2_plugin' raised by action 'php_ini_changed'.
    26.06.2018-08:41 - DEBUG - Info: No webs affected by php.ini change.
    26.06.2018-08:41 - DEBUG - Info: PHP.ini changed: /opt/php70/lib/php.ini, mode fast-cgi vers /opt/php70/lib.
    26.06.2018-08:41 - DEBUG - Calling function 'php_ini_changed' from plugin 'apache2_plugin' raised by action 'php_ini_changed'.
    26.06.2018-08:41 - DEBUG - Info: No webs affected by php.ini change.
    26.06.2018-08:41 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so there are no errors. The pending updates are still in the queue? If yes, are you really sure that the currently pending updates are for this slave where you run server.sh and not for a different slave server?
     
  7. biforme

    biforme New Member HowtoForge Supporter

    Yes, I'm sure.
    I will try another action in other server if you want.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Comment out the server.sh in root crontab by adding a # in front. Then do an action on the master for this slave and then run server.sh. This way, we can test (and see in the log) if the action is picked up properly by the slave.

    Just an idea, did you maybe remove a slave and the pending actions are somehow for this slave?
     
  9. biforme

    biforme New Member HowtoForge Supporter

    I don't have removed any slave.
    The only action I made is update ispconfig from 3.0.5.4p8 to the last 3.1.2.
    The result on slave:
    Code:
     /usr/local/ispconfig/server/server.sh
                
    
    26.06.2018-10:14 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    26.06.2018-10:14 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
    Result on master:
    Code:
     /usr/local/ispconfig/server/server.sh
                
    26.06.2018-10:20 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    26.06.2018-10:20 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    
    Problems communicating with mysql?
     
  10. biforme

    biforme New Member HowtoForge Supporter

    The servers are in DEBUG mode.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You are sure that you disabled the server.sh cronjob in root crontab before you made the change on the master for this slave? Otherwise, the change might have been applied by the cronjob already so it will not show up in the debug output anymore.
     
  12. biforme

    biforme New Member HowtoForge Supporter

    Yes Till, the cronjob is disabled in master and slave.
    In other one slave the creation of website working fine.
    I don't know why in this server is not working. :-/
    I can try to re-update ispconfig? What do you think?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats an important information, currebntly there is a problem on one slave while an other wone is working fine? So we can concentrate our efforts on this one slave as the master must be ok in this case, otherwise the other slave won't work with that master too.

    I don't think that this will help as the slave works flawlessly (locally) according to the debug log. What we have to do is to find out why it does not pick up changes from master. Please take a look in the file /usr/local/ispconfig/server/lib/config.inc.php, the relevant part is this section:

    Code:
    $conf['dbmaster_type']   = 'mysql';
    $conf['dbmaster_host']   = '{mysql_master_server_host}';
    $conf['dbmaster_port']   = '{mysql_master_server_port}';
    $conf['dbmaster_database']  = '{mysql_master_server_database}';
    $conf['dbmaster_user']   = '{mysql_master_server_ispconfig_user}';
    $conf['dbmaster_password']  = '{mysql_master_server_ispconfig_password}';
    $conf['dbmaster_new_link']   = false;
    $conf['dbmaster_client_flags']  = 0;
    my example has some placeholders. Compare it with the same section of the working slave (the username and password should be different, but the general setup should be the same).
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    In case that the master server part on the failing slave looks strange or incorrect, then you can find a copy of the former config.inc.php file under /var/backup/ispconfig..... The config.inc.php file from 3.0.5.4p8 should work with 3.1.12, so you can give it a test to replace the config file with the one from the backup.
     
  15. biforme

    biforme New Member HowtoForge Supporter

    The setup is the same. :-/
    I compared the files from backup.
    Is possible to create another mysql user for this slave?
     
  16. biforme

    biforme New Member HowtoForge Supporter

    I tried access with the data on the file but mysql rejects the connection.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    You should not create another mysql user for the slave, instead try to correct the existing one. The best is to use the phpmyadmin user editor for this as the user permission is split on different tables.
     
  18. biforme

    biforme New Member HowtoForge Supporter

    I tried to correct the password, but the user still can not log in.
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    The user exists twice, once with the IP and once with the hostname. Did you edit both? Is the IP for the user with the IP correct?
     
  20. biforme

    biforme New Member HowtoForge Supporter

    Ok, I have changed password and now I can login on mysql:
    Code:
    MySQL [dbispconfig]> SHOW TABLES;
    +------------------------+
    | Tables_in_dbispconfig  |
    +------------------------+
    | aps_instances          |
    | aps_instances_settings |
    | mail_backup            |
    | mail_traffic           |
    | monitor_data           |
    | server                 |
    | software_update_inst   |
    | sys_datalog            |
    | sys_group              |
    | sys_log                |
    | sys_remoteaction       |
    | web_backup             |
    | web_domain             |
    | web_traffic            |
    +------------------------+
    14 rows in set (0.01 sec)
    
    However, I can not create websites.
     

Share This Page