Problems after update to 2.2.10

Discussion in 'Installation/Configuration' started by Jorem, Feb 21, 2007.

  1. Jorem

    Jorem New Member

    I have a strange problem after updating to 2.2.10.

    Since I updated ISPConfig doesn't make virtusertables in postfix and Vhosts in Apache anymore :(.

    Yesterday before the update I added an account and everything worked great.

    group and passwd files are created. I can login to webmail. Outlook works "great", except that the account can't receive mail offcourse because there is no virtusertable in postfix.

    I updated to php5 a few days ago. And I have safe mode active on a few accounts. Maybe that is the reason for the Vhosts problem?

    For safemode to work you have comment out the AddType line in the php.conf, I also did this in the php.conf for php5. But maybe that isn't working. How can I check the php5 config with apache to see if that is working allright. (had some Vhost problems before, and had to do with php safe mode problems then).

    Config php4:
    LoadModule php4_module modules/
    # AddType application/x-httpd-php .php
    # AddType application/x-httpd-php-source .phps
    DirectoryIndex index.php

    Config php5:
    LoadModule php5_module modules/
    AddHandler php5-script .php
    # AddType text/html .php
    DirectoryIndex index.php
    # AddType application/x-httpd-php-source .phps
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at the ISPConfig logfile for errors:


    Do you have copies of the file with a recent date appended in the same directory?
  3. Jorem

    Jorem New Member

    This is the only warning in the ispconfig.log:

    21.02.2007 - 16:14:12 => WARN - maildirmake /home/www/web62/user/testsite/Maildir &> /dev/null, Line 106: WARNING: could not maildirmake /home/www/web62/user/testsite/Maildir &> /dev/null

    But when I look on the server the Maildir folder has been created.

    I have no other Vhost files in the folder. Tha last time the file was updated was 00.30 this morning/night. Just before the update. Now after the update nothing happens to the file when creating a new web.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run these commands as root user:

    rm -f /home/admispconfig/ispconfig/.run
    rm -f /home/admispconfig/ispconfig/.run2
    rm -f /root/ispconfig/.ispconfig_lock

    and then:

    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    do you get any error messages?
  5. Jorem

    Jorem New Member

    This is the error that I get.

    sh: httpd: command not found
    ls: /conf.d/*.conf: Onbekend bestand of map
    sh: httpd: command not found

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 2 bytes in /root/ispconfig/scripts/lib/classes/ispconfig_db_mysql.lib.php on line 135
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please replace the line "memory_limit = 16M" with "memory_limit = 64M" in the file /root/ispconfig/php/php.ini and try the above steps again.

    Please post the output of the following command too:

    which httpd
  7. Jorem

    Jorem New Member

    Command /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php:
    sh: httpd: command not found
    ls: /conf.d/*.conf: Onbekend bestand of map
    sh: httpd: command not found
    sh: postmap: command not found
    sh: httpd: command not found

    Command which httpd:
    /usr/bin/which: no httpd in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin)
    Last edited: Feb 21, 2007
  8. Jorem

    Jorem New Member

    To test the Vhosts I added another dummy domain. And no I see that there is a new Vhosts file is created but not accepted or how you say that.

    It has the name: Vhosts_ispconfig.conf_21-02-07_17-27-24
  9. till

    till Super Moderator Staff Member ISPConfig Developer

  10. Jorem

    Jorem New Member

    My mail is working again. For some reason it adds users to the virtusertables in Postfix again :).

    The only thing left is Vhosts now. I tried httpd -t allready but it sais httpd: command not found. Also apache2 -t gives the same result. (Apache runs now, and I can restart it without any errors. )
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    It seems that your path variable for the root user is not set correctly or do you use something like sudo?

    Please try:

    /usr/bin/httpd -t
  12. Jorem

    Jorem New Member

    I use CentOS 4.4 and use yum.

    This command worked: /usr/sbin/httpd -t
    Syntax OK

    In the apache logs I found this:
    [error] an unknown filter was not added: PHP

    This is posted every second 2 times.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

  14. Jorem

    Jorem New Member

    I did that and restarted ISPConfig and Apache. But still Vhosts are not created the way they should.

    The errors are also still there:
    [error] an unknown filter was not added: PHP

    Syntax is still OK

    Is there a way how I can check php. All the websites are running fine. But maybe there is something wrong there for creating Vhosts?
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You must change a setting in one of your websites so that the configuration file is rewritten.

    By the way, the filter error has nothing to do with the update and it also is not a real error as it has no impact on your setup. It's just a bit annoying because it fills up your error log.
  16. Jorem

    Jorem New Member

    I changed a setting. And a new Vhost file is created. But that error is still there. Because the new Vhost file is rejected and old one is active again.

    I noticed this after the update and in the Vhost directory there are files created from today. So maybe I have to look what is changed on this date to find the error.

    I will search in the forum for other Vhost problems and solutions and will try them. Hopefully I will find what is wrong with my setting.

    Mail is working again, and users are created, so that is great :). Just one thing to go.

    Thank you very much for your help Till.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    I linked to the solution to find the error earlier in this thread:

    1) Make a backup of the Vhost_ispconfig.conf file.
    2) Rename the latest Vhost_ispconfig.conf file which has a date appended to Vhost_ispconfig.conf
    3) Execute:

    /usr/sbin/httpd -t

    and post the error message here.
  18. Jorem

    Jorem New Member

    Yes I got an error.

    Syntax error on line 261 of /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf:
    Invalid command '.nl', perhaps mis-spelled or defined by a module not included in the server configuration

    I think that is the domain of a user with a lot of co-domains. I think that maybe he did something wrong with creating one.

    I will have a look at the co-domains and let you know where the problem was.
  19. Jorem

    Jorem New Member

    The problems was in the co-domains. One of my users added 300 co-domains this morning :( . After deleting all the newly added domains everything runs good again. No more co-domains for him :) .

    Thanks for your help Till. I learnt a lot today and I hope I can help a lot of other people on the forum again.
  20. Davide

    Davide New Member HowtoForge Supporter

    After upgrading from 2.2.8 to 2.2.10, I got *exactly* the same problem with /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    I put memory_limit=32M in /root/ispconfig/php/php.ini, and these problem dissapeared. I had also problems with the statistics of a reseller (the same error, but inside the control panel), and the problem only dissapeared when I restarted ISPconfig after changing the "memory_limit" value. After reading this thread, I now put a 64 M limit

    I think you should put at least "memory_limit=32M" on later releases. I have no changed anything but ISPConfig version upgrade, and all seemed to stop working (I saw myself restoring all the configuration from backup... ;) )

    Thank you !

Share This Page