Problems after adding a 4th site

Discussion in 'Installation/Configuration' started by GenNS, Jan 6, 2011.

  1. GenNS

    GenNS New Member

    Hi,

    We set up ISPConfig3 using the Ubuntu Perfect Server guide and have had three WordPress blogs running on with (mostly) no trouble.

    Today, I added a 4th site that I planned on putting WP on as well, but for some reason, when I go to the address of the site in question, rather than displaying the site's actual directory/site, it's displaying the "global" index.html in var/www rather than what's in var/www/clients/client4/web4/web

    I checked the enabled hosts file for this client in the apache2 directory and everything in there seems to be in order (I don't have much experience with Linux, but I compared it with one of the sites that's working fine, and it seemed to match up, other than the domain and client/web numbers)

    Any idea why this would happen or how to fix it?

    Thanks in advance if you can help...

    G
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that you selected for all websites on the server a IP address or * but do not mix * and IP in the website settings.
     
  3. GenNS

    GenNS New Member

    Thanks Till,

    They are all set to *

    (* is the only option I have...the actual IP address isn't listed)

    G
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ckeck if there are no typos in the domain name and that you selected auto subdomain www if you want to access the domain with domain.tld and www.domain.tld.

    If thats all ok, then you should check if there are any hanging apache processes which might cause apache to not load the new configuration. You can do that by stopping apache and then checking the "ps aux" output if there are still apache processes running.
     
  5. GenNS

    GenNS New Member

    There were no typos in the domain name (if there were, I don't think I would've even seen the generic index page, because the server wouldn't have answered the request at all), and the domain is blog.[domain].com so the subdomain thing really didn't apply.

    Also, I wasn't sure how to stop apache and check ps aux (over my very limited Linux knowledge), but I did reboot the server, and afterward, apache didn't even start.

    I tried starting it manually, and there was an AllowOverride command in one of the vhost files (for the 1st site) that shouldn't have been there. I edited it out, started apache manually, and then the 4th site was working as expected.

    So thanks for pointing me in the right direction. Not sure how that AllowOverride got there since I've never edited those files manually (nor would I even know what that does), but at least it's working now.

    Oh, also, WordPress (on all four sites) keeps telling me my .htaccess file isn't writable, and the WP auto-updater fails 100% of the time...once I add a new site through ISPConfig3, what do I need to do to make sure WP has all the permissions it needs to work properly, without chmod'ing everything to 777?

    Thanks again...
     
  6. Toucan

    Toucan New Member

    If the ns records point to your server then it will answer by serving the root index.

    Where are you dns records held? You will need a cname record for the subdomain.

    Word press should usually require suexec and fastcgi enabled to run without the need to change permissions too much.

    You can use chmod to change permissions of a file or chown to change the owner.

    To restart apache:
    /etc/init.d/apache2 restart

    Or stop or start

    I wouldn't edit the chose files yourself, ispconfig writes to these and keeps a copy of changes for it's records. If you change it yourself it will be out of sink.




     
  7. GenNS

    GenNS New Member

    Again, before I get more into it, let me just re-iterate that the blog started working properly after a server reboot.

    The DNS is external, and there's an A record for the blog.[domain].com record. Again, we checked it and no typos or anything.

    Both SuExec and FastCGI are set for the new blog, but I was unable to update blog files or upload content before setting permissions manually.

    We did CHOWN the folder hierarchy for the user, but it still didn't help.

    Is there a command to set permissions on a folder and all of its folder and file children so that I can just do it once when we set up a new account?

    Thanks for the apache restart/stop/start commands.

    We didn't edit the vhost file...that's why I was confused about how that line got in there.

    Thanks again,

    G
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no need for chowning any folders when you create a new website in ispconfig. Only in case that you upload content with the wrong user (e.g. root) instead of using the ftp account of the webiste may make it nescessary to chown the newly uploaded content.

    Beside that, ensure that you always enable the suexec checkbox in the website settings and that you use either php-cgi or php-fcgi as php mode when you run a cms system in that site that needs to write to the website folders.
     
  9. GenNS

    GenNS New Member

    Thanks Till,

    I'll have to make sure I set that next time we set one up, much appreciated.

    G
     
  10. GenNS

    GenNS New Member

    Hi again,

    Ok I just added another site / uploaded WordPress and this time I made sure that I checked the SuEXEC checkbox, and set PHP to Fast-CGI in the drop-down.

    However, the new WP installation is still reporting that the .htaccess file isn't writable, and I still can't upload any media through WordPress because it says it can't create new folders.

    (FYI the default permissions for the wp-content folder (and the other folders) is 755. If I manually change them to 775, it seems to work ok, but again, it seems that unless I go through and change ALL the permissions throughout the /web hierarchy, WP won't be able to download themes or plugins or do auto-updates)

    Still confused as to how to get this to work right...thanks in advance,

    G
     
    Last edited: Jan 7, 2011
  11. Toucan

    Toucan New Member

    I think you can change the permissions recursively by using -R after chmod. But, like Till said you don't normally need to change ownership or permissions if they were uploaded by a user created with Ispconfig.

    If you were to use the -R command that could mess with the entire CMS pre set permissions.

    Maybe it would help if you used the command:
    Code:
    ls -l
    from the CMS root and paste the results back here if you're still having troubles.
     
  12. GenNS

    GenNS New Member

    Ok, not really sure what I should be looking at here, but here are the results of ls -l in the CMS root for this newest client / site:

     

Share This Page