problemmoving wordpress site from apache to nginx

Discussion in 'Server Operation' started by PermaNoob, Nov 7, 2013.

  1. PermaNoob

    PermaNoob New Member

    Centos 6.4, nginx, ispconfig

    On the apache server, I had the wp-config.php file 1 directory above www.

    On the nginx server, wp-config.php is in the www directory (the directory above is owned by root, so can't put it there, and don't need to anyway.)

    However, the copied wordpress wants the file in the directory above www:

    File(/var/www/clients/client1/web2/wp-config.php) is not within the allowed path(s):

    wp-config is at /var/www/clients/client1/web2/www/wp-config.php , which is an allowed path, but something in the wordpress code is telling it to look 1 directory up (I always thought wordpress looked in the main directory AND 1 directory up)

    If a wordpress guru could tell me how to change that code, it would be much appreciated.

    Fresh installs of wordpress work fine and look in the correct /var/www/clients/client1/web2/www/ directory.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This error is often misleading and just means that wordpress cant find or read wp-config.php in /var/www/clients/client1/web2/www/. Check that the file wp-config.php is owned by the user and group of this website.
  3. PermaNoob

    PermaNoob New Member

    Thanks for the reply--yes, I uploaded the files as the local user so the user and group are correct.

    Btw, do the log and ssl directories have to be owned by root? If not, I could change the web2 ownership to the local user and then maybe I could put wp-config.php there and make it work.
  4. PermaNoob

    PermaNoob New Member

    still getting error 500

    Still having problems getting wordpress to work correctly. Anyone know a good guide for getting wordpress to work on nginx?
    Last edited: Nov 11, 2013
  5. PermaNoob

    PermaNoob New Member

    I found Falko's code for the Options tab for the site in ISPConfig:

    another version had partially worked, but this seemed to fix it for new installs. Then I got error 500 related to the mingle wordpress plugin on the site I was trying to copy. I went to the old installation and removed mingle, then re-copied the site and database and got it all working.

Share This Page