Probleme with vsFTPd

Discussion in 'Server Operation' started by ahmedbj, Jan 5, 2009.

  1. ahmedbj

    ahmedbj New Member

    Hello everybody
    I had installed vsFTPd and configure it for an anonymous use
    i had specified the default directory which vsftpd will try to change into after an anonymous login into /home/lftp and put some file (pdf,...)
    but when i try to connect from my browsers and try to download some file it does not work and show me this error '550 Failed to change directory' .
    for exemple when i tried to download 'cv.pdf' my ftp server consider it like a file and open it like a file that coutain other files,...
    can someone help me please.
    that's what contain my vsftpd.conf


    sorry for my bad english
  2. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    It looks like the file permissions for the pdf are wrong.

    Can you post the output of ls -l pdf cv.pdf?
  3. ahmedbj

    ahmedbj New Member

    that what gave me
    -rwx------ 1 ahmedbj ahmedbj 42129 2008-12-09 17:56 20081209_cv.pdf
    Yes it was a problem with permissions because wheni tried 775 it works
    so should i change the permission every time that i add a new file in the server, knowing that my ftp file have 775 permission?
    Last edited: Jan 7, 2009
  4. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    Ok, now I see what's happening. The folder /home/lftp needs to be owned by the same user that the vsftpd daemon is running as.
    When you created the pdf file it had the ownership of ahmedbj instead of the same account that vsftpd runs as. In this case you should change the permissions of the pdf back and then change the ownership to that of vsftpd.
    if you are adding new files to the folder then you should chown them to the vsftpd account. So copy all the new files into the folder and then use chown -R [user] to do the whole folder.
    Last edited: Jan 7, 2009
  5. ahmedbj

    ahmedbj New Member

    i have noticed that i can't have acces to the server until i get connexion in my computer, i don't that's normal because i'm working in the same station it should work even if i'm note connected?
    and i wonder if i can have anonymous and local access at the same time in the same server?
  6. archerjd

    archerjd ISPConfig Developer ISPConfig Developer

    vsftpd should run as a service, not when you are logged on.

    Now if you are talking about when you are connected to the internet, then yes you will have that kind of trouble. You must be connected to the internet in order to access vsftpd from another location.

    One other thing, if you are operating vsftpd with anonymous upload and download access inside an internal network then that is ok. Otherwise this configuration is very insecure. This means anyone can upload their stuff. :eek: are you sure you want that?:confused:
  7. ahmedbj

    ahmedbj New Member

    No the problem that i want to have access from the same station where vsftpd is installed but it does not work until i have internet.

    what can you tell me to do? because it's the first time that i have tried to configure vsftpd
    thank you

Share This Page