Probleme mit typo3

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Feb 19, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    Umgebung Debian Buster aktuell, ispconfig 3.1dev, typo3 aktuell 8.7.31
    Typo3 meldet memory_limit zu klein min 128M , memory_limit ist 256M
    Type 3 meldet /var/log/php_error.log not in basedir, ist aber eingetragen
    Habe php script mit php auf der Webseite, rufe ich das auf zeigt phpinfo für lokal und system die selben Werte PHP Version 7.3 memory_limit 256M, basedir ok
    rufe ich phpinfo aus der type3 Umgebung auf bekomme ich für lokal andere Werte so z.B. memory_limit 64M
    was mir auffällt im open_basedir (automatisch von ispconfig gesetzt steht u.a. /usr/share/php5, wir haben aber doch php 7.3, die typo3 8.7.* benötigt php 7 oder höher, was ja sein sollte. der Server ist nach perfect server tutorial von Till für debian buster installiert.
    Googel Suche bringt nichts.
    Die Website lief auf dem alten ispconfig3.1 server unter 7.6.24 mit debian stretch
    1A.
    Sorry aber ich häng da jetzt seit Stunden und es ist nicht das erste Mal, dass ich eine Typo3 Seite umgezogen oder aktualisiert hätte.
    Danke für jegliche Hilfe.

    Rainer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) A website should never log to /var/log/ folder, this folder should not be part of the open_basedir.
    2) You can set the memory Limit of a website in the php directives of the website, set there e.g.:

    memory_limit = 256M

    3) Ensure that you sue the right PHP mode, for Typo3 you should use PHP mode php-fpm and the suexec checkbox must be enabled.
     
  3. muekno

    muekno Member HowtoForge Supporter

    to 1) I added in case of the error message
    to 2) yes I now and i did this all the years, i copied all teh PHP settings from the old ispconfig entries
    to c) php-fpm seams to be the problem, I had fast.cgi, took that from the old running config
    changed to php-fpm, everything looks much better
    Thanks for help
    Rainer
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Makes not much sense for several reasons: every PHP runs under a different user, so different websites can't write there anyway plus you added a security hole by allowing all sites to read from that folder. If you want to write a php log, let it write to the private directory of that website.
     
  5. muekno

    muekno Member HowtoForge Supporter

    I changed the path and modified the PHP open basedir in ipsconfig website options still get
    <code>Uncaught TYPO3\CMS\Core\Error\Exception: PHP Warning: fopen(): open_basedir restriction in effect. File(/var/www/zen-works.de/log/php_error.log) is not within the allowed path(s):</code>
    php open basedir
    <code>/var/www/clients/client4/web58/web:/var/www/clients/client4/web58/private:/var/www/clients/client4/web58/tmp:/var/www/zen-works.de/web:/srv/www/zen-works.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom:/var/www/zen-works.de/log/php_error.log</code>
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The private directory not log directory, so the path has to be:

    /var/www/zen-works.de/private/php_error.log
     

Share This Page