Problemas with http and https

Discussion in 'ISPConfig 3 Priority Support' started by Gaston Girardi, Nov 29, 2019.

  1. Gaston Girardi

    Gaston Girardi New Member HowtoForge Supporter

    Hi, i'm having a problem with all my sites with SSL, i don't know when it starts but on Monday it was working fine. i've got SSL with Let's Encrypt, and i've got the setting in the following way:

    Website
    Auto subdomain: www
    SSL+LE SSL: [v]

    Tab: Redirect
    Type: No Redirect
    Path stays Empty
    SEO Redirect: www.domain.tld => domain.tld
    Rewrite HTTP to HTTPS: [v]

    In the DNS i've got the A records that Till coment in the following post:
    https://www.howtoforge.com/community/threads/solved-www-instead-of-https.81483/#post-386088

    Part of my DNS Zone:
    Code:
    A     c4pos.com.     xx.xx.xxx.xxx
    A     www     xx.xx.xxx.xxx
    
    but if you want to see one of the domins for example, c4pos.com it goes to the default web site, it doesn't do any redirect, but if you type it manually with the "s" https://c4pos.com, it goes to the right site, it is no redirecting any site and the certificates are on date.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check all websites to ensure all of them use either * in the ipv4 field or the IP address, take care that it is not a mix of * and IP on the server as this will cause wrong redirects.
     
    Gaston Girardi likes this.
  3. Gaston Girardi

    Gaston Girardi New Member HowtoForge Supporter

    Till thank you so much i check everything about the ssl but never that point, somebody create a domain and put the IP address of the server, you save me.

    By the way there's no possibility to fixed that the field, so it doesn't matter what people fill over there, there's always going to be fixed with an *
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    To avoid that someone uses the IP accidently, you can remove the IP under System > server IP (as long as you don't have automatic network configuration enabled under system > server config, but that's off by default and should be kept disabled).
     
    ahrasis likes this.

Share This Page